SOGo | BTS

Dependency Graph View Issue ] Relation Graph ] Vertical ]
related to child of duplicate of


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002256SOGoBackend Generalpublic2013-02-26 13:572013-04-05 14:39
Reportermal 
Assigned Tojraby 
PrioritynormalSeverityblockReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.0.4b 
Target VersionFixed in Version2.0.5 
Summary0002256: SOGo does not release LDAP connections
DescriptionHi,

SOGo does not free established TCP connections to the LDAP server causing later lookups to fail. This happens frequently about every 2 days now. I'm not sure what triggers it.
3.0.0.3 in lsof-i_tcp-389 is the ip of teh SOGo server.
I have attached the sogo.log part that i think is interesting.

Please let me know if u need more info.
TagsNo tags attached.
Attached Fileslog file icon sogo.log [^] (49,620 bytes) 2013-02-26 13:57
? file icon lsof-i_tcp-389 [^] (112,794 bytes) 2013-02-26 13:58 [Show Content]
? file icon sogo.log.28 [^] (765,923 bytes) 2013-02-28 09:50

-  Notes
(0005397)
jraby (viewer)
2013-02-27 08:36

By looking at the log you attached, I'd say that it is related to the jpegphoto handling, but it doesn't leak here on my test setup.

It would be really helpful if you could try to isolate the problem or find a way to reproduce it with clear steps.

Also, could you set LDAPDebugEnabled to YES in your config and upload a new logs?

Which distro are you running?
(0005400)
mal (reporter)
2013-02-28 09:53

Hi,

it happend again today. I added another sogo.log with LDAPDebugEnabled YES.
I cannot reproduce it really. Today it seemed to happen after I wanted to look at the Addressbook. (login -> click on adressbook link) SOGo then did not respond anymore.

The server runs Ubuntu 12.04 with package version 2.0.4b-1.
(0005402)
jraby (viewer)
2013-03-01 10:17

Can you post the apache access log for the same time period?

I find it strange that there are that many bind attempts in the same second from cn=read-all,dc=foobar,dc=de.

Can you send a non-obfuscated whole log file to jraby@inverse.ca ?
The whole config would be appreciated too, since I cannot reproduce this issue, it is all guess work and without the 'real info' I won't be able to help you much.

Thanks.
(0005403)
mal (reporter)
2013-03-01 10:55

I just sent the email.
(0005404)
jraby (viewer)
2013-03-01 16:28

Fixed: https://github.com/inverse-inc/sogo/commit/f1846191d5d47717e7c5dff710e265e21c8f0fe2 [^]
(0005405)
mal (reporter)
2013-03-01 16:38

Thank you very much.

- Issue History
Date Modified Username Field Change
2013-02-26 13:57 mal New Issue
2013-02-26 13:57 mal File Added: sogo.log
2013-02-26 13:58 mal File Added: lsof-i_tcp-389
2013-02-27 08:27 jraby Status new => assigned
2013-02-27 08:27 jraby Assigned To => jraby
2013-02-27 08:36 jraby Note Added: 0005397
2013-02-28 09:50 mal File Added: sogo.log.28
2013-02-28 09:53 mal Note Added: 0005400
2013-03-01 10:17 jraby Note Added: 0005402
2013-03-01 10:55 mal Note Added: 0005403
2013-03-01 16:28 jraby Note Added: 0005404
2013-03-01 16:38 mal Note Added: 0005405
2013-04-05 14:39 ludovic Status assigned => closed
2013-04-05 14:39 ludovic Resolution open => fixed
2013-04-05 14:39 ludovic Fixed in Version => 2.0.5


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker