SOGo | BTS

Dependency Graph View Issue ] Relation Graph ] Vertical ]
related to child of duplicate of


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002732SOGoOpenChange backendpublic2014-04-23 21:362015-05-25 15:46
ReporterPegasus 
Assigned Toludovic 
PriorityhighSeverityminorReproducibilityhave not tried
StatusresolvedResolutionsuspended 
Platform[Server] LinuxOSDebianOS Version7 (Wheezy)
Product Version2.2.3 
Target VersionFixed in Version 
Summary0002732: NTLMAuthHandler.py is missing, can't start ocsmanager
DescriptionAfter configuring ocsmanager.ini (which should be mentioned in the Native Outlook document, BTW) and trying to start it, I get:
ImportError: No module named openchange.web.auth.NTLMAuthHandler

...which according to this: http://tracker.openchange.org/boards/3/topics/238 [^] means that the file NTLMAuthHandler.py is missing and indeed it is as I cannot find it on my system anywhere. So I downloaded it from http://tracker.openchange.org/projects/openchange/repository/revisions/master/changes/python/openchange/web/auth/NTLMAuthHandler.py [^] and put it in '/usr/lib/python2.7/dist-packages/openchange/web/auth' (I had to create the 'auth' subdir.) But now trying to start openchange-ocsmanager gives:

  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 584, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: Not Found: pytz-2012c (did you run python setup.py develop?)
Additional InformationIncase it's relevant, I have my Samba 4 DC on a separate machine from my SOGo installation. So the DC machine has the packages samba, openchangeserver and openchangeproxy installed from Debian Jesse (2.0-4 currently) and the SOGo machine has sogo, sogo-openchange, openchange-ocsmanager and openchange-rpcproxy installed from the Inverse repo on Debian Wheezy (2.0.r3669-1~inverse1.0)
TagsNo tags attached.
Attached Files

-  Notes
(0006956)
Pegasus (reporter)
2014-04-23 21:46

Apparently it is relevant... after installing openchangeserver and its dependencies, NTLMAuthHandler.py appeared. The thing is, I want Samba to run on a separate system. How can I do that?
User avatar (0008531)
ludovic (administrator)
2015-05-25 15:46

Retry with v2.3. Reopen if necessary.

- Issue History
Date Modified Username Field Change
2014-04-23 21:36 Pegasus New Issue
2014-04-23 21:46 Pegasus Note Added: 0006956
2015-05-25 15:46 ludovic Note Added: 0008531
2015-05-25 15:46 ludovic Status new => resolved
2015-05-25 15:46 ludovic Resolution open => suspended
2015-05-25 15:46 ludovic Assigned To => ludovic


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker