SOGo | BTS

Relationship Graph View Issue ] Dependency Graph ]
related to child of duplicate of


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000478SOGoWeb Mailpublic2010-03-08 16:462013-09-27 10:48
Reporteroleksa 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionsuspended 
PlatformOSOS Version
Product Version1.2.0 
Target VersionFixed in Version 
Summary0000478: Mail folder cannot be shared
DescriptionWhile trying to share a mail folder of office@mail1.net - INBOX in web ui for another user office@mail2.net I faced with a problem that it is impossible to assign a user and his rights to the shared folder. They are not just saving

127.0.0.1 - - [08/Mar/2010:23:42:17 GMT] "GET /SOGo/so/office@mail1.net/Contacts/userFolders HTTP/1.1" 200 5702/0 0.174 16572 65% 0
2010-03-08 23:42:58.379 sogod[15430] WARNING(-[NSNull(misc) count]): called NSNull -count (returns 0) !!!
127.0.0.1 - - [08/Mar/2010:23:42:58 GMT] "GET /SOGo/so/office@mail1.net/Contacts/userFolders HTTP/1.1" 200 5702/0 0.173 16572 65% 0
127.0.0.1 - - [08/Mar/2010:23:43:02 GMT] "POST /SOGo/so/office@mail1.net/usersSearch?search=office HTTP/1.1" 200 63/0 0.190 - - 0
Mar 08 23:43:05 sogod: SOGo watchdog [15430]: <0x0xa2a8998[NGSendMail]> wrote 1, length 1113
127.0.0.1 - - [08/Mar/2010:23:43:05 GMT] "POST /SOGo/so/office@mail1.net/Mail/office_A_mail1_D_net_A_mail1_D_net/folderINBOX/addUserInAcls?uid=office@mail2.net HTTP/1.1" 204 0/0 0.270 - - 0

When selecting a user for sharing and clicking `Add` the pop-up window doesn't disappear.
TagsNo tags attached.
Attached Files

-  Notes
(0000691)
oleksa (reporter)
2010-03-08 17:09

Also I see the row:

2010-03-09 00:06:14.032 sogod[23111] Scanner initialised with nil string

Sometimes the sogod restarts.

I assume that the backend cannot state a user :-(
User avatar (0001245)
ludovic (administrator)
2010-07-27 13:04

Are you still able to reproduce this with 1.3.0?
(0001424)
oleksa (reporter)
2010-09-11 12:09

Nothing changed. I still cannot add a new user, but I see `Any authenticated user`. Despite this I cannot see this folder under another account :-(
User avatar (0001447)
ludovic (administrator)
2010-09-14 14:54

Which IMAP Server are you using? Have you tried to set

SOGoIMAPAclStyle to "rfc2086" or "rfc4314" ?
(0001515)
oleksa (reporter)
2010-09-26 07:01
edited on: 2010-09-26 19:04

Hi, Ludovic.

Yes, I tried at the moment. But nothing changed.

(0001657)
oleksa (reporter)
2010-10-26 15:04

Sorry, guys, is the issue solved, or no?
User avatar (0006059)
ludovic (administrator)
2013-09-27 10:48

Very old ticket - reopen if necessary by providing a tcpflow trace between SOGo and you IMAP server.

- Issue History
Date Modified Username Field Change
2010-03-08 16:46 oleksa New Issue
2010-03-08 17:09 oleksa Note Added: 0000691
2010-07-27 13:04 ludovic Note Added: 0001245
2010-09-11 12:09 oleksa Note Added: 0001424
2010-09-14 14:54 ludovic Note Added: 0001447
2010-09-26 07:01 oleksa Note Added: 0001515
2010-09-26 19:04 oleksa Note Edited: 0001515
2010-10-26 15:04 oleksa Note Added: 0001657
2013-09-27 10:48 ludovic Note Added: 0006059
2013-09-27 10:48 ludovic Status new => closed
2013-09-27 10:48 ludovic Resolution open => suspended


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker