SOGo - BTS - SOGo
View Issue Details
0004200SOGoWeb Preferencespublic2017-06-16 05:592017-06-18 12:55
poly 
francis 
normalminoralways
resolvedfixed 
3.2.9 
3.2.10 
0004200: Can't create a specific filter in Webinterface

Even after filling all blanks out, the OK-Button does not get activated.
If you have the "match all messages" rule selected.
1. start to create a filters
2. after the form pops up, in rules select "match all messages"
3. add a condition
4. now you can not click OK to save the changes

Complete configuration is shown in my image.
I found a work around for my problem. I can create filters now, but for the specific configuration, like in my image, I need to do the following:

1. define a rule with a condition
2. add a condition
3. select the rule without any conditions(all messages), then OK gets activated
4. add actions

Now I can press OK and activate the filter.
But this is still a strange behaviour, it looks like it is checking if there are any conditions even if there are not needed.

This is also related to mailcow: https://github.com/mailcow/mailcow-dockerized/issues/348 [^]
configuration, sogo
png Screenshot_20170611_140340.png (67,250) 2017-06-16 05:59
https://sogo.nu/bugs/file_download.php?file_id=1812&type=bug
png
Issue History
2017-06-16 05:59polyNew Issue
2017-06-16 05:59polyFile Added: Screenshot_20170611_140340.png
2017-06-16 06:01polyTag Attached: configuration
2017-06-16 06:01polyTag Attached: sogo
2017-06-16 16:55francisChangeset attached => sogo master 6c654e0f
2017-06-16 16:55francisAssigned To => francis
2017-06-16 16:55francisResolutionopen => fixed
2017-06-18 12:55francisStatusnew => resolved
2017-06-18 12:55francisFixed in Version => 3.2.10

There are no notes attached to this issue.