SOGo | BTS

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001019SOGoWeb Mailpublic2010-12-01 09:222014-09-04 02:45
Reporterpaubry 
Assigned Toludovic 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.3.4 
Target VersionFixed in Version1.3.12 
Summary0001019: check sub-folders automatically
DescriptionFolders are not checked until they are opened from the session. This is painful for users with an intensive usage of sieve filters, and we can not reasonnably ask them to open their sub-folders at the beginning of every session.
Additional InformationSolutions:
1. check any sub-folder (quite noisy but already done by heavy clients such as Thunderbird)
2. allow users to mark sub-folders for periodical checking (as it is done in Horde)
PA
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of 0000965closedludovic 0000522: Sub-folders do not show unread message count 
has duplicate 0001236resolvedludovic When you open the webmail, the unread messages inside the folders are not shown. 
related to 0002915new Bug 0001019 again 

-  Notes
(0001912)
alessio (reporter)
2010-12-02 04:35

Allow users to mark sub-folders for periodical checking is a good idea
User avatar (0002943)
Christian Mack (developer)
2011-10-24 08:04

Duplicate of 0000965 ?
(0003160)
mathis (reporter)
2011-12-14 03:49

See also http://www.sogo.nu/bugs/view.php?id=1289 [^]

This is a real problem for all who use Sieve to pre-sort their mails.

I propose the function to check all folders for new mail (instead of just the INBOX) should be implemented optionally (disabled by default), so anyone who enables it knows that he will generate more load on the IMAP server.
(0003164)
alessio (reporter)
2011-12-14 11:56

I have 15 sub-folders (not too many) and it's a problem. I must click 15 times every login on webinterface, very unhandy
People with 20/30 folders are annoyed
User avatar (0003206)
ludovic (administrator)
2011-12-29 15:28

Fixed - see: http://mtn.inverse.ca/revision/diff/a4f6c377a41454eb21ed5b253cb7d07fc2c1a55e/with/3c7106a946b0d9786d46c4f0c0a7e5bc1e5f8684 [^]

We now check for new mails on all folders that have Sieve rules defined to move mails into.

- Issue History
Date Modified Username Field Change
2010-12-01 09:22 paubry New Issue
2010-12-01 17:10 ludovic Severity block => feature
2010-12-02 04:35 alessio Note Added: 0001912
2011-10-24 08:04 Christian Mack Note Added: 0002943
2011-10-24 15:14 francis Relationship added has duplicate 0001236
2011-10-31 09:15 francis Relationship added duplicate of 0000965
2011-12-14 03:49 mathis Note Added: 0003160
2011-12-14 11:56 alessio Note Added: 0003164
2011-12-29 15:28 ludovic Note Added: 0003206
2011-12-29 15:28 ludovic Status new => resolved
2011-12-29 15:28 ludovic Fixed in Version => 1.3.12
2011-12-29 15:28 ludovic Resolution open => fixed
2011-12-29 15:28 ludovic Assigned To => ludovic
2011-12-29 15:29 ludovic Status resolved => closed
2014-09-04 02:45 Christian Mack Relationship added related to 0002915


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker