View Issue Details

IDProjectCategoryView StatusLast Update
0001032SOGoWeb Generalpublic2011-04-29 06:28
Reportergienger Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.4 
Target VersionFixed in Version1.3.5 
Summary0001032: (LDAP) Passwords containing '}' and ']' do not work
DescriptionThe user cannot login when the password contains a } character or a ] character.

Examples:

H3bndbk3] does not work
H3bndbk3} does not work
[H3bndbk3] does not work
{H3bndbk3} does not work

[H3bndbk3 does work
{H3bndbk3 does work

LDAP Binds done via ldapsearch (Open LDAP client) do work without a problem.
TagsNo tags attached.

Activities

ludovic

ludovic

2010-12-29 14:55

administrator   ~0001984

It works for me. Try with the latest code (ie., nightly build of tomorrow, December 30th) as there has been changes in the session and password cache code.
ludovic

ludovic

2011-04-11 08:25

administrator   ~0002363

Please give feedback, otherwise the issue will be closed.
Christian Mack

Christian Mack

2011-04-29 06:25

developer   ~0002413

I've just tested it.
In SOGo 1.3.6 this Bug is fixed.

Issue History

Date Modified Username Field Change
2010-12-03 03:06 gienger New Issue
2010-12-29 14:55 ludovic Note Added: 0001984
2010-12-29 14:55 ludovic Severity major => minor
2011-04-11 08:25 ludovic Note Added: 0002363
2011-04-29 06:25 Christian Mack Note Added: 0002413
2011-04-29 06:28 ludovic Status new => resolved
2011-04-29 06:28 ludovic Fixed in Version => 1.3.5
2011-04-29 06:28 ludovic Resolution open => fixed
2011-04-29 06:28 ludovic Assigned To => ludovic