View Issue Details

IDProjectCategoryView StatusLast Update
0001035SOGoBackend Generalpublic2011-06-16 11:44
Reporterbuzzdee Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.4 
Target Version1.3.8Fixed in Version1.3.8 
Summary0001035: On OpenBSD there is no -lcrypt
DescriptionLinking SOGo on OpenBSD fails, since it tries to link against a non existent libcrypt. However there is libcrypto.
Attached patch does not link against libcrypt unconditionally anymore. It now checks the GNUSTEP_HOST_OS, if its openbsd, and if it matches, it conditionally links against libcrypto, otherwise against libcrypt.
TagsNo tags attached.

Activities

2010-12-03 03:55

 

patch-SoObjects_SOGo_GNUmakefile_preamble (588 bytes)
--- SoObjects/SOGo/GNUmakefile.preamble.orig	Wed Nov 17 17:30:03 2010
+++ SoObjects/SOGo/GNUmakefile.preamble	Fri Dec  3 09:42:53 2010
@@ -18,9 +18,15 @@ SOGo_LIBRARIES_DEPEND_UPON += \
 	-lNGCards		\
 	-lNGMime		\
 	-lNGStreams -lNGExtensions -lEOControl \
-	-lXmlRpc -lDOM -lSaxObjC -lcrypt \
+	-lXmlRpc -lDOM -lSaxObjC \
 	-lNGLdap -lSBJson \
         -lGDLContentStore
+
+ifeq ($(findstring openbsd, $(GNUSTEP_HOST_OS)), openbsd)
+SOGo_LIBRARIES_DEPEND_UPON += -lcrypto
+else
+SOGo_LIBRARIES_DEPEND_UPON += -lcrypt
+endif
 
 ADDITIONAL_TOOL_LIBS += \
         -L$(GNUSTEP_OBJ_DIR)/ \
buzzdee

buzzdee

2011-04-13 07:38

reporter   ~0002376

could this be reviewed and commented, or even included if its fine? Shortly after a release is a good time to add new stuff, since the plenty of time for testing till the next release ;)
ludovic

ludovic

2011-06-16 11:44

administrator   ~0002592

Patch pushed: http://mtn.inverse.ca/revision/diff/869378c97b2bf3386ab9d61f8e107135f0dc0529/with/698461b7043455867e02dfbd291566ea991bf8a5

Issue History

Date Modified Username Field Change
2010-12-03 03:55 buzzdee New Issue
2010-12-03 03:55 buzzdee File Added: patch-SoObjects_SOGo_GNUmakefile_preamble
2011-02-15 17:02 ludovic Status new => assigned
2011-02-15 17:02 ludovic Assigned To => ludovic
2011-04-13 07:38 buzzdee Note Added: 0002376
2011-06-15 16:56 ludovic Target Version => 1.3.8
2011-06-16 11:44 ludovic Note Added: 0002592
2011-06-16 11:44 ludovic Status assigned => resolved
2011-06-16 11:44 ludovic Fixed in Version => 1.3.8
2011-06-16 11:44 ludovic Resolution open => fixed