View Issue Details

IDProjectCategoryView StatusLast Update
0001036SOGoBackend Mailpublic2011-06-03 12:13
Reportergienger Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.4 
Target VersionFixed in Version1.3.6 
Summary0001036: Items moved to trash do not get really deleted (missing expunge)
DescriptionSOGo moves messages from a folder to the trashcan, but the messages remain flagged \\Deleted in the source folder. No EXPUNGE does occur, the messages are still there.

At logout, not every mailbox gets expunged, only the inbox. There should be an EXPUNGE button somewhere, to expunge all deleted messages on the IMAP server....
TagsNo tags attached.

Activities

ludovic

ludovic

2010-12-06 11:27

administrator   ~0001930

Right click on a mailbox -> Compact this folder
gienger

gienger

2010-12-06 11:29

reporter   ~0001931

you're right but imagine you have many folders with non-expunged messages: You won't see them - so you won't have an idea where to compact folders.

Thunderbird offers a possibility to mark deleted messages.

And there's the problem back: The IMAP's semantics of "delete" are not the same as the one from most programs using a "trashcan".
wsourdeau

wsourdeau

2010-12-06 11:40

viewer   ~0001932

The supposed behaviour is that a folder with messages marked with "\Deleted" should be expunged when a new folder is selected. This used to work before but something may have changed since then.

How it works is that once messages have been deleted, the folder IMAP url is saved in the user settings via -[SOGoMailFolder markForExpunge] (invoked from deleteUIDs:useTrashFolder:inContext:.

Issue History

Date Modified Username Field Change
2010-12-03 04:04 gienger New Issue
2010-12-06 11:27 ludovic Note Added: 0001930
2010-12-06 11:29 gienger Note Added: 0001931
2010-12-06 11:40 wsourdeau Note Added: 0001932
2011-06-03 12:13 francis Status new => resolved
2011-06-03 12:13 francis Fixed in Version => 1.3.6
2011-06-03 12:13 francis Resolution open => fixed
2011-06-03 12:13 francis Assigned To => francis