View Issue Details

IDProjectCategoryView StatusLast Update
0001159SOGoWeb Mailpublic2020-09-08 12:11
ReporterAshok Assigned Tofrancis  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.5 
Fixed in Version5.0.0 
Summary0001159: Mail Serch: Should search "Subject or Sendar" instead of "Subject"
Description

The default filter selected in the email search text filed should be "Subject or Sender". Most people look for emails from a PERSON, not the subject. It is a big pain to always change the filter since it gets reset after changing a folder.

Also, folder is changed to "Sent" folder, the filter should automatically change to "To or CC"

This is how it happens in Thunderbird too.

TagsNo tags attached.

Activities

rof

rof

2020-04-28 11:20

reporter   ~0014291

We have the same wish. Additionally, a search for all recipients (Sender or CC) and for "subject or entire message" is requested - maybe this is realizable?

francis

francis

2020-05-08 12:15

administrator   ~0014311

This is not configurable but you can change the default search scope and add some new scopes by modifying UIxMailFolderTemplate.wox. Example:

diff --git a/UI/Templates/MailerUI/UIxMailFolderTemplate.wox b/UI/Templates/MailerUI/UIxMailFolderTemplate.wox
index 1905aaec3..f3de9abb8 100644
--- a/UI/Templates/MailerUI/UIxMailFolderTemplate.wox
+++ b/UI/Templates/MailerUI/UIxMailFolderTemplate.wox
@@ -139,9 +139,10 @@
         </md-input-container>
         <md-input-container flex="25">
           <md-select label:aria-label="Search scope">
-            <md-option value="subject" selected="selected"><var:string label:value="Subject"/></md-option>
+            <md-option value="subject"><var:string label:value="Subject"/></md-option>
             <md-option value="from"><var:string label:value="Sender"/></md-option>
-            <md-option value="subject_or_from"><var:string label:value="Subject or Sender"/></md-option>
+            <md-option value="subject_or_from" selected="selected"><var:string label:value="Subject or Sender"/></md-option>
+            <md-option value="subject_or_body"><var:string label:value="Subject or Body"/></md-option>
             <md-option value="to_or_cc"><var:string label:value="To or Cc"/></md-option>
             <md-option value="body"><var:string label:value="Entire Message"/></md-option>
           </md-select>
rof

rof

2020-09-02 07:19

reporter   ~0014735

Thanks for the support and the project! This can be closed, because of https://github.com/inverse-inc/sogo/commit/8642ff9d00d7152588c44980d7c0fbde7f9a3c1f

Issue History

Date Modified Username Field Change
2011-03-02 09:06 Ashok New Issue
2020-04-28 11:20 rof Note Added: 0014291
2020-05-08 12:15 francis Note Added: 0014311
2020-09-02 07:19 rof Note Added: 0014735
2020-09-08 12:11 francis Assigned To => francis
2020-09-08 12:11 francis Status new => resolved
2020-09-08 12:11 francis Resolution open => fixed
2020-09-08 12:11 francis Fixed in Version => 5.0.0