View Issue Details

IDProjectCategoryView StatusLast Update
0000012SOGoWeb Calendarpublic2009-08-04 14:54
Reporterjakob42 Assigned Towsourdeau 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.1 
Fixed in Version1.0.2 
Summary0000012: Only owner of a calendar can delete an event
Description

I've set up a calendar for a couple users with every right (Public/Confidential/Private) set to "modifiy", the create and delete settings below too.

When someone creates an event, he cannot delete it again, even if he created it himself. The only one who can delete is the owner of the calendar.

Additional Information

I don't know if its a web calendar problem or a problem of the backend, since I didn't have time to get the thunderbird integration up and running. And I'm new to SOGo, if I forgot important information, please ask.

TagsNo tags attached.

Activities

kirby

kirby

2009-05-20 16:29

reporter   ~0000001

Appears to be only a problem with the web calneder. iCal has no problems deleting events for other user's shared calendars (given sufficient privilege).

wsourdeau

wsourdeau

2009-06-01 14:31

viewer   ~0000004

Fixed in monotone.

Issue History

Date Modified Username Field Change
2009-05-13 02:35 jakob42 New Issue
2009-05-20 16:29 kirby Note Added: 0000001
2009-06-01 11:37 francis Status new => assigned
2009-06-01 11:37 francis Assigned To => wsourdeau
2009-06-01 14:31 wsourdeau Note Added: 0000004
2009-06-01 14:31 wsourdeau Status assigned => resolved
2009-06-01 14:31 wsourdeau Resolution open => fixed
2009-08-04 14:54 francis Fixed in Version => 1.0.2