View Issue Details

IDProjectCategoryView StatusLast Update
0001252SOGoWeb Mailpublic2011-07-29 09:32
Reporteralessio Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.3 
Target VersionFixed in Version 
Summary0001252: Bad visualization with gb2312 charset
DescriptionI can't visualize correctly some mail with sogo webmail. The problem is the charset, a chinese charset named gb2312

Content-Type: text/plain;
    charset="gb2312"
Content-Transfer-Encoding: quoted-printable

Thunderbird and Outlook visualize it correcly, sogo doesn't
How can i set correctly charset like in thunderbird?
TagsNo tags attached.

Activities

ludovic

ludovic

2011-04-11 16:28

administrator   ~0002369

Attach some sample mails to this ticket.
alessio

alessio

2011-04-13 09:27

reporter   ~0002378

hi ludovic, i send you a private e-mail. I can't share customer's e-mail
alessio

alessio

2011-04-14 03:37

reporter   ~0002382

Tested on 1.3.6, it doesn't work
ludovic

ludovic

2011-04-21 14:24

administrator   ~0002404

I've tested with the mail you sent me and it works perfectly for me.

2011-04-28 12:05

 

SOGo.conf (1,888 bytes)
alessio

alessio

2011-04-28 12:07

reporter   ~0002411

Maybe is my configuration error?
This is my configuration, i delete this two entry but nothing.
    
 WOMessageUseUTF8 = YES; WOParsersUseUTF8 = YES;

I attach my httpd.conf for sogo part:


NSGlobalDomain = {
    };
    sogod = {
        NGUseUTF8AsURLEncoding = YES;
        OCSFolderInfoURL = "mysql://sogo:*****5vwrjLSsV+ES8BC6oAkhTTwgG2JRFPhchvOLE7F3AvnSMkw@localhost/sogo/sogo_folder_info";
        SOGoACLsSendEMailNotifications = NO;
        SOGoAppointmentSendEMailNotifications = YES;
        SOGoAppointmentSendEMailReceipts = YES;
        SOGoAuthenticationMethod = LDAP;
        SOGoDraftsFolderName = Drafts;
        SOGoEnablePublicAccess = YES;
        SOGoFoldersSendEMailNotifications = NO;
        SOGoIMAPServer = localhost;
        SOGoMailDomain = nethesis.it;
        SOGoMailingMechanism = smtp;
        SOGoProfileURL = "mysql://sogo:******myr5vwrjLSsV+ES8BC6oAkhTTwgG2JRFPhchvOLE7F3AvnSMkw@localhost/sogo/sogo_user_profile";
        SOGoSMTPServer = localhost;
        SOGoSentFolderName = Sent;
        SOGoSuperUsernames = (
            admin
        );
        SOGoTimeZone = Europe/Rome;
        SOGoTrashFolderName = Trash;
        SOGoUserSources = (
            {
                CNFieldName = cn;
                IDFieldName = uid;
                UIDFieldName = uid;
                baseDN = "ou=Users,dc=nethesis,dc=it";
                bindFields = uid;
                canAuthenticate = YES;
                displayName = "Users";
                hostname = localhost;
                id = users;
                isAddressBook = YES;
                port = ;
                type = ldap;
            },
            {
                CNFieldName = cn;
                IDFieldName = cn;
                UIDFieldName = cn;
                baseDN = "ou=Groups,dc=nethesis,dc=it";
                bindFields = cn;
                canAuthenticate = YES;
                displayName = "Groups";
                hostname = localhost;
                id = groups;
                isAddressBook = YES;
                port = ;
                type = ldap;
            }
        );
        WOMessageUseUTF8 = YES;
        WOParsersUseUTF8 = YES;
        WOPort = 127.0.0.1:20000;
        WOUseRelativeURLs = YES;
    };
}
alessio

alessio

2011-05-19 11:53

reporter   ~0002497

how can sogo visualize correctly e-mail charset?
I think that bad visualization is a problem of my OS based on centos 5.4
I think that sogo misses something for works correctly.
What can i search/check on my server? What does sogo miss?
alessio

alessio

2011-06-23 08:34

reporter   ~0002625

Maybe the problem is the multiple charset into the mail.
I have send you another mail to check.
alessio

alessio

2011-07-27 06:04

reporter   ~0002744

Can you check this bug? It's very urgent for me!
ludovic

ludovic

2011-07-27 09:45

administrator   ~0002745

We never received your test mails.
ludovic

ludovic

2011-07-29 09:32

administrator   ~0002764

http://mtn.inverse.ca/revision/diff/6b4e2f16b2a1ac3bbbb8f854763b7deb70bd8a46/with/addfe836292fcae874e765a05ef776bfe841be1d

Issue History

Date Modified Username Field Change
2011-04-11 09:34 alessio New Issue
2011-04-11 16:28 ludovic Note Added: 0002369
2011-04-13 09:27 alessio Note Added: 0002378
2011-04-14 03:37 alessio Note Added: 0002382
2011-04-21 14:24 ludovic Note Added: 0002404
2011-04-28 12:05 alessio File Added: SOGo.conf
2011-04-28 12:07 alessio Note Added: 0002411
2011-05-19 11:53 alessio Note Added: 0002497
2011-06-23 08:34 alessio Note Added: 0002625
2011-07-27 06:04 alessio Note Added: 0002744
2011-07-27 09:45 ludovic Note Added: 0002745
2011-07-29 09:32 ludovic Note Added: 0002764
2011-07-29 09:32 ludovic Status new => resolved
2011-07-29 09:32 ludovic Resolution open => fixed
2011-07-29 09:32 ludovic Assigned To => ludovic