SOGo | BTS

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001337SOGoWeb Calendarpublic2011-06-14 06:102011-10-24 15:16
ReporterChristian Mack 
Assigned Tofrancis 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionno change required 
PlatformOSOS Version
Product Version1.3.7 
Target VersionFixed in Version 
Summary0001337: While editing event "Calendar:" is always set to "personal calendar".
DescriptionWhen editing an existing event the field "Calendar:" is always set to "personal calendar", ignoring the calendar it is really in.

This is also true for subscribed shared calendars.

This is really annoying, as you always have to check it before saving.
Steps To ReproduceCreate additional calendar, e.g. "second calendar".
Create an event in this additional calendar, e.g. "Test event in 2-nd".
Open this event with "Edit this selected event..." in the event list or by double click in the graphical overview.

Now you can see that in field "Calendar:" always "Personal calendar" is selected, but it should be "second calendar", as this is where this event is really located.
TagsNo tags attached.
Attached Filespng file icon Screenshot1-SOGo-Firefox4Linux.png [^] (79,040 bytes) 2011-06-24 03:38


png file icon Screenshot2-SOGoProbe_Event-Firefox4Linux.png [^] (30,623 bytes) 2011-06-24 03:39

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
User avatar (0002606)
ludovic (administrator)
2011-06-20 15:48

Which browser are you having the problem with?
User avatar (0002610)
Christian Mack (developer)
2011-06-21 05:39

I tried it with
Firefox 4.0 on Linux (openSUSE 11.3),
Epiphany 2.30.2 on Linux,
Firefox 4.0.1 on WinXP,
IE 8 on WinXP,
Google Chrome 12.0.742.100 on WinXP.

It's always the same. You get "Personal Calendar" when editing events.

BTW:
This is also true for tasks.
User avatar (0002630)
ludovic (administrator)
2011-06-23 11:37

I can't reproduce this with FF5 and Safari 5.

Show me some screenshots.
User avatar (0002634)
Christian Mack (developer)
2011-06-24 03:48

I've attached screen shots made on Linux with Firefox 4.
On all above mentioned browsers and OS combinations it's always the same situation.

Screenshot1 shows the calendar overview.
As you can see, there is an Event named "Probe Event" painted in blue.
Blue is the colour associated with the second calendar "Probekalendar".

Screenshot2 shows the event "Probe Event" in edit view.
There you see that the "calendar:" field is set to "Persönlicher Kalender".
It should show "Probekalendar".

Hope this helps a bit.
User avatar (0002636)
ludovic (administrator)
2011-06-24 19:00

I still can't reproduce that bug. Can you try on sogo-demo.inverse.ca?
User avatar (0002641)
Christian Mack (developer)
2011-06-27 04:05

Just tried it on sogo-demo.inverse.ca.
There I can't reproduce it either.

Don't know if this is a configuration problem or fixed in the current nightly.
User avatar (0002642)
ludovic (administrator)
2011-06-27 09:42

Any errors from your Firefox error console?

I think it's an "update" problem on your side. That code hasn't changed in a long time.

You could validate that "theory" by downloading the ZEG 1.3.7a from sogo.nu and testing it out.

Regards,
User avatar (0002646)
Christian Mack (developer)
2011-06-28 05:21

Firefox 4.0.1 shows the following errors when I open an event for editing from our SOGo instance:

Fehler: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.clearUserPref]" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: chrome://dotnetassistant/content/bootstrap.js :: BootStrapDotNetAsssitantExtension :: line 52" data: no]
Fehler: Components.classes['@mozilla.org/extensions/manager;1'] is undefined
Quelldatei: chrome://jqs/content/overlay.js
Zeile: 9



There are some warnings too, which I think are irrelevant for this Problem:

Warnung: XUL-Box für _moz_generated_content_after-Element enthält ein Inline-#text-Kind-Element, was alle Nachkommen zwingt, von einem Block umgeben zu werden.
Quelldatei: chrome://browser/content/browser.xul
Zeile: 0
Warnung: Unbekannte Eigenschaft '-moz-outline'. Deklaration ignoriert.
Quelldatei: https://sogo.uni-konstanz.de/SOGo.woa/WebServerResources/generic.css [^]
Zeile: 51
Warnung: Unbekannte Eigenschaft '-moz-opacity'. Deklaration ignoriert.
Quelldatei: https://sogo.uni-konstanz.de/SOGo.woa/WebServerResources/generic.css [^]
Zeile: 433
Warnung: Unbekannte Eigenschaft '-moz-opacity'. Deklaration ignoriert.
Quelldatei: https://sogo.uni-konstanz.de/SOGo.woa/WebServerResources/generic.css [^]
Zeile: 452
Warnung: Fehler beim Verarbeiten des Wertes für 'padding-left'. Deklaration ignoriert.
Quelldatei: https://sogo.uni-konstanz.de/SOGo.woa/WebServerResources/generic.css [^]
Zeile: 858
Warnung: Unbekannte Eigenschaft '-moz-opacity'. Deklaration ignoriert.
Quelldatei: https://sogo.uni-konstanz.de/SOGo.woa/WebServerResources/SchedulerUI.css [^]
Zeile: 1297
Warnung: Unbekannte Eigenschaft '-moz-opacity'. Deklaration ignoriert.
Quelldatei: https://sogo.uni-konstanz.de/SOGo.woa/WebServerResources/SchedulerUI.css [^]
Zeile: 1340
Warnung: Unbekannte Eigenschaft '-moz-opacity'. Deklaration ignoriert.
Quelldatei: https://sogo.uni-konstanz.de/SOGo.woa/WebServerResources/SchedulerUI.css [^]
Zeile: 1353
Warnung: Unbekannte Eigenschaft '-moz-opacity'. Deklaration ignoriert.
Quelldatei: https://sogo.uni-konstanz.de/SOGo.woa/WebServerResources/SchedulerUI.css [^]
Zeile: 1394


Will try ZEG in the afternoon.
User avatar (0002667)
ludovic (administrator)
2011-07-06 13:49

Any updates on your SOGo ZEG test?
User avatar (0002702)
Christian Mack (developer)
2011-07-13 09:46

Sorry for the late response.

Got ZEG 1.3.7 (@vizzini.inverse.ca 201105032010)

With it I can't reproduce the problem. It always sets the correct calendar when editing an event.

Also I get the same errors and warnings in Firefox 4.0.1 and 5.0 as mentioned before. Therefore they are not related to the problem.

The only difference I see is that our version reads 1.3.7 (root@vizzini.inverse.ca 201105061205). It was installed from rpm.
User avatar (0002801)
Christian Mack (developer)
2011-08-17 06:18

We are now on SOGo 1.3.8a.
But this problem persists.

I checked with firebug the corresponding window for changing the event.
All existing calendars are listed in option tags.
There is _NO_ selected=selected entry for any of the option tags in id=calendarList.

So it can't display the correct one.

As this is working in ZEG, what could be the reason for this?
User avatar (0002941)
Christian Mack (developer)
2011-10-24 04:32

Tested this with 2.0 beta2.
Now it works correctly.

So this bug can be closed.

- Issue History
Date Modified Username Field Change
2011-06-14 06:10 Christian Mack New Issue
2011-06-15 16:15 ludovic Target Version => 1.3.8
2011-06-20 15:48 ludovic Note Added: 0002606
2011-06-21 05:39 Christian Mack Note Added: 0002610
2011-06-23 11:37 ludovic Note Added: 0002630
2011-06-24 03:38 Christian Mack File Added: Screenshot1-SOGo-Firefox4Linux.png
2011-06-24 03:39 Christian Mack File Added: Screenshot2-SOGoProbe_Event-Firefox4Linux.png
2011-06-24 03:48 Christian Mack Note Added: 0002634
2011-06-24 19:00 ludovic Note Added: 0002636
2011-06-27 04:05 Christian Mack Note Added: 0002641
2011-06-27 09:42 ludovic Note Added: 0002642
2011-06-27 09:42 ludovic Target Version 1.3.8 =>
2011-06-28 05:21 Christian Mack Note Added: 0002646
2011-07-06 13:49 ludovic Note Added: 0002667
2011-07-13 09:46 Christian Mack Note Added: 0002702
2011-08-17 06:18 Christian Mack Note Added: 0002801
2011-10-24 04:32 Christian Mack Note Added: 0002941
2011-10-24 07:14 ludovic Status new => closed
2011-10-24 07:14 ludovic Resolution open => no change required
2011-10-24 15:16 francis Status closed => resolved
2011-10-24 15:16 francis Assigned To => francis


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker