View Issue Details

IDProjectCategoryView StatusLast Update
0001396SOGoWeb Calendarpublic2012-09-20 09:11
Reporterthoralf Assigned To 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionno change required 
Product Version1.3.8 
Target VersionFixed in Version 
Summary0001396: syncing appointments from android crashes the web calendar
Descriptionsyncing any appointments from an android phone to the sogo server via funambol (ds server 8.7.0) causes the calendar in the sogo web interface to become unusable. the only solution to make it responsive again is to delete the respective user with sogotool.

a few things to note:
- accessing the calendar with another client via caldav still works (tried with lightning), so the issue seems to be with the sogo web interface only
- synchronizing the other way around (ie., sogo -> android) works flawlessly
- the funambol log does not show any errors
Additional Informationsogo.log - using the webinterface to add an appointment:
127.0.0.1 - - [20/Jul/2011:17:07:49 GMT] "GET /SOGo/so/ HTTP/1.1" 200 3505/0 0.049 10640 67% 1M
Jul 20 17:07:53 sogod [30373]: SOGoRootPage successful login for user 'thoralf' - expire = -1 grace = -1
Jul 20 17:07:53 sogod [30373]: [WARN] <0x0x914b6b0[SOGoWebDAVAclManager]> entry '{DAV:}write' already exists in DAV permissions table
Jul 20 17:07:53 sogod [30373]: [WARN] <0x0x914b6b0[SOGoWebDAVAclManager]> entry '{DAV:}write-properties' already exists in DAV permissions table
Jul 20 17:07:53 sogod [30373]: [WARN] <0x0x914b6b0[SOGoWebDAVAclManager]> entry '{DAV:}write-content' already exists in DAV permissions table
127.0.0.1 - - [20/Jul/2011:17:07:53 GMT] "POST /SOGo/connect HTTP/1.1" 200 27/41 0.008 - - 64K
127.0.0.1 - - [20/Jul/2011:17:07:53 GMT] "GET /SOGo/so/thoralf HTTP/1.1" 302 0/0 0.002 - - 8K
127.0.0.1 - - [20/Jul/2011:17:07:53 GMT] "GET /SOGo/so/thoralf/view HTTP/1.1" 302 0/0 0.002 - - 8K
127.0.0.1 - - [20/Jul/2011:17:07:53 GMT] "GET /SOGo/so/thoralf/Mail HTTP/1.1" 302 0/0 0.002 - - 16K
2011-07-20 17:07:53.910 sogod[30373] WARNING: IMAP4 connection pooling is disabled!
2011-07-20 17:07:53.912 sogod[30373] Note(NGImap4Connection): using '/' as the IMAP4 folder separator.
2011-07-20 17:07:54.192 sogod[30373] Note: using 'UCS-2LE' on Linux.
127.0.0.1 - - [20/Jul/2011:17:07:54 GMT] "GET /SOGo/so/thoralf/Mail/view HTTP/1.1" 200 42113/0 0.984 158652 73% 26M
127.0.0.1 - - [20/Jul/2011:17:07:55 GMT] "POST /SOGo/so/thoralf/Calendar/alarmslist?browserTime=1311174475 HTTP/1.1" 200 2/0 0.015 - - 260K
127.0.0.1 - - [20/Jul/2011:17:07:55 GMT] "POST /SOGo/so/thoralf/Mail/0/mailboxes HTTP/1.1" 200 4865/0 0.172 - - 8K
127.0.0.1 - - [20/Jul/2011:17:07:55 GMT] "POST /SOGo/so/thoralf/Mail//0/folderINBOX/unseenCount HTTP/1.1" 200 13/0 0.209 - - 8K
127.0.0.1 - - [20/Jul/2011:17:07:55 GMT] "POST /SOGo/so/thoralf/Mail/foldersState HTTP/1.1" 200 23/0 0.003 - - 0
2011-07-20 17:09:05.293 sogod[30373] File NSKeyValueCoding.m: 892. In [SOGoAppointmentFolder -valuesForKeys:] This method is deprecated, use -dictionaryWithValuesFo
rKeys:

... syncing ...
27.0.0.1 - - [20/Jul/2011:17:09:05 GMT] "PROPFIND /SOGo/dav/sogo_ressources/Calendar/995-4E1F1080-11-2BF90440/ HTTP/1.1" 207 338/123 0.026 - - 116K

... and trying to use the web if again:
127.0.0.1 - - [20/Jul/2011:17:10:03 GMT] "GET /SOGo/so/thoralf/Mail//0/folderINBOX/expunge HTTP/1.1" 200 2/0 0.170 - - 0
127.0.0.1 - - [20/Jul/2011:17:10:04 GMT] "GET /SOGo/so/thoralf/Calendar HTTP/1.1" 302 0/0 0.003 - - 0
127.0.0.1 - - [20/Jul/2011:17:10:04 GMT] "GET /SOGo/so/thoralf/Calendar/view HTTP/1.1" 200 10705/0 0.100 43707 75% 120K
127.0.0.1 - - [20/Jul/2011:17:10:04 GMT] "POST /SOGo/so/thoralf/Calendar/personal/canAccessContent HTTP/1.1" 204 0/0 0.029 - - 12K
127.0.0.1 - - [20/Jul/2011:17:10:04 GMT] "POST /SOGo/so/thoralf/Calendar/alarmslist?browserTime=1311174604 HTTP/1.1" 200 2/0 0.013 - - 0
127.0.0.1 - - [20/Jul/2011:17:10:04 GMT] "POST /SOGo/so/thoralf/Calendar/taskslist?show-completed=0 HTTP/1.1" 200 2/0 0.004 - - 24K
127.0.0.1 - - [20/Jul/2011:17:10:04 GMT] "POST /SOGo/so/thoralf/Calendar/weekview HTTP/1.1" 200 1934/0 0.034 22313 91% 8K
127.0.0.1 - - [20/Jul/2011:17:10:04 GMT] "POST /SOGo/so/thoralf/Calendar/eventslist?asc=true&sort=start&day=&filterpopup=view_today HTTP/1.1" 200 2/0 0.006 - - 8K
Jul 20 17:10:04 sogod [29662]: <0x0x8e040e8[WOWatchDogChild]> child 30373 exited
Jul 20 17:10:04 sogod [29662]: <0x0x8e040e8[WOWatchDogChild]> (terminated due to signal 11)
Jul 20 17:10:04 sogod [29662]: <0x0x8fe54c8[WOWatchDog]> child spawned with pid 30418
2011-07-20 17:10:04.758 sogod[30418] Note: Using UTF-8 as URL encoding in NGExtensions.
Jul 20 17:10:04 sogod [30418]: <0x0x8ef9288[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Jul 20 17:10:04 sogod [30418]: <0x0x8ef9288[SOGoCache]> Using host(s) 'localhost' as server(s)
2011-07-20 17:10:04.764 sogod[30418] Note(SoObject): SoDebugKeyLookup is enabled!
2011-07-20 17:10:04.764 sogod[30418] Note(SoObject): SoDebugBaseURL is enabled!
2011-07-20 17:10:04.764 sogod[30418] Note(SoObject): relative base URLs are enabled.
Jul 20 17:10:04 sogod [30418]: [WARN] <0x0x917e750[SOGoWebDAVAclManager]> entry '{DAV:}write' already exists in DAV permissions table
Jul 20 17:10:04 sogod [30418]: [WARN] <0x0x917e750[SOGoWebDAVAclManager]> entry '{DAV:}write-properties' already exists in DAV permissions table
Jul 20 17:10:04 sogod [30418]: [WARN] <0x0x917e750[SOGoWebDAVAclManager]> entry '{DAV:}write-content' already exists in DAV permissions table
Jul 20 17:10:04 sogod [29662]: <0x0x8e040e8[WOWatchDogChild]> child 30418 exited
Jul 20 17:10:04 sogod [29662]: <0x0x8e040e8[WOWatchDogChild]> (terminated due to signal 11)
Jul 20 17:10:04 sogod [29662]: <0x0x8e040e8[WOWatchDogChild]> avoiding to respawn child before 2011-07-20 17:10:09 +0200
Jul 20 17:10:09 sogod [29662]: <0x0x8fe54c8[WOWatchDog]> child spawned with pid 30419
2011-07-20 17:10:09.058 sogod[30419] Note: Using UTF-8 as URL encoding in NGExtensions.

please see also:
* https://inverse.ca/sogo/lists/arc/users/2010-09/msg00351.html and
* https://inverse.ca/sogo/lists/arc/users/2011-07/msg00143.html
TagsNo tags attached.

Activities

thoralf

thoralf

2011-07-29 07:53

reporter   ~0002758

please let me know if there is anything i can do to assist with debugging this issue ...
ludovic

ludovic

2011-07-29 09:39

administrator   ~0002765

Install the SOGo/SOPE debugging packages, start SOGo with one process, attach to it using gdb, continue, make it crash, send the backtrace.
thoralf

thoralf

2011-08-01 12:43

reporter   ~0002775

hi ludovic,

please see the attached file.

with kind regards,
t.

2011-08-01 12:43

 

sogo_ui_crash (4,624 bytes)
(gdb) bt
#0  0x0983bbe0 in ?? ()
#1  0xf7f0f047 in ?? () from /usr/lib/libSOGo.so.1
#2  0xf7f1f68e in ?? () from /usr/lib/libSOGo.so.1
#3  0xf6af2114 in -[UIxCalListingActions _fetchFields:forComponentOfType:] (self=0x9ca2530, _cmd=0xf6b1dbc0, fields=0x9fc0410, component=0xf6b1d498)
    at UIxCalListingActions.m:367
#4  0xf6af4f2b in -[UIxCalListingActions eventsBlocksAction] (self=0x9ca2530, _cmd=0x9a4d1e0) at UIxCalListingActions.m:976
#5  0xf75cc53d in ?? () from /usr/lib/libgnustep-base.so.1.16
#6  0xf7b7e58d in -[WODirectAction performActionNamed:] (self=0x9ca2530, _cmd=0xf7cea860, _actionName=0x9fe0990) at WODirectAction.m:101
#7  0xf7c10252 in -[SoActionInvocation callOnObject:withPositionalParametersWhenNotNil:inContext:] (self=0xa6f32f0, _cmd=0xf7cea878, _client=0xa72dff8, 
    _positionalArgs=0x0, _ctx=0x9965f68) at SoActionInvocation.m:300
#8  0xf7c104de in -[SoActionInvocation callOnObject:inContext:] (self=0xa6f32f0, _cmd=0xf7cea808, _client=0xa72dff8, _ctx=0x9965f68) at SoActionInvocation.m:316
#9  0xf7c10103 in -[SoActionInvocation callOnObject:withPositionalParametersWhenNotNil:inContext:] (self=0x9987a48, _cmd=0xf7cea878, _client=0xa72dff8, 
    _positionalArgs=0x0, _ctx=0x9965f68) at SoActionInvocation.m:259
#10 0xf7c104de in -[SoActionInvocation callOnObject:inContext:] (self=0x9987a48, _cmd=0xf7ce8d88, _client=0xa72dff8, _ctx=0x9965f68) at SoActionInvocation.m:316
#11 0xf7c0ab2a in -[SoObjectMethodDispatcher dispatchInContext:] (self=0x9f0f930, _cmd=0xf7ce9598, _ctx=0x9965f68) at SoObjectMethodDispatcher.m:191
#12 0xf7c0d4b2 in -[SoObjectRequestHandler handleRequest:inContext:session:application:] (self=0x9a44e38, _cmd=0xf7c9c4d8, _rq=0x9c84210, _ctx=0x9965f68, 
    _sn=0x0, app=0x99a6de8) at SoObjectRequestHandler.m:591
#13 0xf7b9000f in -[WORequestHandler handleRequest:] (self=0x9a44e38, _cmd=0xf7c7a140, _request=0x9c84210) at WORequestHandler.m:241
#14 0xf7b4ebbd in -[WOCoreApplication dispatchRequest:usingHandler:] (self=0x99a6de8, _cmd=0xf7c7a178, _request=0x9c84210, handler=0x9a44e38)
    at WOCoreApplication.m:704
#15 0xf7b4ee5b in -[WOCoreApplication dispatchRequest:] (self=0x99a6de8, _cmd=0x8051858, _request=0x9c84210) at WOCoreApplication.m:744
#16 0x0804ac1c in -[SOGo dispatchRequest:] (self=0x99a6de8, _cmd=0xf7cd9790, _request=0x9c84210) at SOGo.m:451
#17 0xf7bfae43 in -[WOHttpTransaction _run] (self=0x9d4dfa8, _cmd=0xf7cd97a8) at WOHttpTransaction.m:546
#18 0xf7bfb09a in -[WOHttpTransaction run] (self=0x9d4dfa8, _cmd=0xf7cd8ae8) at WOHttpTransaction.m:599
#19 0xf7bf6b35 in -[WOHttpAdaptor runConnection:] (self=0x9a32a78, _cmd=0xf7cd8b38, _socket=0x9befae8) at WOHttpAdaptor.m:384
#20 0xf7bf6d85 in -[WOHttpAdaptor _handleAcceptedConnection:] (self=0x9a32a78, _cmd=0xf7cd8b40, _connection=0x9befae8) at WOHttpAdaptor.m:418
#21 0xf7bf7223 in -[WOHttpAdaptor _handleConnection:] (self=0x9a32a78, _cmd=0xf7cd8b98, connection=0x9befae8) at WOHttpAdaptor.m:477
#22 0xf7bf74c1 in -[WOHttpAdaptor acceptControlMessage:] (self=0x9a32a78, _cmd=0xf7cd8a48, aNotification=0x98cc708) at WOHttpAdaptor.m:516
#23 0xf75bce79 in ?? () from /usr/lib/libgnustep-base.so.1.16
#24 0xf75bd78b in ?? () from /usr/lib/libgnustep-base.so.1.16
#25 0xf75bd642 in ?? () from /usr/lib/libgnustep-base.so.1.16
#26 0xf79404a2 in -[NSObject(FileObjectWatcher) receivedEvent:type:extra:forMode:] (self=0x98e0cb8, _cmd=0xf7857ab8, _fdData=0x8, _type=ET_RDESC, _extra=0x8, 
    _mode=0xf781d338) at NSRunLoop+FileObjects.m:57
#27 0xf76c1052 in ?? () from /usr/lib/libgnustep-base.so.1.16
#28 0xf76042ec in ?? () from /usr/lib/libgnustep-base.so.1.16
#29 0xf760474a in ?? () from /usr/lib/libgnustep-base.so.1.16
#30 0xf7b4e452 in -[WOCoreApplication run] (self=0x99a6de8, _cmd=0x8051768) at WOCoreApplication.m:576
#31 0x0804a25f in -[SOGo run] (self=0x99a6de8, _cmd=0xf7ca1118) at SOGo.m:275
#32 0xf7b9b3b7 in -[WOWatchDog _runChildWithControlSocket:] (self=0x9a431b8, _cmd=0xf7ca1188, controlSocket=0x98e0cb8) at WOWatchDogApplicationMain.m:499
#33 0xf7b9b6fd in -[WOWatchDog _spawnChild:] (self=0x9a431b8, _cmd=0xf7ca11f8, child=0x99e1250) at WOWatchDogApplicationMain.m:563
#34 0xf7b9a6bd in -[WOWatchDog _ensureChildren] (self=0x9a431b8, _cmd=0xf7ca1300) at WOWatchDogApplicationMain.m:653
#35 0xf7b9aed5 in -[WOWatchDog run:argc:argv:] (self=0x9a431b8, _cmd=0xf7ca1388, newAppName=0x8050660, newArgC=1, newArgV=0xffab72d4)
    at WOWatchDogApplicationMain.m:927
#36 0xf7b9c12c in WOWatchDogApplicationMain (appName=0x8050660, argc=1, argv=0xffab72d4) at WOWatchDogApplicationMain.m:1036
#37 0x08049474 in main (argc=1, argv=0xffab72d4, env=0xffab72dc) at sogod.m:53
(gdb) 

sogo_ui_crash (4,624 bytes)
ludovic

ludovic

2011-11-24 16:01

administrator   ~0003075

Unfortunately, the stack trace is missing important information.

Could you try on our end with a test user, empty the calendar, sync to create the issue, backup the calendar using sogo-tool and attach the backup file to this ticket?
ludovic

ludovic

2012-09-20 09:11

administrator   ~0004501

No feedback was provided in almost a year.

Try with the latest version of SOGo and see what happens. Reopen if necessary.

Issue History

Date Modified Username Field Change
2011-07-26 12:39 thoralf New Issue
2011-07-29 07:53 thoralf Note Added: 0002758
2011-07-29 09:39 ludovic Note Added: 0002765
2011-08-01 12:43 thoralf Note Added: 0002775
2011-08-01 12:43 thoralf File Added: sogo_ui_crash
2011-11-24 16:01 ludovic Note Added: 0003075
2012-09-20 09:11 ludovic Note Added: 0004501
2012-09-20 09:11 ludovic Status new => closed
2012-09-20 09:11 ludovic Resolution open => no change required