View Issue Details

IDProjectCategoryView StatusLast Update
0000015SOGoBackend Mailpublic2009-08-04 14:54
Reportertarjei Assigned Towsourdeau 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.1 
Fixed in Version1.0.2 
Summary0000015: Sogo IMAP client chrashes too easily on odd characters in foldernames
Description

I got a problem getting the webmail part of SOGo to work.

According to the Cyrus logs, SOGo logs on to the imap server. In my sogod log I find:

2009-05-25 13:36:49.775 sogod[10040] Note(NGImap4Connection): using '/' as the IMAP4 folder separator.
EXCEPTION: <NSException: 0xab9fb68> NAME:NSInvalidArgumentException REASON:Tried to add nil key to dictionary INFO:{"
.. ( long list of all my folders ) ..

child 10085 (0000002) was terminated by signal 6 (uptime=207s).

2009-05-25 13:36:51.145 sogod[10040] starting SOGo (build root@vizzini 200904071244)
2009-05-25 13:36:51.145 sogod[10040] Note: vmem size check enabled: shutting down app when vmem > 200 MB
May 25 13:36:51 sogod [10581]: SNS support disabled.
...

According to Romain LE DISEZ this is due to unhandled characters in the folder names.

TagsNo tags attached.

Activities

francis

francis

2009-05-26 17:15

administrator   ~0000002

Would it be possible to see either the result of the LIST IMAP command for your problematic account or event the "long list of all you folders" that appear in the log of sogo?

Thanks!

tarjei

tarjei

2009-05-27 02:44

reporter   ~0000003

Logs emailed francis privately.

wsourdeau

wsourdeau

2009-06-15 21:55

viewer   ~0000006

Indeed, there were problems in managing specific characters. THe code has been entirely reviewed and fixed. The nigthlies and monotone are updated.

Issue History

Date Modified Username Field Change
2009-05-25 08:58 tarjei New Issue
2009-05-26 17:15 francis Note Added: 0000002
2009-05-27 02:44 tarjei Note Added: 0000003
2009-06-15 21:55 wsourdeau Note Added: 0000006
2009-06-15 21:55 wsourdeau Status new => resolved
2009-06-15 21:55 wsourdeau Resolution open => fixed
2009-06-15 21:55 wsourdeau Assigned To => wsourdeau
2009-08-04 14:54 francis Fixed in Version => 1.0.2