View Issue Details

IDProjectCategoryView StatusLast Update
0001573SOGoBackend Calendarpublic2012-05-31 15:02
Reporteramaramrahul Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.11 
Target VersionFixed in Version 
Summary0001573: Delete Event and Delete Task does not work with SOGo 1.3.11 + Lightning Inverse Edition 1.0b2.108i
DescriptionWhen I delete a task or event, it does not get deleted. The error messages displayed in the error console are:

Error: An error occurred executing the calendar_delete_todo_command command: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]" nsresult: "0x80004002 (NS_NOINTERFACE)" location: "JS frame :: file:///home/rahul/.thunderbird/6kqvwk7n.test/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/rahul/.thunderbird/6kqvwk7n.test/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavCalendar.js :: caldav_deleteItemOrUseCache :: line 867" data: no]
Source File: chrome://global/content/globalOverlay.js
Line: 100

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]" nsresult: "0x80004002 (NS_NOINTERFACE)" location: "JS frame :: file:///home/rahul/.thunderbird/6kqvwk7n.test/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/rahul/.thunderbird/6kqvwk7n.test/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavCalendar.js :: caldav_modifyItemOrUseCache :: line 711" data: no]

Error: An error occurred executing the calendar_delete_event_command command: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]" nsresult: "0x80004002 (NS_NOINTERFACE)" location: "JS frame :: file:///home/rahul/.thunderbird/6kqvwk7n.test/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/rahul/.thunderbird/6kqvwk7n.test/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavCalendar.js :: caldav_deleteItemOrUseCache :: line 867" data: no]
Source File: chrome://global/content/globalOverlay.js
Line: 100
TagsNo tags attached.

Activities

martinseener

martinseener

2012-01-19 06:01

reporter   ~0003290

+1
We have the same Issue. Thunderbird 3.1.17 + latest stable Lightning Inverse + SOGO Connector and Integrator, backend is SOGo 1.3.11 w. Debian Squeeze
joolsr

joolsr

2012-01-19 06:47

reporter   ~0003291

+1

I have same issue, I think the problems started for me with SOGo 3.106 Lightning but still exist on 3.108

I use 3.105 for my users to get round it.

With 3.106 onwards i specifically get issues with deleting tasks on a resource directly even if the user has full read/write privs to access it.
ultreia

ultreia

2012-01-19 07:54

reporter   ~0003292

Same here.
It does nothing when we try to delete or add a task or an event and we get an exception in Thunderbird console.
It happens with user's own calendars (so it's supposed it has full privileges) but it doesn't happen with other users' calendars this user has access to (weird).
Version 3.106 is also affected but I can't test previous versions since I get an empty calendar.
amaramrahul

amaramrahul

2012-01-26 05:49

reporter   ~0003314

I request any of the SOGo developers to look into this bug. This seems to be a serious enough bug to exist in the stable versions. I could help with any necessary testing of patches.
joolsr

joolsr

2012-01-26 07:52

reporter   ~0003316

+1

I will have to concur. Normally Ludovic and Walter et al, are very good at tracking down and fixing bugs, but this has been an issue for a while now.

I realise that perhaps it isn't that easy to demonstrate the issue, but I think it really needs some attention now. It seemed to be an issue for me when the use of the acl file was started at the start of 3.106. On 3.105 there was no acl file in the user's Thunderbird profile/calendar-data dir.
ludovic

ludovic

2012-01-26 09:26

administrator   ~0003320

I don't have this issue with the latest version of the extension. One issue I sometimes have is when I delete an event from the web interface, it doesn't get deleted from Thunderbird after a calendar refresh.

Could you try to remove the content of your calendar-data directory, restart Thunderbird and see if you still get the error?
amaramrahul

amaramrahul

2012-01-26 12:55

reporter   ~0003324

I am facing this error with a new installation of SOGo as well as an upgraded instance of SOGo.
ludovic

ludovic

2012-01-26 13:11

administrator   ~0003325

Have you tried what I asked? Upgrading SOGo has nothing to do with it.
amaramrahul

amaramrahul

2012-01-26 13:30

reporter   ~0003327

If you are referring to your suggestion of deleting calendar data in thunderbird, then that is not applicable as i am always testing with a new profile in thunderbird.
ludovic

ludovic

2012-01-26 13:31

administrator   ~0003328

So with a brand new profile, you get the exceptions mentioned in the ticket? What versions of SOGo Connector, Integrator and Lightning are you using?
amaramrahul

amaramrahul

2012-01-26 13:42

reporter   ~0003330

Yes the profile is brand new. I only use connector (3.108) and lightning plugin (1.0b2.108i).
guawhitehawk

guawhitehawk

2012-01-26 13:43

reporter   ~0003331

Iam using Thunderbird 3.1.17 (Mac, English) from the Mozilla Download Page, using Lightning Inverse Edition 1.0b2 for TBird 3, SOGo Connector and Integrator from the sogo.nu Website.

i hope not, that the order how to install these in Tbird is important^^
ludovic

ludovic

2012-01-26 14:14

administrator   ~0003333

It's not, but out of curiosity, have you customized your SOGO Integrator?
amaramrahul

amaramrahul

2012-01-26 21:25

reporter   ~0003334

I have not installed SOGo integrator. Only use lightning and connector plugins.
guawhitehawk

guawhitehawk

2012-01-27 02:53

reporter   ~0003335

havent changed anything there, wether in connector nor integrator!
wsourdeau

wsourdeau

2012-02-08 09:20

viewer   ~0003382

Are your calendars used in cached mode? If not, please enable caching (and restart tbird). This might be the cause of this issue.
joolsr

joolsr

2012-02-08 09:38

reporter   ~0003383

how do you enable cache mode?
wsourdeau

wsourdeau

2012-02-08 09:40

viewer   ~0003384

You need to double-click on each calendar name (in the list on the left), and check "cached". If the checkbox does not appear, it probably means you are using sogo integrator...
joolsr

joolsr

2012-02-09 05:35

reporter   ~0003409

Yes I am using SOGo Intergrator
amaramrahul

amaramrahul

2012-02-11 00:48

reporter   ~0003421

Solved. Enabling caching has fixed this issue. Thanks for the tip.

Are there any potential problems which I should be aware of for using caching?
ludovic

ludovic

2012-05-31 15:02

administrator   ~0003999

Cached mode (not using it) was the root cause of this issue. When using the SOGo Integrator, it is forced. Preferred extensions are now the ones for Thunderbird 10 ESR anyway.

Issue History

Date Modified Username Field Change
2012-01-11 04:32 amaramrahul New Issue
2012-01-19 06:01 martinseener Note Added: 0003290
2012-01-19 06:47 joolsr Note Added: 0003291
2012-01-19 07:54 ultreia Note Added: 0003292
2012-01-26 05:49 amaramrahul Note Added: 0003314
2012-01-26 07:52 joolsr Note Added: 0003316
2012-01-26 09:26 ludovic Note Added: 0003320
2012-01-26 12:55 amaramrahul Note Added: 0003324
2012-01-26 13:11 ludovic Note Added: 0003325
2012-01-26 13:30 amaramrahul Note Added: 0003327
2012-01-26 13:31 ludovic Note Added: 0003328
2012-01-26 13:42 amaramrahul Note Added: 0003330
2012-01-26 13:43 guawhitehawk Note Added: 0003331
2012-01-26 14:14 ludovic Note Added: 0003333
2012-01-26 21:25 amaramrahul Note Added: 0003334
2012-01-27 02:53 guawhitehawk Note Added: 0003335
2012-02-08 09:20 wsourdeau Note Added: 0003382
2012-02-08 09:38 joolsr Note Added: 0003383
2012-02-08 09:40 wsourdeau Note Added: 0003384
2012-02-09 05:35 joolsr Note Added: 0003409
2012-02-11 00:48 amaramrahul Note Added: 0003421
2012-05-31 15:02 ludovic Note Added: 0003999
2012-05-31 15:02 ludovic Status new => closed
2012-05-31 15:02 ludovic Resolution open => fixed