SOGo | BTS

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001607SOGoBackend Generalpublic2012-01-27 17:402012-02-08 15:29
ReporterGeordie 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionopen 
PlatformOSOS Version
Product Version1.3.11 
Target VersionFixed in Version 
Summary0001607: Debian Testing/Unstable unmet dependencies
Description# apt-get install sogo
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 sogo : Depends: libgnustep-base1.20 (>= 1.20.1) but it is not installable
        Depends: libmemcached5 (>= 0.33) but it is not installable
        Depends: libsope-appserver4.9 (>= 4.9.r1664.20120126) but it is not going to be installed
        Depends: libsope-core4.9 (>= 4.9.r1664.20120126) but it is not going to be installed
        Depends: libsope-gdl1-4.9 (>= 4.9.r1664.20120126) but it is not going to be installed
        Depends: libsope-ldap4.9 (>= 4.9.r1664.20120126) but it is not going to be installed
        Depends: libsope-mime4.9 (>= 4.9.r1664.20120126) but it is not going to be installed
        Depends: sope4.9-libxmlsaxdriver but it is not going to be installed
        Depends: sope4.9-db-connector

Additional InformationI tried in testing same issue. I tried each package individually, again no luck
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0003343)
jraby (viewer)
2012-01-30 14:49
edited on: 2012-01-30 14:50

We currently only provide packages for debian lenny and squeeze.
Debian testing now ships with gnustep-base 1.22 and our squeeze builds were done using gnustep-base 1.20.

libmemcached has a similiar issue: testing now ships libmemcached6 while squeeze ships limemcached5.

You could try installing libgnustep-base1.20 and libmemcached5 from squeeze, this might work.

Also, make sure to run 'apt-get update' before installing sogo from the nightly builds since we only keep the "build of the day".

(0003345)
Geordie (reporter)
2012-01-30 17:31

Well
Now isn't that a big disappointment. When I last installed SOGO 2+ years ago Squeeze was in testing. I guess the plans for getting SOGO into the Debian repositories has been placed on the back burner. That was one of the reasons I installed this program. Are there plans afoot to move this a stable and testing environment? FYI as of Feb 2 or 12th 2012 Lenny is no longer supported by Debian and from what I read today they are planning for Wheezy to become stable so I guess you are more than a little behind.
I am not a big fan of running stable mixed with testing and unstable. I have not had the best of experience with this. Testing is only 10 day old unstable. Things in my opinion work better. Also in Debian nightly builds would be classified as experimental. I am not brave enough to tackle these
Geordie
(0003397)
jraby (viewer)
2012-02-08 15:28

Well, of course Wheezy will be supported when it is released, until you'll have to run it with squeeze pkgs for memcached and gnustep.

- Issue History
Date Modified Username Field Change
2012-01-27 17:40 Geordie New Issue
2012-01-30 14:49 jraby Note Added: 0003343
2012-01-30 14:50 jraby Note Edited: 0003343
2012-01-30 17:31 Geordie Note Added: 0003345
2012-02-08 15:28 jraby Note Added: 0003397
2012-02-08 15:29 jraby Status new => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker