View Issue Details

IDProjectCategoryView StatusLast Update
0001714SOGosogo-toolpublic2012-07-23 09:39
Reporterbugfix3k Assigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0001714: user-preferences set defaults
DescriptionHi

I'm using Sogo V1.3.13 on debian squeeze 32-bit and i'm trying to set a vacation-message with the sogo-tool:

/usr/sbin/sogo-tool user-preferences set defaults iamsam sieve:sieve_pass Vacation '{"enabled": 1, "endDate": 1332313565, "ignoreLists": 1,
"autoReplyEmailAddresses": ["iamsam@...","buzzz@..."], "autoReplyText": :"Holidays....", "daysBetweenResponse": "7", "endDateEnabled": 1}'

Output:

<0x0x90e54e8[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
<0x0x90e54e8[SOGoCache]> Using host(s) 'localhost' as server(s)
/usr/sbin/sogo-tool: Uncaught exception NSRangeException, reason: Index
6 is out of range 6 (in 'objectAtIndex:')

Thx for help
Additional InformationWhen I try some others, for example:
/sogo-tool user-preferences set defaults iamsam SOGoTimeFormat "SOGoTimeFormat:%H:%M"

There are the same Results:
<0x0x9225470[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
<0x0x9225470[SOGoCache]> Using host(s) 'localhost' as server(s)
/usr/sbin/sogo-tool: Uncaught exception NSRangeException, reason: Index 5 is out of range 5 (in 'objectAtIndex:')
Tagssogo, sogo-tool

Activities

bugfix3k

bugfix3k

2012-03-21 08:55

reporter   ~0003612

Last edited: 2012-03-27 05:21

I'm sorry, the second example is wrong. Of course it should be:
sogo-tool user-preferences set defaults iamsam SOGoTimeFormat '{"SOGoTimeFormat":"%H:%M"}'

bugfix3k

bugfix3k

2012-03-28 08:35

reporter   ~0003665

Same problem with version 2.0
ludovic

ludovic

2012-05-22 13:50

administrator   ~0003948

I've just tested and it works for me as expected.

Are you sure you don't use an old version of sogo-tool?
ludovic

ludovic

2012-05-31 14:39

administrator   ~0003995

Lowering severity, no feedback received for many days.
ludovic

ludovic

2012-07-23 09:39

administrator   ~0004191

No feedback provided in many months, closing for now.

Issue History

Date Modified Username Field Change
2012-03-21 03:11 bugfix3k New Issue
2012-03-21 07:55 bugfix3k Tag Attached: sogo
2012-03-21 07:55 bugfix3k Tag Attached: sogo-tool
2012-03-21 08:55 bugfix3k Note Added: 0003612
2012-03-27 05:21 bugfix3k Note Edited: 0003612
2012-03-28 08:35 bugfix3k Note Added: 0003665
2012-05-22 13:50 ludovic Note Added: 0003948
2012-05-31 14:39 ludovic Note Added: 0003995
2012-05-31 14:39 ludovic Severity major => tweak
2012-07-23 09:39 ludovic Note Added: 0004191
2012-07-23 09:39 ludovic Status new => closed
2012-07-23 09:39 ludovic Resolution open => suspended