View Issue Details

IDProjectCategoryView StatusLast Update
0001742SOGoOpenChange backendpublic2017-05-30 15:30
ReporterjrabyAssigned Toludovic  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0001742: mails sent using the "sharing request" feature are sent to the wrong recipient
DescriptionWhen a user doesn't have access to another user's resources (AB or cal), outlook ask the user if he want to send a mail to request access.

These mails end up in the bitbucket.

Log excerpt from the ZEG:
Mar 27 16:49:01 sogo postfix/pickup[9151]: 69825F641: uid=1000 from=<sogo>
Mar 27 16:49:01 sogo postfix/cleanup[9147]: 69825F641: message-id=<20120327204901.69825F641@sogo.example.com>
Mar 27 16:49:01 sogo postfix/qmgr[25443]: 69825F641: from=<sogo@sogo.example.com>, size=576, nrcpt=1 (queue active)
Mar 27 16:49:01 sogo cyrus/lmtpunix[8905]: accepted connection
Mar 27 16:49:01 sogo cyrus/lmtpunix[8905]: lmtp connection preauth'd as postman
Mar 27 16:49:01 sogo cyrus/lmtpunix[8905]: verify_user(user.sogo) failed: Mailbox does not exist
Mar 27 16:49:01 sogo postfix/pipe[8722]: 69825F641: to=<sogo@sogo.example.com>, orig_to=<sogo>, relay=cyrus, delay=0.02, delays=0.01/0/0/0.01, dsn=5.6.0, status=bounced (data format error. Command output: sogo: Mailbox does not exist )
Mar 27 16:49:01 sogo postfix/cleanup[9147]: 6D140F640: message-id=<20120327204901.6D140F640@sogo.example.com>
Mar 27 16:49:01 sogo postfix/qmgr[25443]: 6D140F640: from=<>, size=2408, nrcpt=1 (queue active)
Mar 27 16:49:01 sogo postfix/bounce[9172]: 69825F641: sender non-delivery notification: 6D140F640
Mar 27 16:49:01 sogo postfix/qmgr[25443]: 69825F641: removed
Mar 27 16:49:01 sogo cyrus/lmtpunix[8905]: accepted connection
Mar 27 16:49:01 sogo cyrus/lmtpunix[8905]: lmtp connection preauth'd as postman
Mar 27 16:49:01 sogo cyrus/lmtpunix[8905]: verify_user(user.sogo) failed: Mailbox does not exist
Mar 27 16:49:01 sogo postfix/pipe[7139]: 6D140F640: to=<sogo@sogo.example.com>, relay=cyrus, delay=0.01, delays=0/0/0/0.01, dsn=5.6.0, status=bounced (data format error. Command output: sogo: Mailbox does not exist )
Mar 27 16:49:01 sogo postfix/qmgr[25443]: 6D140F640: removed
TagsNo tags attached.

Activities

wsourdeau

wsourdeau

2012-06-18 12:05

viewer   ~0004068

Please ellaborate, what is the "sharing feature" taht you are mentionning?
ludovic

ludovic

2012-09-05 09:55

administrator   ~0004433

Under Outlook 2010, go in the calendar view.

Click on the Folder tab (top menu).

Click on "Share Calendar"

Choose a recipient (for example, I would chose sogo2 if sogo3 is connected using OL2010).

Check either "Request permission to view recipient's calendar" or "Allow recipient to view calendar".

Click on Send.

The recipient is ALWAYS sogo@example.com - which of course is wrong.

The mail in the Sent folder is correct though.
ludovic

ludovic

2012-09-06 13:50

administrator   ~0004447

This bug is still there even if 0001943 is fixed.
ludovic

ludovic

2012-09-12 11:27

administrator   ~0004472

The mail log trace has nothing to do with SOGo/Outlook not sending notifications. These are caused by cronjobs running as the sogo user!

Setting SOGoACLsSendEMailNotifications to YES doesn't trigger notification so this feature is clearly not implemented.

Lowering the priority for the release.
ludovic

ludovic

2017-05-30 15:30

administrator   ~0011880

OpenChange is dead - setting for removal from SOGo.

Issue History

Date Modified Username Field Change
2012-03-27 16:54 jraby New Issue
2012-06-18 12:05 wsourdeau Note Added: 0004068
2012-07-25 16:08 ludovic Target Version => 2.0
2012-09-05 09:55 ludovic Note Added: 0004433
2012-09-06 13:50 ludovic Note Added: 0004447
2012-09-12 11:27 ludovic Note Added: 0004472
2012-09-12 11:27 ludovic Product Version trunk =>
2012-09-12 11:27 ludovic Target Version 2.0 =>
2012-10-03 11:11 wsourdeau Project SOGo Native Outlook Compatibility (obsolete) => SOGo
2012-10-03 11:12 wsourdeau Category => OpenChange backend
2017-05-30 15:30 ludovic Note Added: 0011880
2017-05-30 15:30 ludovic Status new => resolved
2017-05-30 15:30 ludovic Resolution open => suspended
2017-05-30 15:30 ludovic Assigned To => ludovic