View Issue Details

IDProjectCategoryView StatusLast Update
0001747SOGo Connectorpublic2018-03-16 14:28
Reportertoerned Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0001747: Connector + Address Book client + Apple Adressbookserver do not sync
DescriptionClient 0000001
Thunderbird 11.0.1 + Inverse SOGo connector 10.0.1

Client 0000002
Apple Address Book 5.0.3 (883) on Mac OS X 10.6.8

Server
Apple Addressbook server / CalDAV on Mac OS X 10.7.3, configured with a Push certificate and an internal SSL cert for addressbook server.

Ok:
1. Creating a new contact in Thunderbird immediately pushes that contact to the Apple Address book, including the notice "X-MOZILLA-HTML: FALSE" in the description field.

Not ok:
2. Updating an existing contact in thunderbird does not propagate to Apple Address book.
3. Contacts created in Apple Address book are never synced to Thunderbird.

Note: Thunderbird has been configured by copying the Address Book DAV url from access.log, it looks like this "https://host.domain.tld:8443/addressbooks/__uids__/C4E5682D-7875-49BA-A063-CF3468F43B49/addressbook/"
Additional InformationAddress book server error.log:

2012-03-31 00:16:54+0200 [-] [mailgateway] 2012-03-31 00:16:54+0200 [IMAP4DownloadProtocol,client] Unhandled unsolicited response: ['OK', ['URLMECH', 'INTERNAL'], 'Mechanisms', 'supported']
2012-03-31 00:16:57+0200 [-] [caldav-0] [PooledMemCacheProtocol,client] [twistedcaldav.method.put_addressbook_common#error] Cannot overwrite vcard resource C52CC8ED-31D0-0001-4910-AA42F5101C9A.vcf with different UID C52CC8ED-35D0-0001-F1B2-1A6699BF1A20
2012-03-31 00:17:04+0200 [-] [caldav-0] [PooledMemCacheProtocol,client] [twistedcaldav.method.put_addressbook_common#error] Cannot overwrite vcard resource C52CC8ED-31D0-0001-4910-AA42F5101C9A.vcf with different UID C52CC8ED-35D0-0001-F1B2-1A6699BF1A20
2012-03-31 00:17:25+0200 [-] [mailgateway] 2012-03-31 00:17:25+0200 [IMAP4DownloadProtocol,client] Unhandled unsolicited response: ['OK', ['HIGHESTMODSEQ', '1'], 'Highest']
2012-03-31 00:17:25+0200 [-] [mailgateway] 2012-03-31 00:17:25+0200 [IMAP4DownloadProtocol,client] Unhandled unsolicited response: ['OK', ['URLMECH', 'INTERNAL'], 'Mechanisms', 'supported']
2012-03-31 00:17:33+0200 [-] [caldav-1] [PooledMemCacheProtocol,client] [twext.web2.dav.method.propfind#error] File not found: <RootResource: /Library/Server/Calendar and Contacts/Documents/directory>
TagsNo tags attached.

Activities

ludovic

ludovic

2018-03-16 14:28

administrator   ~0012739

Ancient stuff.

Issue History

Date Modified Username Field Change
2012-03-30 18:28 toerned New Issue
2012-08-27 16:32 ludovic Project Funambol SOGo Connector => SOGo Connector
2018-03-16 14:28 ludovic Note Added: 0012739
2018-03-16 14:28 ludovic Status new => closed
2018-03-16 14:28 ludovic Assigned To => ludovic
2018-03-16 14:28 ludovic Resolution open => suspended