View Issue Details

IDProjectCategoryView StatusLast Update
0001802SOGoBackend Calendarpublic2012-05-16 15:04
Reportersebblin Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version1.3.14 
Target VersionFixed in Version 
Summary0001802: doesn't send email notifications when creating or modifying appointments
Description

Everything seems ok, but it does not work.

That doesn't send email notifications when creating or modifying appointments.


sogo@sogo:~$ defaults read sogod SOGoAppointmentSendEMailNotifications
sogod SOGoAppointmentSendEMailNotifications YES
sogo@sogo:~$ defaults read sogod SOGoEnableEMailAlarms
sogod SOGoEnableEMailAlarms YES


The cron /etc/cron.d /sogo is already executed as user sogo.

In Webmin --> Scheduled Cron Jobs, i see :

User Active? Command
sogo Yes /usr/sbin/sogo-ealarms-notify

Here /usr/sbin/sogo-ealarms-notify suggests that eMail alarms are disabled in
the SOGo configuration !!!???


As root from command line:

/usr/sbin/sogo-ealarms-notify
2012-04-30 09:30:28.840 sogo-ealarms-notify[32575] EMail alarms are disabled in
the SOGo configuration.

TagsNo tags attached.

Activities

chrroessner

chrroessner

2012-05-11 09:24

reporter   ~0003893

I can confirm this bug on my system, too.

Mail notifications are not sent.

Even after defining a notification, I can check the PostgreSQL table and see that there has not be made any insertion.

But the notify symbol is shown in the web interface.

francis

francis

2012-05-15 11:40

administrator   ~0003901

Is your workstation timezone the same as the timezone defined in your personal SOGo preferences?

chrroessner

chrroessner

2012-05-15 13:20

reporter   ~0003902

sogo ~ # date
Tue May 15 18:51:42 CEST 2012

sogod SOGoTimeZone Europe/Berlin

And on my Mac, too.

I just saw this while typing into this text field:

May 15 19:19:20 sogod [13154]: [ERROR] <0x01207620[SOGoAppointmentFolder]:personal> DAV property '{urn:ietf:params:xml:ns:caldav}schedule-tag' has no matching SQL field, response could be incomplete

Could it be that my tables are broken?

chrroessner

chrroessner

2012-05-15 13:30

reporter   ~0003903

I dropped the alarms table and restarted sogo. The table got recreated and after doing a new test, there are still no entries:

select * from sogo_alarms_folder;
c_path | c_name | c_uid | c_recurrence_id | c_alarm_number | c_alarm_date
--------+--------+-------+-----------------+----------------+--------------
(0 rows)

wsourdeau

wsourdeau

2012-05-15 13:38

viewer   ~0003904

Can you provide us with a copy of your event ics?

ludovic

ludovic

2012-05-15 13:38

administrator   ~0003905

sebblin, have you set OCSEMailAlarmsFolderURL in your configuration?

chrroessner, have you created a test event in the future and not in the past?

chrroessner

chrroessner

2012-05-15 13:47

reporter   ~0003906

sogo=> select c_content from sogocroessne00138e9c6a7 where c_creationdate='1337102889';
c_content

BEGIN:VCALENDAR\r
VERSION:2.0\r
PRODID:-//Inverse inc./SOGo 2.0.0//EN\r
BEGIN:VEVENT\r
UID:3574-4FB29200-1-2A6DA400\r
SUMMARY:Neuer Test\r
DESCRIPTION:Test\r
CLASS:PUBLIC\r
CREATED:20120515T172809Z\r
DTSTAMP:20120515T172809Z\r
LAST-MODIFIED:20120515T172809Z\r
BEGIN:VALARM\r
TRIGGER;VALUE=DURATION;X-WEBSTATUS=triggered:-PT30M\r
ACTION:DISPLAY\r
END:VALARM\r
DTSTART;TZID=Europe/Berlin:20120515T200000\r
DTEND;TZID=Europe/Berlin:20120515T210000\r
TRANSP:OPAQUE\r
END:VEVENT\r
BEGIN:VTIMEZONE\r
TZID:Europe/Berlin\r
X-LIC-LOCATION:Europe/Berlin\r
BEGIN:DAYLIGHT\r
TZOFFSETFROM:+0100\r
TZOFFSETTO:+0200\r
TZNAME:CEST\r
DTSTART:19700329T020000\r
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU\r
END:DAYLIGHT\r
BEGIN:STANDARD\r
TZOFFSETFROM:+0200\r
TZOFFSETTO:+0100\r
TZNAME:CET\r
DTSTART:19701025T030000\r
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU\r
END:STANDARD\r
END:VTIMEZONE\r
END:VCALENDAR
(1 row)

This one is not in the future :) Not yet. Maybe when you have read it

chrroessner

chrroessner

2012-05-15 14:03

reporter   ~0003907

I have to mention that I have one thing different in my Apache configuration:

FIX for http://www.sogo.nu/bugs/view.php?id=1203

    RequestHeader unset Accept-Encoding

    AddOutputFilterByType SUBSTITUTE text/calendar text/xml
    Substitute 's|^RRULE:([A-Z].+[A-Za-z0-9]);?FREQ=([A-Za-z]*);?(.*)$|RRULE:FREQ=$2;$1$3|'

Everything else is done as described in the documentation.

chrroessner

chrroessner

2012-05-15 15:31

reporter   ~0003908

I removed the substitute stuff and tested again with an event on May, 16th in Firefox 10.0.4-ESR, no luck.

wsourdeau

wsourdeau

2012-05-15 15:47

viewer   ~0003909

Ok, from the content the problem is clear. The VALARM has its ACTION set to "DISPLAY". For email alarms, the ACTION must be "EMAIL" in order to enable email alarms....

chrroessner

chrroessner

2012-05-15 17:23

reporter   ~0003911

From your answer the problem is clear, too. :)

Solution:

When defining a new entry in the WebGUI and you add a reminder, have a look at "user defined" (<- don't know, in German it is Benutzerdefiniert). Only there you will find option to send an email notification. That was not quite clear for me as a regular user.

           c_path               |            c_name            |          c_uid           | c_recurrence_id | c_alarm_number | c_alarm_date 

------------------------------------+------------------------------+--------------------------+-----------------+----------------+--------------
/Users/croessner/Calendar/personal | 3805-4FB2C800-5-4EB3F600.ics | 3805-4FB2C800-5-4EB3F600 | 0 | 0 | 1337144400
(1 row)

sebblin

sebblin

2012-05-16 04:43

reporter   ~0003913

@ludovic

I have set OCSEMailAlarmsFolderURL in my configuration.

OCSEMailAlarmsFolderURL = "mysql://sogo:*****@127.0.0.1:3306/sogo/sogo_alarms_folder";

In the table "sogo_alarls_folder", no index is defined, is this normal?

Unlike chrroessner my problem is not solved.

I didn 't "ACTION" in the event ics.

BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Paris
X-LIC-LOCATION:Europe/Paris
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20120516T083219Z
LAST-MODIFIED:20120516T083232Z
DTSTAMP:20120516T083232Z
UID:d673f1c8-717b-4bc2-83bf-de7f9e3ec5f8
SUMMARY:test
DTSTART;TZID=Europe/Paris:20120518T141500
DTEND;TZID=Europe/Paris:20120518T151500
DESCRIPTION:test
END:VEVENT
END:VCALENDAR

2012-05-16 08:54

 

francis

francis

2012-05-16 08:55

administrator   ~0003915

@sebblin you absolutely need to set the alarm from the web interface (see attached screenshot).

sebblin

sebblin

2012-05-16 10:24

reporter   ~0003916

Ok thank you, by cons why does not send a mail automatically without making that?

In thunderbird, it is not possible apparently.

francis

francis

2012-05-16 15:04

administrator   ~0003919

It's not currently possible to automatically set predefined alarms to events.

Issue History

Date Modified Username Field Change
2012-05-11 09:12 sebblin New Issue
2012-05-11 09:24 chrroessner Note Added: 0003893
2012-05-14 03:31 Christian Mack Severity block => major
2012-05-14 03:31 Christian Mack Category Packaging (Debian) => Backend Calendar
2012-05-15 11:40 francis Note Added: 0003901
2012-05-15 13:20 chrroessner Note Added: 0003902
2012-05-15 13:30 chrroessner Note Added: 0003903
2012-05-15 13:38 wsourdeau Note Added: 0003904
2012-05-15 13:38 ludovic Note Added: 0003905
2012-05-15 13:47 chrroessner Note Added: 0003906
2012-05-15 14:03 chrroessner Note Added: 0003907
2012-05-15 15:31 chrroessner Note Added: 0003908
2012-05-15 15:47 wsourdeau Note Added: 0003909
2012-05-15 17:23 chrroessner Note Added: 0003911
2012-05-16 04:43 sebblin Note Added: 0003913
2012-05-16 08:54 francis File Added: sogo-event-email-reminder.png
2012-05-16 08:55 francis Note Added: 0003915
2012-05-16 10:24 sebblin Note Added: 0003916
2012-05-16 15:04 francis Note Added: 0003919
2012-05-16 15:04 francis Status new => closed
2012-05-16 15:04 francis Resolution open => no change required