SOGo | BTS

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001850SOGoBackend Calendarpublic2012-06-26 07:532013-01-09 14:10
Reporternetphantm 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.3.16 
Target Version2.0.4Fixed in Version2.0.4 
Summary0001850: events accepted in the webGUI or in lightning still appear as "needs action" (dashed outline) in iCal
DescriptionEven if the attendee accepts an event through Lightning or the webGUI, iCal still displays it with dashed outlines and greyed out in the attendee's calendar. He is still asked for an action, but the green "accepted" symbol is there already.
If I manually remove the RSVP=TRUE flag in the db record, the event appears as accepted (after removing/adding his calendar account again).
We use sogo v. 1.3.16 with the patch from http://www.sogo.nu/bugs/view.php?id=1839 [^]
Additional Informationcreate meeting:

BEGIN:VCALENDAR
PRODID:-//Apple Inc.//iCal 4.0.4//EN
VERSION:2.0
CALSCALE:GREGORIAN
BEGIN:VTIMEZONE
TZID:Europe/Berlin
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZNAME:GMT+02:00
TZOFFSETTO:+0200
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
DTSTART:19810329T020000
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZNAME:GMT+01:00
TZOFFSETTO:+0100
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
DTSTART:19961027T030000
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
UID:E3F2B64A-6AAF-4070-B52E-B49378402E87
DTSTAMP:20120626T085800Z
TRANSP:OPAQUE
CREATED:20120626T085756Z
SUMMARY:test
SEQUENCE:2
DTEND;TZID=Europe/Berlin:20120627T140000
DTSTART;TZID=Europe/Berlin:20120627T133000
END:VEVENT
END:VCALENDAR


invite foo:

BEGIN:VCALENDAR
PRODID:-//Apple Inc.//iCal 4.0.4//EN
VERSION:2.0
CALSCALE:GREGORIAN
BEGIN:VTIMEZONE
TZID:Europe/Berlin
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZNAME:GMT+02:00
TZOFFSETTO:+0200
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
DTSTART:19810329T020000
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZNAME:GMT+01:00
TZOFFSETTO:+0100
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
DTSTART:19961027T030000
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
UID:E3F2B64A-6AAF-4070-B52E-B49378402E87
DTSTAMP:20120626T085859Z
TRANSP:OPAQUE
CREATED:20120626T085756Z
SUMMARY:test
ORGANIZER;CN=Bruno Lingner:mailto:bruno.lingner@kochan.de
SEQUENCE:4
DTEND;TZID=Europe/Berlin:20120627T140000
DTSTART;TZID=Europe/Berlin:20120627T133000
ATTENDEE;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIPANT;EMAIL=foo.bar@kochan.de
 ;CN=Foo Bär;CUTYPE=INDIVIDUAL;RSVP=TRUE:mailto:foo.bar@kochan.de
END:VEVENT
END:VCALENDAR


foo accepts in the webGUI:

BEGIN:VCALENDAR
PRODID:-//Apple Inc.//iCal 4.0.4//EN
VERSION:2.0
CALSCALE:GREGORIAN
BEGIN:VTIMEZONE
TZID:Europe/Berlin
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZNAME:GMT+02:00
TZOFFSETTO:+0200
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
DTSTART:19810329T020000
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZNAME:GMT+01:00
TZOFFSETTO:+0100
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
DTSTART:19961027T030000
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
UID:E3F2B64A-6AAF-4070-B52E-B49378402E87
DTSTAMP:20120626T085859Z
TRANSP:OPAQUE
CREATED:20120626T085756Z
SUMMARY:test
ORGANIZER;CN=Bruno Lingner:mailto:bruno.lingner@kochan.de
SEQUENCE:4
DTEND;TZID=Europe/Berlin:20120627T140000
DTSTART;TZID=Europe/Berlin:20120627T133000
ATTENDEE;EMAIL=foo.bar@kochan.de;RSVP=TRUE;CUTYPE=INDIVIDUAL;CN=Foo Bär;ROL
 E=REQ-PARTICIPANT;PARTSTAT=ACCEPTED:mailto:foo.bar@kochan.de
END:VEVENT
END:VCALENDAR


foo accepts again in iCal, his db record looks now like this:

BEGIN:VCALENDAR
PRODID:-//Apple Inc.//iCal 4.0.4//EN
VERSION:2.0
CALSCALE:GREGORIAN
BEGIN:VTIMEZONE
TZID:Europe/Berlin
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZNAME:GMT+02:00
TZOFFSETTO:+0200
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
DTSTART:19810329T020000
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZNAME:GMT+01:00
TZOFFSETTO:+0100
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
DTSTART:19961027T030000
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
UID:E3F2B64A-6AAF-4070-B52E-B49378402E87
DTSTAMP:20120626T085859Z
TRANSP:OPAQUE
CREATED:20120626T085756Z
SUMMARY:test
ORGANIZER;CN="Bruno Lingner":mailto:bruno.lingner@kochan.de
SEQUENCE:4
DTEND;TZID=Europe/Berlin:20120627T140000
ATTENDEE;CN="Foo Bär";CUTYPE=INDIVIDUAL;EMAIL="foo.bar@kochan.de";PARTST
 AT=ACCEPTED;ROLE=REQ-PARTICIPANT:mailto:foo.bar@kochan.de
DTSTART;TZID=Europe/Berlin:20120627T133000
END:VEVENT
END:VCALENDAR
TagsNo tags attached.
Attached Filespng file icon Bildschirmfoto 2013-01-09 um 14.55.45.png [^] (12,195 bytes) 2013-01-09 08:58

- Relationships Relation Graph ] Dependency Graph ]
related to 0001839closedludovic Events on iCal appear dashed after an attendee accepts 

-  Notes
User avatar (0005008)
ludovic (administrator)
2012-11-30 14:18

Fixed - see: https://github.com/inverse-inc/sogo/commit/eed17fd95abdbe421f870dc112abac71d67971d7 [^]

Can you please try the upcoming nightly build (available in about 12 hours from now) and tell me if it fixes the issue?

Thanks!
User avatar (0005009)
ludovic (administrator)
2012-11-30 15:46

One more commit was made regarding this bug: https://github.com/inverse-inc/sogo/commit/5500f99312988721524c4ba003a66eb3a968afda [^]
(0005094)
netphantm (reporter)
2013-01-09 08:53

if the invitee is a resource or a location and it auto accepts the event, then the RSVP flag still is left set:

....
ORGANIZER;ROLE=CHAIR;PARTSTAT=ACCEPTED;CN=Bruno Lingner;RSVP=TRUE:mailto:br
 uno.lingner@kochan.de
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=ACCEPTED;CN=Aquathek;RSVP=TRUE:mailt
 o:mm.aquathek@kochan.de
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=ACCEPTED;CN=Beamer;RSVP=TRUE:mailto:
 mm.beamer@kochan.de
....
User avatar (0005113)
ludovic (administrator)
2013-01-09 14:10

Fix pushed: https://github.com/inverse-inc/sogo/commit/c7fbcb0fc430f4391f5539d9142cbcff4df16e32 [^]

- Issue History
Date Modified Username Field Change
2012-06-26 07:53 netphantm New Issue
2012-10-17 09:32 Christian Mack Relationship added duplicate of 0001839
2012-10-17 09:35 Christian Mack Relationship deleted 0001839
2012-10-17 09:35 Christian Mack Relationship added related to 0001839
2012-11-21 15:44 ludovic Target Version => 2.0.3
2012-11-30 14:18 ludovic Note Added: 0005008
2012-11-30 14:18 ludovic Status new => closed
2012-11-30 14:18 ludovic Resolution open => fixed
2012-11-30 14:18 ludovic Fixed in Version => 2.0.3
2012-11-30 15:46 ludovic Note Added: 0005009
2013-01-09 08:53 netphantm Note Added: 0005094
2013-01-09 08:53 netphantm Status closed => feedback
2013-01-09 08:53 netphantm Resolution fixed => reopened
2013-01-09 08:58 netphantm File Added: Bildschirmfoto 2013-01-09 um 14.55.45.png
2013-01-09 09:01 ludovic Target Version 2.0.3 => 2.0.4
2013-01-09 14:10 ludovic Note Added: 0005113
2013-01-09 14:10 ludovic Status feedback => closed
2013-01-09 14:10 ludovic Resolution reopened => fixed
2013-01-09 14:10 ludovic Fixed in Version 2.0.3 => 2.0.4


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker