View Issue Details

IDProjectCategoryView StatusLast Update
0001907SOGo Native Outlook Compatibility (obsolete)public2012-08-07 15:23
Reporterfmelison Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0beta4 
Target VersionFixed in Version 
Summary0001907: Cannot Build Sogo openchange backend
Description

Compiling file MAPIStoreSOGo.m ...
MAPIStoreSOGo.m: In function 'sogo_backendinit':
MAPIStoreSOGo.m:101: error: 'environ' undeclared (first use in this function)
MAPIStoreSOGo.m:101: error: (Each undeclared identifier is reported only once
MAPIStoreSOGo.m:101: error: for each function it appears in.)
gmake[3]: [obj/MAPIStoreSOGo.obj/MAPIStoreSOGo.m.o] Error 1
gmake[2]:
[internal-library-all
] Error 2
gmake[1]: [MAPIStoreSOGo.all.library.variables] Error 2
gmake:
[internal-all] Error 2

Additional Information

If I dig into the MAPIStoreSOGo.m, though until now I've never met objective-c source code (C, C++, php are more common to me), I can clearly understand that the method "sogo_backend_init" calls the function "NSProcessInfo" with 3 arguments and the third of them "environ" variable is undeclared. The same could be said about the next called function "SOGoSystemDefaults" which has only one parameter "sharedSystemDefaults" which is undeclared too (if I only look at the method block).
If I dig a bit more I can find "sharedSystemDefaults" in one of the import files (physically in file ../SoObjects/SOGo/SOGoSystemDefaults.h) declared in the headers : "" which declares this "+ (SOGoSystemDefaults *) sharedSystemDefaults;" and makes me think that sharedSystemDefaults is a class SOGoSystemDefaults object pointer and that it is a global object (?).
Could it be the same for variable "environ". But I haven't yet found this declaration (generally a global variable or object is in caps letters but not mandatory at all).
If it is the case, maybe the problem is only related to header import files (or include) not found (or some compilation clauses which are not set properly)?
If not, ... it's something else I cannot solve by myself (without spending a huge time on it) cause I'm very new to the arcanes of objective-C and SOGo project.

TagsNo tags attached.

Activities

oooo1

oooo1

2012-08-01 08:19

reporter   ~0004239

As I know the current version of Openchange trunk is incompatible with Openchange SoGo plug-in at the moment, you should use Openchange version from SOGo website.

fmelison

fmelison

2012-08-01 09:07

reporter   ~0004241

I didn't think I could get an answer so fast...

Yes, I've read that on some other posts but this isn't the case. In fact when I wrote this report I've made some precisions about my configuration but when I submitted the whole post it failed. So I created a new one, copying and pasting, but I missed the 2 or 3 first lines where those precisions were made...
So I rewrite them (extensively):

I've build the whole thing on FreeBSD 9.0: ports (the easy part), SOPE 2.0.0rc4 (I began to meet problems with it), then samba4 (which is part of openchange-sogo-2.0.0rc4) through "script/installsamba" of openchange (I've struggled a lot of time with samba4 mainly due to bad headers and some other tricks) And sogo-2.0.0rc4 (all downloaded from sogo web page http://www.sogo.nu/english/downloads/backend.html and not from openchange web site).
Sogo itself was easy (only 1 or 2 problems to solve) to build compared to samba and openchange. When I believed that all was OK, I was planning to the configuration part but discovered that I had to build an other part of openchange (what is called "sogo openchange backend") in the sogo source tree and it is there that I've got the reported problem.
So the Openchange sogo plug-in should be the good one...
In reality, there are 2 openchange things when building the whole thing:

  • One which is in the tgz file openchange-sogo-2.0.0rc4.tar.gz (which tree contains samba4 among others)
  • One in the sogo source tree (SOGo-2.0.0rc4.tar.gz): openchange subfolder.

And I followed the howto held in http://www.sogo.nu/files/docs/SOGo%20Native%20Microsoft%20Outlook%20Configuration.pdf where I'm stuck on "SOGo OpenChange backend".

ludovic

ludovic

2012-08-07 15:23

administrator   ~0004290

Pull the latest version of the source code for OpenChange (sogo branch) and SOGo/SOPE if you want to build things. Don't use RC4 anymore.

Issue History

Date Modified Username Field Change
2012-08-01 06:13 fmelison New Issue
2012-08-01 08:19 oooo1 Note Added: 0004239
2012-08-01 09:07 fmelison Note Added: 0004241
2012-08-07 15:23 ludovic Note Added: 0004290
2012-08-07 15:23 ludovic Status new => closed
2012-08-07 15:23 ludovic Resolution open => fixed