View Issue Details

IDProjectCategoryView StatusLast Update
0002082SOGoWeb Preferencespublic2012-11-30 10:30
Reportersim Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.2 
Target Version2.0.3Fixed in Version2.0.3 
Summary0002082: SOGo uses imapflags instead of imap4flags
DescriptionSOGo seems to use the deprecated imapflags instead of imap4flags. This breaks filters. Either tagging functionality needs to be removed or updated to use imap4flags.
Additional Information2012-10-30 13:01:24.350 sogod[13702] Could not upload Sieve script: {RawResponse = "{ok = 0; reason = \"sogo: line 1: error: require command: unknown Sieve capability 'imapflags'.
TagsNo tags attached.

Activities

krpi

krpi

2012-11-28 05:12

reporter   ~0004997

I had same problem with dovecot.
This helped me: http://wiki.dovecot.org/LDA/Sieve/Dovecot#Migration_from_CMUSieve

I added to config:

plugin {
 sieve_extensions = +notify +imapflags
}
sim

sim

2012-11-28 19:03

reporter   ~0004998

That is the work around anyone is using with dovecot. However, AFAIK, imapflags is deprecated. It's not good coding to deprecated standards. Since there was no bug report for it, I made one.
ludovic

ludovic

2012-11-30 10:30

administrator   ~0005003

Fixed - see: https://github.com/inverse-inc/sogo/commit/47a9a22bc02ac4dbfbcb9d30eae2643773e9a6fa

Issue History

Date Modified Username Field Change
2012-10-30 00:42 sim New Issue
2012-11-28 05:12 krpi Note Added: 0004997
2012-11-28 19:03 sim Note Added: 0004998
2012-11-29 07:29 ludovic Target Version => 2.0.3
2012-11-30 10:30 ludovic Note Added: 0005003
2012-11-30 10:30 ludovic Status new => closed
2012-11-30 10:30 ludovic Resolution open => fixed
2012-11-30 10:30 ludovic Fixed in Version => 2.0.3