SOGo | BTS

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002270SOGoWeb Mailpublic2013-03-18 06:302013-09-27 15:38
ReporterLudovic Hutin 
Assigned Toludovic 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.0.4b 
Target Version2.1.0Fixed in Version2.1.0 
Summary0002270: Problem with mimetype image/pdf
DescriptionWe got a strange problem with pdf files. The file is in the mail,
but we can't see them. (With the last version, it's the same).

    Sometimes we got some attachment like that

------=_=-_OpenGroupware_org_NGMime-6469-1363274063.976003-0------
content-type: image/pdf
content-transfer-encoding: base64
content-length: 80523
content-disposition: inline; filename="MYFILE.pdf"

    And this attachment are not visible on the Web interface. Is
there a way to show them ?

    Probably a mime-type problem ?

    When you have no way to fix the sender side, i think the Web
Interface of SOGo should (at least) show the attachment. In this
situation you can't save the file.
    With Thunderbird, there is no problem you can download the file and
open it.
TagsNo tags attached.
Attached Files? file icon mail [^] (12,551 bytes) 2013-03-18 09:45 [Show Content]
txt file icon log_sogo.txt [^] (5,402 bytes) 2013-09-10 11:29 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
User avatar (0005425)
ludovic (administrator)
2013-03-18 07:16

Please attach a sample mail to this ticket.
(0005426)
Ludovic Hutin (reporter)
2013-03-18 09:56

The problem affect only Firefox, with Chrome with got an icon, and we can at least download the pdf file.
User avatar (0005509)
ludovic (administrator)
2013-04-10 15:57

The problem is the content-type.

image/pdf isn't good, and it was provided by Thunderbird.

You can still save the file by clicking on the small icon and choosing "save as..."
(0005514)
Ludovic Hutin (reporter)
2013-04-11 08:56

<quote>You can still save the file by clicking on the small icon and choosing "save as..."</quote>

With Firefox you have no small icon...
(0005965)
jem555 (reporter)
2013-09-10 11:28

Hi. Same here. I received a mail that was sent using Microsoft Outlook 2010 with a pdf file attached. I cannot see the email preview in SOGO web interface neither open the message. Although I can select "Save as..." on that mail, open the "Saved messages.zip", then open the .eml file and there is my pdf file.

Content-type: image/pdf

I'm with Firefox and Chrome...same issue.

Hope it helps.
User avatar (0006066)
ludovic (administrator)
2013-09-27 15:38

https://github.com/inverse-inc/sogo/commit/84e999229bd2e0ca5c76b613dbfab7b15432bfcc [^]

- Issue History
Date Modified Username Field Change
2013-03-18 06:30 Ludovic Hutin New Issue
2013-03-18 07:16 ludovic Note Added: 0005425
2013-03-18 09:45 Ludovic Hutin File Added: mail
2013-03-18 09:56 Ludovic Hutin Note Added: 0005426
2013-04-05 14:38 ludovic Target Version => 2.0.5
2013-04-10 15:57 ludovic Note Added: 0005509
2013-04-10 15:57 ludovic Status new => resolved
2013-04-10 15:57 ludovic Resolution open => won't fix
2013-04-10 15:57 ludovic Assigned To => ludovic
2013-04-11 08:56 Ludovic Hutin Note Added: 0005514
2013-04-11 08:56 Ludovic Hutin Status resolved => feedback
2013-04-11 08:56 Ludovic Hutin Resolution won't fix => reopened
2013-04-11 15:48 ludovic Target Version 2.0.5 => soon
2013-09-10 11:28 jem555 Note Added: 0005965
2013-09-10 11:29 jem555 File Added: log_sogo.txt
2013-09-27 15:37 ludovic Target Version soon => 2.1.0
2013-09-27 15:38 ludovic Note Added: 0006066
2013-09-27 15:38 ludovic Status feedback => closed
2013-09-27 15:38 ludovic Resolution reopened => fixed
2013-09-27 15:38 ludovic Fixed in Version => 2.1.0


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker