View Issue Details

IDProjectCategoryView StatusLast Update
0002297SOGoOpenChange backendpublic2015-05-25 15:50
Reporteronofabio Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0002297: Entire day events
DescriptionHello sogo users,
I have wrong behavior on Entire day events.

All my devices is configurated with same timezone.

If I create a all day appointment on outlook and sync with server, on sogo webmail I see event one day before.

If I create a all day appointment on sogo webmail, on outlook I see event correctly.

VCal of event in database is wrong (by outlook).
An event created at 19th April 2013 (today) have fields:
DTSTART:20130418
DTEND:20130419
TagsNative Outlook Compatibility

Activities

onofabio

onofabio

2013-09-25 09:23

reporter   ~0006036

Same problem with sogo 2.1.0.20130924-1

DTSTART field has 1 day before event date.
onofabio

onofabio

2014-03-27 10:34

reporter   ~0006788

Any news about this bug?

Also in 2.2.2 version same problem.
vendafo

vendafo

2014-03-27 10:51

reporter   ~0006790

Hi. Just found this which suggests problems between platforms because of lack of clarity in RFC 2445:

http://www.bedework.org/trac/bedework/wiki/Bedework/DevDocs/DtstartEndNotes
ludovic

ludovic

2015-05-25 15:50

administrator   ~0008532

Retry with v2.3. Reopen if necessary.

Issue History

Date Modified Username Field Change
2013-04-19 08:53 onofabio New Issue
2013-04-19 09:07 onofabio Tag Attached: Native Outlook Compatibility
2013-09-25 09:23 onofabio Note Added: 0006036
2014-03-27 10:34 onofabio Note Added: 0006788
2014-03-27 10:51 vendafo Note Added: 0006790
2015-05-25 15:50 ludovic Note Added: 0008532
2015-05-25 15:50 ludovic Status new => resolved
2015-05-25 15:50 ludovic Resolution open => suspended
2015-05-25 15:50 ludovic Assigned To => ludovic