SOGo | BTS

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002312SOGoBackend Mailpublic2013-05-10 08:472013-11-20 02:47
ReporterLudovic Hutin 
Assigned Tojraby 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformOSOS Version
Product Version2.0.5 
Target VersionsoonFixed in Version 
Summary0002312: Impossible to remove a or read a folder with particular symbol.
DescriptionHello,

    We found a new bug, if you create a folder with this symbol "<" or ">", you will not be able to delete this one. You will always get an error. If you have mail inside, you can't see them.

    I create a folder like that "TEST<", and when i want to delete them, it's impossible.

    In the log we can see that :

?May 10 14:38:10 sogod [16282]: [ERROR] <0x0x7f9948bf08f0[NGImap4Connection]> could not select URL: imap://ludovic.hutin@XXXXXXXXXXXXXXXXXX/INBOX/TEST%26lt%3B/: {RawResponse = "{ResponseResult = {description = \"Mailboxdoesn't exist: TEST&-lt;\"; result = no; tagId = 25; }; }"; reason = "Mailbox doesn't exist: TEST&-lt;"; result= 0; }

   This is probably no "html decode"

Best regards,
Ludovic.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
User avatar (0005670)
ludovic (administrator)
2013-06-19 15:54

How have you created that folder in the first place?

What IMAP server are you using?

Please provide me a tcpflow trace (IMAP) when you want to create it from SOGo. One more when you want to select it and one more when you want to delete it.
(0005675)
Ludovic Hutin (reporter)
2013-06-20 03:18

We create them with the SOGo interface.
We use Dovecot dovecot-imapd 1:1.2.9-1ubuntu6.5

I send you in private the tcpdump with the 3 actions.
User avatar (0006139)
ludovic (administrator)
2013-10-18 16:18

Can you still reproduce that bug with a night build of SOGo and SOPE?
User avatar (0006241)
ludovic (administrator)
2013-11-19 11:53

No feedback provided in more than month, closing.
(0006244)
Ludovic Hutin (reporter)
2013-11-20 02:47

I try with de 2.1.0 version and the problem is here.

A folder who start with a "<" is not shown on the web interface.
A folder with ">" is shown, but impossible to delete.

- Issue History
Date Modified Username Field Change
2013-05-10 08:47 Ludovic Hutin New Issue
2013-05-24 07:41 ludovic Target Version => 2.0.6
2013-06-03 10:51 lcharland Status new => assigned
2013-06-03 10:51 lcharland Assigned To => lcharland
2013-06-19 15:54 ludovic Note Added: 0005670
2013-06-19 15:54 ludovic Target Version 2.0.6 => soon
2013-06-20 03:18 Ludovic Hutin Note Added: 0005675
2013-09-27 10:10 ludovic Assigned To lcharland => jraby
2013-10-18 16:18 ludovic Note Added: 0006139
2013-10-22 11:33 ludovic Severity block => minor
2013-10-28 15:40 ludovic Status assigned => feedback
2013-11-19 11:53 ludovic Note Added: 0006241
2013-11-19 11:53 ludovic Status feedback => closed
2013-11-19 11:53 ludovic Resolution open => no change required
2013-11-20 02:47 Ludovic Hutin Note Added: 0006244
2013-11-20 02:47 Ludovic Hutin Status closed => feedback
2013-11-20 02:47 Ludovic Hutin Resolution no change required => reopened


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker