View Issue Details

IDProjectCategoryView StatusLast Update
0002425SOGoWeb Mailpublic2017-03-01 11:24
Reporterdani Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0.7 
Target VersionFixed in Version3.2.8 
Summary0002425: Invalid "no recipient" warning when sending mail with CAS authentication
DescriptionWhen using CAS authentication, there's a bug checking recipient of a mail. Event if the mail has valid recipient(s), we have a popup asking to enter at least one recipient.

To trigger this:

- Configure SOGo to use CAS authentication
- Open the mail composer, add one or more valid recipient
- Wait a few minutes with the mail editor open (wait at least SOGoCacheCleanupInterval seconds)
- Try to send the mail

When the popup is triggered, you just have to click ok and send again, and this time it works

I haven't debuged this, but it looks like clicking on "Send" should first send a GET request in order to renew the ticket
Additional InformationRising the SOGoCacheCleanupInterval parameter can mitigate the issue (for example, using 1800 instead of the default 300 seconds will let users up to 30 minutes writing their mail before they'll hit this bug)
TagsNo tags attached.

Relationships

related to 0001456 resolvedludovic CAS Authentication : CAS session timeout leads to bad parameters when adding a new appointment 

Activities

Ludovic Hutin

Ludovic Hutin

2013-09-30 03:12

reporter   ~0006075

Hello,

   We got the same problem here. We try many time to identify the problem without any result :(
   We will try to reproduce the problem here, and if it's possitive, we would increase the SOGoCacheCleanupInterval.

Ludovic.
Ludovic Hutin

Ludovic Hutin

2013-10-03 02:42

reporter   ~0006081

If this bug could be fix, it should be very very nice. :-)
ludovic

ludovic

2017-03-01 11:24

administrator   ~0011398

https://github.com/inverse-inc/sogo/commit/af3a35169a585b3d242042f6da7915ac4ea5f755

Issue History

Date Modified Username Field Change
2013-09-29 08:11 dani New Issue
2013-09-30 03:12 Ludovic Hutin Note Added: 0006075
2013-09-30 08:58 ludovic Relationship added related to 0001456
2013-10-03 02:42 Ludovic Hutin Note Added: 0006081
2017-03-01 11:24 ludovic Note Added: 0011398
2017-03-01 11:24 ludovic Status new => resolved
2017-03-01 11:24 ludovic Fixed in Version => 3.2.8
2017-03-01 11:24 ludovic Resolution open => fixed
2017-03-01 11:24 ludovic Assigned To => ludovic