View Issue Details

IDProjectCategoryView StatusLast Update
0002616SOGoWeb Generalpublic2014-04-07 15:44
Reporterxblax Assigned Toacloutier 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSDebian 7 (Wheezy)OS Version
Product Version2.1.1b 
Target Version2.2.4Fixed in Version2.2.4 
Summary0002616: URLs contain double slashes
Description

Some of the URLs that are used in the Webinterface contain double slashes. Examples that I have extracted from my log files:

POST /SOGo/so/test123@examplemail.tk/Mail//0/folderINBOX/14/view?noframe=1
POST /SOGo/so/test123@examplemail.tk/Mail//0/folderINBOX/batchDelete
POST /SOGo/so/test123@examplemail.tk/Mail//0/folderINBOX/uids HTTP/1.1
POST /SOGo/so/test123@examplemail.tk/Mail//0/folderINBOX/moveMessages
POST /SOGo/so/test123@examplemail.tk/Mail//0/folderINBOX/headers
GET /SOGo/so/test123@examplemail.tk/Mail//0/folderINBOX/expunge HTTP/1.1
GET /SOGo/so/test123@examplemail.tk/Contacts/personal//B4A-530C8700-1-62E7D200.vcf/editAsContact

There seems to be no impact on functionality as the web server handles these requests.

GET /SOGo/so/test123@examplemail.tk/Calendar//personal/properties HTTP/1.1

This URL belongs to the calendar properties page. It breaks the relative links to Caldav/ICS/XML access. Due to the malformed base URL they point to /SOGO/so/dav instead of /SOGO/dav.

Steps To Reproduce
  • Use the web interface and check the logs.
  • Go to calendar tab, right click on any calendar, open properties window.
TagsNo tags attached.

Activities

inf7

inf7

2014-03-05 03:51

reporter   ~0006629

Last edited: 2014-03-05 03:53

View 2 revisions

We have the same problem since September. At that time there was a patch and since there is a problem with the Subscribe to a calendar.

https://server.de/SOGo/so/user1/Calendar//user2_personal/properties

An error occurred during object publishing

the requested object could not be found!

ludovic

ludovic

2014-04-07 15:44

administrator   ~0006845

https://github.com/inverse-inc/sogo/commit/4fe0358581974eca9cde62f787c78b3be728407e

Issue History

Date Modified Username Field Change
2014-02-25 07:30 xblax New Issue
2014-02-27 13:33 francis Assigned To => acloutier
2014-02-27 13:33 francis Status new => assigned
2014-03-05 03:51 inf7 Note Added: 0006629
2014-03-05 03:53 inf7 Note Edited: 0006629 View Revisions
2014-04-03 16:34 ludovic Target Version => 2.2.4
2014-04-07 15:44 ludovic Note Added: 0006845
2014-04-07 15:44 ludovic Status assigned => resolved
2014-04-07 15:44 ludovic Fixed in Version => 2.2.4
2014-04-07 15:44 ludovic Resolution open => fixed