View Issue Details

IDProjectCategoryView StatusLast Update
0003368SOGoBackend Calendarpublic2018-04-27 06:09
Reporterbear-cave Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Version2.3.2 
Target VersionFixed in Version3.2.5 
Summary0003368: Adding event to shared calendar does not necessarily send invitations
DescriptionIf a user creates an event with invitees in a shared calendar they have permission to access but do not own using a CalDAV connected device, SOGo may not send emails to the invitees, depending on the device.

iOS 9, Android via DMFS CalDAV Sync, Mozilla Lightning: No email sent.
Mac OS 10.10.1: Email sent.
I have reports that a Blackberry device works. I am checking this.

If the event is created via the web interface, email is sent.
Steps To ReproduceGiven regular SOGo accounts sogo1, sogo2 and sogo3.

As sogo1, share personal calendar with sogo2 and sogo3, giving them write access.

Using the web interface as sogo2, create an event in sogo1's shared calendar and invite sogo3. Verify that invitation email is sent to sogo3.

Access SOGo as sogo2 using an iOS device. Create an event in sogo1's shared calendar and invite sogo3. Verify that invitation email is *not* sent to sogo3.
Additional InformationAfter examining the .ics sent by the above devices, it looks like a Mac works because it sets the ORGANIZER to be the *owner* of the shared calendar, sogo1. iOS, Android and Lightning set the ORGANIZER to be the arranger of the meeting, sogo2.

The web interface sets the ORGANIZER to be the calendar owner sogo1, but adds a SENT-BY clause specifying the arranger, sogo2.

A quick read of RFC2445 suggests that, strictly speaking, the web interface may have the balance of right on its side. In which case all the above clients are wrong...
Tagscalendar, Shared, thunderbird

Relationships

has duplicate 0002863 resolvedludovic SOGo No email invitations sent to attendees when using Thunderbird and CalDAV 
has duplicate 0002971 resolvedludovic SOGo Connector sender email wrong in invitations to an event 

Activities

bear-cave

bear-cave

2015-10-15 12:21

reporter  

Samples.txt (1,849 bytes)
BEGIN:VCALENDAR
PRODID:-//Apple Inc.//Mac OS X 10.10.1//EN
VERSION:2.0
CALSCALE:GREGORIAN
BEGIN:VTIMEZONE
TZID:Europe/London
BEGIN:DAYLIGHT
TZOFFSETFROM:+0000
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
DTSTART:19810329T010000
TZNAME:BST
TZOFFSETTO:+0100
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0100
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
DTSTART:19961027T020000
TZNAME:GMT
TZOFFSETTO:+0000
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20151015T145903Z
UID:1180E793-CA89-4CC1-A809-CB44D6EE8142
DTEND;TZID=Europe/London:20151016T184500
TRANSP:OPAQUE
SUMMARY:Mac test shared
DTSTART;TZID=Europe/London:20151016T174500
DTSTAMP:20151015T145903Z
ORGANIZER;CN=EXAMPLE common resources:mailto:owner@example.com
SEQUENCE:0
ATTENDEE;RSVP=TRUE;EMAIL=test@example.com;PARTSTAT=NEEDS-ACTION;CN=Test Use
 r;CUTYPE=INDIVIDUAL:mailto:test@example.com
CLASS:PUBLIC
END:VEVENT
END:VCALENDAR


BEGIN:VCALENDAR
PRODID:-//dmfs.org//mimedir.icalendar//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/London
X-LIC-LOCATION:Europe/London
BEGIN:DAYLIGHT
TZOFFSETFROM:+0000
TZOFFSETTO:+0100
TZNAME:BST
DTSTART:19700329T010000
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0100
TZOFFSETTO:+0000
TZNAME:GMT
DTSTART:19701025T020000
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
DTSTART;TZID=Europe/London:20151016T180000
SUMMARY:Test Android - shared
TRANSP:OPAQUE
STATUS:CONFIRMED
DTEND;TZID=Europe/London:20151016T190000
LAST-MODIFIED:20151015T102835Z
DTSTAMP:20151015T102835Z
ORGANIZER;CN=Jim Hague:mailto:jim.hague@example.com
CREATED:20151015T102835Z
UID:5a66e305-6fb0-47f0-9759-5c6c34e75cbf.1444904915272
ATTENDEE;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIPANT;RSVP=TRUE:mailto:test@l
 aicatc.com
CLASS:PUBLIC
END:VEVENT
END:VCALENDAR
Samples.txt (1,849 bytes)
JanKraljic

JanKraljic

2015-11-02 10:21

reporter   ~0009065

I can confirm this issue.

I'm going nuts to search why some does not receive invitation. Now I know. :(
JanKraljic

JanKraljic

2015-11-03 02:41

reporter   ~0009066

Did you report bug to Mozilla?
JanKraljic

JanKraljic

2015-11-05 03:58

reporter   ~0009071

Submited bug to mozilla: https://bugzilla.mozilla.org/show_bug.cgi?id=1221918
bear-cave

bear-cave

2015-11-05 05:35

reporter   ~0009072

I have not reported this as a bug myself anywhere, because I am in no way an expert on RFC2445, and I'm not at all confident that SOGo's behaviour is in fact correct. I didn't have any proper time to read RFC2445 at the time, and I have just discovered that it's obsoleted by RFC5545.

In fact, I think the Mac behaviour is wrong. RFC5545, p111, states clearly that ORGANIZER must be the meeting organiser. SENT-BY can be used to specify that someone else acting on behalf of the organiser (e.g. a secretary), but responses should still be sent to the organiser.

In the case of someone creating a meeting in a shared calendar, I think the question is the intent. Are they the organiser, or is the owner of the calendar of the calendar the organiser? That's a user context question; there is no definitive answer. At the very least, a Mac should set SENT-BY. And I now feel that iOD, Android and Lightning have a strong argument that they are right.

Regardless of what a standards lawyer would say, there remains the practical question of making SOGo work as the majority of users expect. Which probably boils down to 'what does Outlook/Exchange do in this circumstance'? I don't know the answer to that question.

We hit this problem because we're a small organisation using a single calendar as global 'who is where' resource. This usage cannot scale, so probably shouldn't be catered for as the default way of SOGo working. I suspect that what we should be doing is to have the shared calendar as a resource as per http://wiki.sogo.nu/ResourceConfiguration, configured to accept a huge number of multiple bookings, and tell people to create bookings in their personal calendar and invite the shared calendar.
bear-cave

bear-cave

2015-11-05 05:53

reporter   ~0009073

Thinking a moment more, I am still trying to work out why SOGo doesn't send invitations anyway. Why should a third party, creating an event in a calendar to which they have access, only get invitations triggered if ORGANIZER is the calendar owner? Surely the question of ownership is not relevant to invitation?
Christian Mack

Christian Mack

2016-02-08 09:44

developer   ~0009457

IIRK this was done, because importing of events from another calendar system with another owner already set, should not trigger invitations again.
groovepack

groovepack

2016-02-09 11:25

reporter   ~0009477

For security reasons it should be an option if a third party could trigger an invitation mail.

In one case we have team assistance with full access to the managers calendar, and it would be nice if there would be send an invitation in form of "Event Invitation: foo bar - on behalf of [Calendar Owner]" with sender address of the team assistance.
jaragunde

jaragunde

2016-05-06 08:14

reporter   ~0010052

The exposed behavior in Thunderbird has another consequence: events created by user A in B's shared calendar don't appear in A's personal calendar.
ludovic

ludovic

2016-05-06 13:19

administrator   ~0010058

@jaragundeThat is perfectly normal.
jaragunde

jaragunde

2016-05-09 04:45

reporter   ~0010077

@ludovic Thanks for your response :) But I still think that behavior is inconsistent, at least. If you create an event in another person's shared calendar using the web UI, that event appears in your personal calendar, but doing the same from Thunderbird doesn't have the same effect.
jaywalker

jaywalker

2016-07-02 08:09

reporter   ~0010464

Still an issue with Sogo v3.1.3

Would it at least be possible to add a configuration option that allows to send invitations if the organizer is not the owner of the calendar?

Thank you!

Related Changesets

sogo: master 7197b7eb

2016-12-23 10:04:43

ludovic

Details Diff
(fix) handle delegation scenario with no SENT-BY set (fixes 0003368) Affected Issues
0003368
mod - SoObjects/Appointments/SOGoAppointmentObject.m Diff File

Issue History

Date Modified Username Field Change
2015-10-15 12:21 bear-cave New Issue
2015-10-15 12:21 bear-cave File Added: Samples.txt
2015-11-02 10:21 JanKraljic Note Added: 0009065
2015-11-02 10:21 JanKraljic Tag Attached: calendar
2015-11-02 10:21 JanKraljic Tag Attached: thunderbird
2015-11-02 10:21 JanKraljic Tag Attached: Shared
2015-11-03 02:41 JanKraljic Note Added: 0009066
2015-11-05 03:58 JanKraljic Note Added: 0009071
2015-11-05 05:35 bear-cave Note Added: 0009072
2015-11-05 05:53 bear-cave Note Added: 0009073
2016-02-08 09:44 Christian Mack Note Added: 0009457
2016-02-09 11:25 groovepack Note Added: 0009477
2016-05-06 08:14 jaragunde Note Added: 0010052
2016-05-06 13:19 ludovic Note Added: 0010058
2016-05-09 04:45 jaragunde Note Added: 0010077
2016-07-02 08:09 jaywalker Note Added: 0010464
2016-12-23 10:05 ludovic Changeset attached => sogo master 7197b7eb
2016-12-23 10:05 ludovic Assigned To => ludovic
2016-12-23 10:05 ludovic Resolution open => fixed
2016-12-23 10:07 ludovic Status new => resolved
2016-12-23 10:07 ludovic Fixed in Version => 3.2.5
2016-12-23 10:09 ludovic Relationship added has duplicate 0002863
2016-12-23 10:10 ludovic Relationship added has duplicate 0002971