View Issue Details

IDProjectCategoryView StatusLast Update
0003456SOGoWeb Mailpublic2018-11-05 03:31
Reporterjader31 Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Platform[Client] MicrosoftOSWindowsOS Version8
Product Version2.3.4 
Target VersionFixed in Version 
Summary0003456: DOVECOT Master User not working with SOGo frontend
Description

I've SME Server (www.contribs.org) with DOVECOT backend and 2 front end: HORP/IMP and SOGO.

Have enabled everything to make master user possible, and confirmed it works as expected with HORDE/IMP. But when I try to use SOGo I receive an error telling me the user/password is wrong. It's not wrong... but user is <someone>*admin and it's admin password.
This exact combination works at HORDE/IMP.

A friend of mine tell me (becasuse I'm not a programmer) the error is because SOGO verify user using LDAP (or something like that) and do not work/will not work with Master User feature of DOVECOT.

If you need help to debug or any debug file, just ask. I'm here to help.

Regards,

J√°der

TagsNo tags attached.

Relationships

related to 0004589 new SuperUser with features like Dovcot Master User 

Activities

Christian Mack

Christian Mack

2016-01-26 05:30

developer   ~0009328

So you want an enhancment for SOGo to authenticate against IMAP/Dovecot?

jader31

jader31

2016-01-26 10:23

reporter   ~0009333

Last edited: 2016-01-26 16:57

View 2 revisions

Hum... I'm not sure if it's an enhancement... I'm just reporting a strange behaviour... maybe a bug. Not sure if it's a NFR or a BUG.
I'm sure it's a very usefull feature of dovecot allowing admin log as any user and this is not supported by SOGo.
And SOGo is the webmail I use and recomend.
Maybe it's simple to fix or a worthy new feature... but I'm just a reporter. :)

ludovic

ludovic

2016-02-03 16:25

administrator   ~0009436

SOGo can only authenticate users defined in an authentication sources (LDAP and SQL sources are supported). We don't plan to change this.

Issue History

Date Modified Username Field Change
2016-01-25 17:32 jader31 New Issue
2016-01-26 05:30 Christian Mack Note Added: 0009328
2016-01-26 10:23 jader31 Note Added: 0009333
2016-01-26 16:57 jader31 Note Edited: 0009333 View Revisions
2016-02-03 16:25 ludovic Note Added: 0009436
2016-02-03 16:25 ludovic Status new => closed
2016-02-03 16:25 ludovic Assigned To => ludovic
2016-02-03 16:25 ludovic Resolution open => won't fix
2018-11-05 03:31 Christian Mack Relationship added related to 0004589