Scalable OGo (SOGo)

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003836SOGoWeb Mailpublic2016-10-12 06:052017-11-29 13:03
ReporterChristian Mack 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformLinuxOSCentOSOS Version5.6
Product Version2.3.16 
Target VersionFixed in Version 
Summary0003836: Escaping of Umlauts in Subject with different coding break on reply
DescriptionWhen we send an email via our listserver mailman, mailman adds a subject prefix.
If the subject of the original email contains a non ASCII character, mailman will generate a multipart coded subject.

When you reply to one of those in SOGo, then you get a garbled Subject with readable encoding part.

E.g.:
Sending to mailman "Mail mit Umlaut äöüß"
Subject: =?UTF-8?B?TWFpbCBtaXQgVW1sYXV0IMOkw7bDvMOf?=

Getting from mailman "[höchst diffiziler Test]Mail mit Umlaut äöüß"
Subject: =?utf-8?q?=5Bh=C3=B6chst_diffiziler_Test=5D?= =?utf-8?q?Mail_mit_?=
    =?utf-8?b?VW1sYXV0IMOkw7bDvMOf?=

replyed with SOGo "Re: [höchst diffiziler Test]?==?utf-8?q? Mail mit Umlaut äöüß"
Subject: Re: =?utf-8?q?=5Bh=C3=B6chst_diffiziler_Test=5D?=
 =?utf-8?b?Pz09P3V0?=
 =?utf-8?b?Zi04P3E/IE1haWwgbWl0IFVtbGF1dCDDpMO2w7zDnw==?=


The "?==?utf-8?q?" part should not be there.
I guess this is happening, because there are =?utf-8?q? and =?utf-8?b? encodings mixed.
Steps To ReproduceI have added the example email we get from mailman.

1) Import that example email into your SOGo mail account.
2) Reply on that email in SOGo webinterface.
3) Change the recipient to an account you can read.
4) Send the reply.
5) Check on the recipients side. => The recipient gets the garbled Subject.
TagsNo tags attached.
Attached Fileseml file icon [höchst diffiziler Test]Mail mit Umlaut äöüß.eml [^] (10,167 bytes) 2016-10-12 06:05

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0012282)
cedric.archambeau (reporter)
2017-09-11 09:10

Hi, a little up for this bug - same problem, with latest 3.2.11.

Thanks.
(0012459)
wimmer (reporter)
2017-11-29 13:03

Hi,
I receive many complaints to this bug (or behaviour) from our users.
When needed some better clarification, here is my example:
--

1a) I sent message from SOGo WebGUI 2.3.23 to mailman list [XXX]
- source code of the message in my Sent folder:
   Subject: =?utf-8?q?Doktorsk=C3=BD?==?utf-8?q?_semin=C3=A1=C5=99?=
- displayed as:
   Doktorský seminá?
- result: OK

1b) I receive that message from mailman:
- source code of the message in my Inbox:
   Subject: [XXX] =?utf-8?b?RG9rdG9yc2vDvT89PT91dGYtOD9xPyBzZW1pbsOhxZk=?=
- displayed as:
   Doktorský?==?utf-8?q? seminá?
- result: FAIL
--

2a) I sent message from Thunderbird to mailman list [XXX]
- source code of the message in my Sent folder:
   Subject: =?UTF-8?B?RG9rdG9yc2vDvSBzZW1pbsOhxZk=?=
- displayed as:
   Doktorský seminá?
- result: OK

2b) I receive that message from mailman:
- source code of the message in my Inbox:
   Subject: [XXX] =?utf-8?b?RG9rdG9yc2vDvSBzZW1pbsOhxZk=?=
- displayed as:
   Doktorský seminá?
- result: OK

----

It looks SOGo use some complicated way for coding Subject.
Simple coding of the whole Subject (like Thunderbird does) would solve this problem.

Thanks for your work,
Milos

- Issue History
Date Modified Username Field Change
2016-10-12 06:05 Christian Mack New Issue
2016-10-12 06:05 Christian Mack File Added: [höchst diffiziler Test]Mail mit Umlaut äöüß.eml
2017-09-11 09:10 cedric.archambeau Note Added: 0012282
2017-11-29 13:03 wimmer Note Added: 0012459


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker