SOGo | BTS

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003904SOGoWeb Preferencespublic2016-11-16 04:152017-03-06 11:21
Reporterandre.peters 
Assigned Tofrancis 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Version3.2.1 
Target VersionFixed in Version3.2.5 
Summary0003904: Sieve script: fileinto folder with umlauts uses IMAP folder name instead of umlaut
DescriptionCreate a folder "Testnäme". Create a sieve script to move all mail with "Testär" in the subject into "Testnäme":

require ["fileinto"];
if allof (header :contains "subject" "Testär") {
    fileinto "Testn&AOQ-me";
}

fileinto "Testn&AOQ-me" creates a folder named "Testn&AOQ-me".

Regards,
André
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of 0003832resolvedfrancis "SOGoSieveFolderEncoding = UTF-8" does not work 
duplicate of 0003697resolvedfrancis Web mail filter with cyrillic folder name 

-  Notes
User avatar (0010874)
francis (administrator)
2016-11-16 10:38

Set SOGoSieveFolderEncoding to "UTF-8".
(0010881)
andre.peters (reporter)
2016-11-16 16:28

Still moving mails to Testn&AOQ-me.

Restarted cached and sogod. Previous script was deleted. The sieve file also looks the same.
(0010882)
andre.peters (reporter)
2016-11-16 16:36

Follow-up: I also set encoding for the domain context instead of "only" in sogo.conf - the app still posts this:

"actions":[{"method":"fileinto","argument":"INBOX/Testn&AOQ-me"}]
User avatar (0010884)
francis (administrator)
2016-11-16 22:29

It's a bug. I'll fix it.
User avatar (0010886)
francis (administrator)
2016-11-17 09:44

https://github.com/inverse-inc/sogo/commit/baf1d4454895b17ef6ee69cc6a6c3ec321ef57aa [^]
(0010922)
andre.peters (reporter)
2016-11-26 13:35
edited on: 2016-11-26 13:40

Hi,
Thanks, but I think it broke something else:

I choose to store a mail in INBOX/Something, but it always falls back to Something (without INBOX).

I have the IMAP separator set to / in SOGo, too.

Oh, the select menu looks strange now, too. :-) =>

[Screenshot](https://i.imgur.com/RI9prJm.png [^])

User avatar (0010930)
francis (administrator)
2016-11-29 09:17

Make sure to clear your browser's cache.

Show us the generated Sieve script.
(0010931)
andre.peters (reporter)
2016-11-29 13:12

Sure, everything is cleaned. :-)

It is still the same. The script looks like this:

require ["fileinto"];
if allof (header :contains "subject" "Ein Betreff") {
    fileinto "Testordner";
}

That's also what the request looks like.

After I created that filter rule and try to edit it, I again have this glitch in the mask from aboves screenshot.
User avatar (0010944)
francis (administrator)
2016-12-02 17:53

I fixed the path, but I can't reproduce the visual glitch.
User avatar (0011441)
francis (administrator)
2017-03-06 11:21

Considered resolved. Reopen if necessary.

- Related Changesets
sogo: master ba5bd65e
Timestamp: 2016-12-02 17:38:33
Author: francis
Details ] Diff ]
Fix support for SOGoSieveFolderEncoding defaults

Cont'd. Fixes 0003904
mod - NEWS Diff ] File ]
mod - SoObjects/Mailer/SOGoMailAccount.h Diff ] File ]
mod - SoObjects/Mailer/SOGoMailAccount.m Diff ] File ]
mod - UI/PreferencesUI/UIxPreferences.m Diff ] File ]
mod - UI/Templates/PreferencesUI/UIxFilterEditor.wox Diff ] File ]
mod - UI/Templates/PreferencesUI/UIxPreferences.wox Diff ] File ]
mod - UI/WebServerResources/js/Preferences/FiltersDialogController.js Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-11-16 04:15 andre.peters New Issue
2016-11-16 10:38 francis Note Added: 0010874
2016-11-16 16:28 andre.peters Note Added: 0010881
2016-11-16 16:36 andre.peters Note Added: 0010882
2016-11-16 22:29 francis Note Added: 0010884
2016-11-17 09:44 francis Note Added: 0010886
2016-11-17 09:44 francis Status new => resolved
2016-11-17 09:44 francis Fixed in Version => 3.2.2
2016-11-17 09:44 francis Resolution open => fixed
2016-11-17 09:44 francis Assigned To => francis
2016-11-26 13:35 andre.peters Note Added: 0010922
2016-11-26 13:35 andre.peters Status resolved => feedback
2016-11-26 13:35 andre.peters Resolution fixed => reopened
2016-11-26 13:40 andre.peters Note Edited: 0010922 View Revisions
2016-11-29 09:17 francis Note Added: 0010930
2016-11-29 13:12 andre.peters Note Added: 0010931
2016-11-29 13:12 andre.peters Status feedback => assigned
2016-12-02 17:39 francis Changeset attached => sogo master ba5bd65e
2016-12-02 17:53 francis Note Added: 0010944
2016-12-02 18:13 francis Relationship added duplicate of 0003832
2016-12-02 18:14 francis Fixed in Version 3.2.2 => 3.2.5
2016-12-09 15:20 francis Relationship added duplicate of 0003697
2017-03-06 11:21 francis Note Added: 0011441
2017-03-06 11:21 francis Status assigned => resolved
2017-03-06 11:21 francis Resolution reopened => fixed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker