View Issue Details

IDProjectCategoryView StatusLast Update
0004201SOGoWeb Mailpublic2017-10-09 03:56
Reportergturner Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS Version9 (Stretch)
Product Version3.2.6 
Target Version3.2.10Fixed in Version3.2.10 
Summary0004201: Mail with Content-Type multipart/signed (RFC 1847) is not displayed
DescriptionEmail with MIME Content-Type multipart/signed is not displayed within SOGo at all, they're rendered as a blank message.

These emails used to be displayed with SOGo 2.2.17.
Steps To ReproduceOpen a PGP/MIME signed email (RFC 1847)
Additional InformationToday I upgraded my SOGo server's OS from Debian 8 (Jessie) to Debian 9 (Stretch) which coincidentally upgraded SOGo from 2.2.17 to 3.2.6. Every message in my Sent folder renders blank. A large amount of mail received from Debian Mailing Lists (see attachment) are rendered blank. Other users of my SOGo installation see blank mail for every mail sent by me.
TagsNo tags attached.

Relationships

has duplicate 0004307 closedludovic Cannot view gpg signed emails 

Activities

gturner

gturner

2017-06-17 19:50

reporter  

multipart-signed-email (7,230 bytes)
Return-Path: <bounce-debian-devel-announce=gturner=unzane.com@lists.debian.org>
X-Spam-Checker-Version: SpamAssassin 3.4.1 (2015-04-28) on azathoth.unzane.com
X-Spam-Level: 
X-Spam-ASN: AS8365 82.195.64.0/19
X-Spam-Status: No, score=-1.7 required=3.0 tests=AWL,BAYES_00,
	LOCAL_NEGATE_DNSWL_HI,RCVD_IN_DNSWL_HI,RCVD_IN_MSPIKE_H3,RCVD_IN_MSPIKE_WL,
	T_RP_MATCHES_RCVD shortcircuit=no autolearn=no autolearn_force=no
	version=3.4.1
X-Original-To: gturner@unzane.com
Delivered-To: gturner@unzane.com
X-Envelope-From: <bounce-debian-devel-announce=gturner=unzane.com@lists.debian.org>
Received: from bendel.debian.org (bendel.debian.org [82.195.75.100])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(No client certificate requested)
	by azathoth.unzane.com (Postfix) with ESMTPS id 0F122600096
	for <gturner@unzane.com>; Tue, 13 Jun 2017 23:24:20 -0700 (PDT)
Received: from localhost (localhost [127.0.0.1])
	by bendel.debian.org (Postfix) with QMQP
	id A34DCA2; Wed, 14 Jun 2017 06:24:06 +0000 (UTC)
X-Mailbox-Line: From debian-devel-announce-request@lists.debian.org  Wed Jun 14 06:24:06 2017
Old-Return-Path: <jmw@debian.org>
X-Original-To: lists-debian-devel-announce@bendel.debian.org
Delivered-To: lists-debian-devel-announce@bendel.debian.org
Received: from localhost (localhost [127.0.0.1])
	by bendel.debian.org (Postfix) with ESMTP id 0C4EF90
	for <lists-debian-devel-announce@bendel.debian.org>; Wed, 14 Jun 2017 06:23:58 +0000 (UTC)
X-Virus-Scanned: at lists.debian.org with policy bank moderated
X-Amavis-Spam-Status: No, score=-9.334 tagged_above=-10000 required=5.3
	tests=[BAYES_00=-2, DIGITS_LETTERS=1, LDO_WHITELIST=-5,
	PGPSIGNATURE=-5, RCVD_IN_DNSWL_NONE=-0.0001, SARE_BOUNDARY_LC=1.666]
	autolearn=ham autolearn_force=no
Received: from bendel.debian.org ([127.0.0.1])
	by localhost (lists.debian.org [127.0.0.1]) (amavisd-new, port 2525)
	with ESMTP id C9p9Lm3BRZzz
	for <lists-debian-devel-announce@bendel.debian.org>;
	Wed, 14 Jun 2017 06:23:53 +0000 (UTC)
X-policyd-weight: using cached result; rate: -2.75
Received: from hermione.home.powdarrmonkey.net (hogwarts.powdarrmonkey.net [IPv6:2001:8b0:caea:eda7:3ed9:2bff:fe02:9128])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(Client did not present a certificate)
	by bendel.debian.org (Postfix) with ESMTPS id 15FF354
	for <debian-devel-announce@lists.debian.org>; Wed, 14 Jun 2017 06:23:52 +0000 (UTC)
Received: from [2001:8b0:caea:eda7:35c7:78d:c809:23f2] (helo=lupin)
	by hermione.home.powdarrmonkey.net with esmtpsa (TLS1.2:ECDHE_RSA_AES_256_GCM_SHA384:256)
	(Exim 4.89)
	(envelope-from <jmw@debian.org>)
	id 1dL1iY-0007x0-1B
	for debian-devel-announce@lists.debian.org; Wed, 14 Jun 2017 07:23:50 +0100
Received: from jona by lupin with local (Exim 4.89)
	(envelope-from <jmw@debian.org>)
	id 1dL1iW-0004Lg-SL
	for debian-devel-announce@lists.debian.org; Wed, 14 Jun 2017 07:23:48 +0100
Date: Wed, 14 Jun 2017 07:23:48 +0100
From: Jonathan Wiltshire <jmw@debian.org>
To: debian-devel-announce@lists.debian.org
Subject: Call for Signatures: stretch dedication
Message-ID: <20170614062348.ysbwh53bwngstj4z@powdarrmonkey.net>
Reply-To: jmw@debian.org
Mail-Followup-To: jmw@debian.org
MIME-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha256;
	protocol="application/pgp-signature"; boundary="aafywhfzjlyomyhv"
Content-Disposition: inline
User-Agent: NeoMutt/20170113 (1.7.2)
X-Debian-Message: Signature check passed for Debian member
X-Rc-Virus: 2007-09-13_01
X-Rc-Spam: 2008-11-04_01
Resent-Message-ID: <dCew6HCfNgH.A.6tC.GaNQZB@bendel>
Resent-From: debian-devel-announce@lists.debian.org
X-Mailing-List: <debian-devel-announce@lists.debian.org> archive/latest/2035
X-Loop: debian-devel-announce@lists.debian.org
List-Id: <debian-devel-announce.lists.debian.org>
List-URL: <https://lists.debian.org/debian-devel-announce/>
List-Post: <mailto:debian-devel-announce@lists.debian.org>
List-Help: <mailto:debian-devel-announce-request@lists.debian.org?subject=help>
List-Subscribe: <mailto:debian-devel-announce-request@lists.debian.org?subject=subscribe>
List-Unsubscribe: <mailto:debian-devel-announce-request@lists.debian.org?subject=unsubscribe>
Precedence: list
Resent-Sender: debian-devel-announce-request@lists.debian.org
List-Archive: https://lists.debian.org/msgid-search/20170614062348.ysbwh53bwngstj4z@powdarrmonkey.net
Resent-Date: Wed, 14 Jun 2017 06:24:06 +0000 (UTC)


--aafywhfzjlyomyhv
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Hi,

My apologies that this is rather short notice. We deferred discussion of
the subject in 2015 to "nearer the release", and then promptly failed to
add it to any checklists.

Debian 9 "stretch" will be dedicated to Ian Murdock. Whilst dedications in
more specific areas of Debian development are generally preferred, the
founder of the project is a common sense exception. As is traditional, the
dedication will be expressed by a file on the mirrors and CD images.

We welcome every Debian developer, maintainer, translator, or
contributor in any other field to join us in signing this dedication.

If you wish to do so, please:

  * Download the dedication file:
    https://people.debian.org/~jmw/dedication-9.0.txt
  * Verify the sha1sum: fb37a995eebad8ced194709a9a2eb7a68ad8979c
  * Create a detached, ascii-armoured signature in a file with your name,
    underscore-separate. Use of proper capitalisation is appreciated.
    For example, mine is called Jonathan_Wiltshire:
       gpg -bao Your_Name dedication-9.0.txt
  * Mail the file as an attachment directly to me, jmw@debian.org with the
    subject line "Dedication signature". I will collate them.

Owing to the proximity of the release, the deadline for signatures
is 2016-06-16 18:00 UTC (Friday). I am aware that this does not leave
very much time and I'm sorry about that; I will make one further update
to the signatures archive around the time of the first point release for
anyone who cannot meet this schedule.

Thanks,

For the release team:
--=20
Jonathan Wiltshire                                      jmw@debian.org
Debian Developer                         http://people.debian.org/~jmw

4096R: 0xD3524C51 / 0A55 B7C5 1223 3942 86EC  74C3 5394 479D D352 4C51


--aafywhfzjlyomyhv
Content-Type: application/pgp-signature; name="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEADLdyLGMneGYn8dtRNMqtfom+MkFAllA1m4ACgkQRNMqtfom
+MlnNhAAt8hkkg8BZ0FTDTz5qahAYAWCfdmxkF0DDHFY5dcBbZ2uVYaf2Se79F+L
t5w0JW1SototRjOhdcvz/9VZnrx4sk/6sHROKATn5jJA3edHM7YjUp+HAlEQ6W2b
c7sWQ2m+oBX7iMnSjOPZDFWs/8ejWx+Knf1XpF9ZutkoB1KoA1pNIuqrkp3nLIz+
O9sUr8bPgnh8/EH9AyYPTwjPYautDPLDBzjeWiObzqNi3QNeF0Uq71r7uviw7fQu
VNwGMgIYZ26Vxs6aMdcAiKSrnU8tYiIB/08IkhCyNubHAq5PUrNr82W1vPR+iCQ8
YIr76p4U4/tMCmJc8tzN9W1W6Upm5uMMGcmBU8YEhrGXCjMI3mgVAjeX70lAXzfP
wgMUDbD/fqBoO62ElAe4XFUSCJ40OFkT0LcOOlB7x8AP+9N4rNYNQayM8TfG/YAu
kyWjLA4GMA7IfH+klnrHMjQzHsAuyXizhO6FiZixIDrQe/vqdX7R5pkaerwSPrtv
dM9vlfnWZa4cS74Xv1ybhDPWOUI4TS4VGEDOc1f+/+6nnkHmK4CzHBqDdttbKhz+
ZkxVOHxyDmsy79x25Gtf29bqlqnwaGQeyPqKjWQ/SjCstbF80XFGXOJ/YmNrdnUa
VhQMlGavqvZbTI71L37dEiAhs6ntQPTKs2AIB2jzqIOTsEWUvEg=
=L16v
-----END PGP SIGNATURE-----

--aafywhfzjlyomyhv--

multipart-signed-email (7,230 bytes)
Christian Mack

Christian Mack

2017-06-19 04:13

developer   ~0011985

Are there smime.p7m attachments?
gturner

gturner

2017-06-19 12:44

reporter   ~0011991

Hi Christian, to answer your question, there are no smime.p7m attachments.

The first MIME part is:

  Content-Type: text/plain; charset=us-ascii
  Content-Disposition: inline
  Content-Transfer-Encoding: quoted-printable

The second MIME part is:

  Content-Type: application/pgp-signature; name="signature.asc"

I'm used to SOGo (older 2.x) and many other mail clients displaying that second part as a download. Clients like Evolution or Thunderbird with Enigmail instead verify the PGP signature. I'm not expecting SOGo to do any PGP operations. There's regression in SOGo 3 that it doesn't render the first MIME part at all (text/plain, not shown).
jordi

jordi

2017-06-27 08:12

reporter   ~0012007

Hello,

The Debian version of SOGo is compiled against GnuTLS instead of OpenSSL due to licensing reasons. Unfortunately, there is a codepath that is not ported to GnuTLS and apparently causes this regression.

Ludovic, see the HAVE_OPENSSL ifdefs in UI/MailPartViewers/UIxMailPartSignedViewer.m.

I've been wanting to contribute a fix from our end, but have not been able.
gturner

gturner

2017-06-27 12:21

reporter   ~0012009

That's interesting jordi, I attempted to verify by rebuilding Debian's package with libssl-dev (OpenSSL 1.1), however at runtime it broke SOGo's ability to connect to IMAPS. So I made another attempt at rebuilding with libssl-1.0-dev (OpenSSL 1.0), but this is impractical since another dependency, liblasso3-dev, depends on OpenSSL 1.1. Damn this OpenSSL API break!
ludovic

ludovic

2017-07-04 10:29

administrator   ~0012029

That is correct - 3 methods from UI/MailPartViewers/UIxMailPartSignedViewer.m need to be ported to Gnu TLS.

Related Changesets

sogo: master 22c078ee

2017-07-04 11:00:06

ludovic

Details Diff
(fix) enable S/MIME even when using GNU TLS (fixes 0004201) Affected Issues
0004201
mod - UI/MailPartViewers/GNUmakefile.preamble Diff File
mod - UI/MailPartViewers/UIxMailPartSignedViewer.m Diff File

sogo: v2 8d1b02d5

2017-07-04 11:00:06

ludovic

Details Diff
(fix) enable S/MIME even when using GNU TLS (fixes 0004201)

Conflicts:
UI/MailPartViewers/UIxMailPartSignedViewer.m
Affected Issues
0004201
mod - UI/MailPartViewers/GNUmakefile.preamble Diff File
mod - UI/MailPartViewers/UIxMailPartSignedViewer.m Diff File

Issue History

Date Modified Username Field Change
2017-06-17 19:50 gturner New Issue
2017-06-17 19:50 gturner File Added: multipart-signed-email
2017-06-19 04:13 Christian Mack Note Added: 0011985
2017-06-19 12:44 gturner Note Added: 0011991
2017-06-27 07:48 ludovic Severity major => minor
2017-06-27 07:49 ludovic Assigned To => ludovic
2017-06-27 07:49 ludovic Status new => assigned
2017-06-27 07:49 ludovic Target Version => 3.2.10
2017-06-27 08:12 jordi Note Added: 0012007
2017-06-27 12:21 gturner Note Added: 0012009
2017-07-04 10:29 ludovic Note Added: 0012029
2017-07-04 11:01 ludovic Changeset attached => sogo master 22c078ee
2017-07-04 11:01 ludovic Resolution open => fixed
2017-07-04 11:02 ludovic Changeset attached => sogo v2 8d1b02d5
2017-07-04 11:03 ludovic Status assigned => resolved
2017-07-04 11:03 ludovic Fixed in Version => 3.2.10
2017-10-09 03:56 Christian Mack Relationship added has duplicate 0004307