SOGo | BTS

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004258SOGoWeb Mailpublic2017-08-24 06:272017-09-08 10:56
Reporterfsoyer 
Assigned Tofrancis 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionreopened 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version3.2.10 
Target VersionFixed in Version4.0.0 
Summary0004258: copying/pasting email addresses from calc (xls, ods) result in bad merged address
DescriptionAfter trying to resolv this on users@sogo.nu, and after a lot of tests, I need to open this bug as continuation of closed bug 0004097.
On Sogo 3.2.9, then updated to 3.2.10 (but same behavior on two versions), copying/pasting email addresses from a calc result in one unique merged (and bad) address. I don't post screenshots, as this is exactly the same as those pposted by nenonano on 0004097.
Steps To ReproduceOpen a calc, add email addresses one by cell (on row or on column, no difference). Copy addresses (by keystroke or with menus, no difference), then paste it in a new mail in Sogo 3. Hit enter or change field with mouse (no difference) : the addresses are merged in one big bad address.
Additional Informationserver : SOGo 3.2.9 updated to 3.2.10 on CentOS 7.3
Clients : Ubuntu 16.04 - Windows 7
Tested with :
LibreOffice linux -> Firefox linux
LibreOffice linux -> Chrome linux
LibreOffice windows -> Firefox windows
LibreOffice windows -> Chrome windows
Excel 2016 -> Firefox windows
Excel 2016 -> Chrome windows

All tests give same result.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0012224)
fsoyer (reporter)
2017-08-24 07:27

[NOTE] Pasting this addresses in a notepad show that :
- if copied from one column, some lines, it is pasted with carriage returns
- if copied from on line, some columns, it is pasted with tabs
(0012252)
fsoyer (reporter)
2017-09-04 05:56
edited on: 2017-09-04 05:59

I'm sorry to inform you that this change doesn't solved the problem for me.
I've replaced the file /usr/lib64/GNUstep/SOGo/WebServerResources/js/Mailer/MessageEditorController.js with the new one, and tried to debug it with Chrome developper tool. First, it confirmed to me that the new script is correctly loaded. But I'm not able to debug more, I'm just a sysadmin :) With a breakpoint on line 297, if I paste adresses copied with carriage return as separator (from calc or even a notepad), the debugger shows me that "recipients = ["addr1@domain.com addr2@domain.com addr3@domain.com"]". Same if separator is tabulation. But if I just add ";" between pasted adresses, it shows "recipients = (3) ["addr1@domain.com", " addr2@domain.com", " addr3@domain.com"]" and the adresses are correctly displayed.
Is there something else I can try ?

(0012253)
fsoyer (reporter)
2017-09-04 07:25

Note: This Sogo 3.2.10 with the new js file is a test server. If necessary I can give access to it with a test account.
User avatar (0012255)
francis (administrator)
2017-09-04 14:44

This is not the proper way to try the patch since this JavaScript controller ends in a generated JavaScript file. Use the nightly build to easily test it.
(0012261)
fsoyer (reporter)
2017-09-06 05:35

Hi Francis, thank you for that. Can you tell us when the 3.2.11 will be available on the repos ? We use rpms on https://packages.inverse.ca/SOGo/nightly/3/rhel/7 [^] (but I can see that it's not available for other distros)
User avatar (0012264)
francis (administrator)
2017-09-06 09:04

Try
sogo-3.2.10.20170906-1.el7.centos.x86_64.rpm
(0012270)
fsoyer (reporter)
2017-09-06 18:36
edited on: 2017-09-06 18:36

Ok ! nearly done !
I've updated our test server to 3.2.10.20170906-1. It works now when pasting adresses copied vertically (some lines in a column) that give a carriage return as separator. But copied from a line (tabulation as separator) it give a big address as before. I know, this not a common case, but...

In any case, thank you for the work.

(0012277)
cedric.archambeau (reporter)
2017-09-07 12:07

This commit fixes the bug for us too.

Thanks Francis.
(0012278)
fsoyer (reporter)
2017-09-08 10:38

I notice another thing with the field To:, you will tell me if it is dependant or if I must report it specifically.
When typing (or pasting) address(ses), Enter or Tab or click in another field doesn't quit the field To:, we need to re-enter or re-click.

- Related Changesets
sogo: master 84edeb85
Timestamp: 2017-09-01 11:09:24
Author: francis
Details ] Diff ]
(js) Fix parsing of pasted email addresses

Fixes 0004258 and fixes 0004097
mod - NEWS Diff ] File ]
mod - UI/WebServerResources/js/Mailer/MessageEditorController.js Diff ] File ]
sogo: master 614a1371
Timestamp: 2017-09-08 10:50:10
Author: francis
Details ] Diff ]
(js) Fix parsing of tab-delimited email addresses

Fixes 0004258
mod - UI/WebServerResources/js/Mailer/MessageEditorController.js Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-08-24 06:27 fsoyer New Issue
2017-08-24 07:27 fsoyer Note Added: 0012224
2017-09-01 11:10 francis Changeset attached => sogo master 84edeb85
2017-09-01 11:10 francis Assigned To => francis
2017-09-01 11:10 francis Resolution open => fixed
2017-09-01 11:10 francis Status new => resolved
2017-09-01 11:10 francis Fixed in Version => 4.0.0
2017-09-04 05:56 fsoyer Note Added: 0012252
2017-09-04 05:56 fsoyer Status resolved => feedback
2017-09-04 05:56 fsoyer Resolution fixed => reopened
2017-09-04 05:59 fsoyer Note Edited: 0012252 View Revisions
2017-09-04 07:25 fsoyer Note Added: 0012253
2017-09-04 07:25 fsoyer Status feedback => assigned
2017-09-04 14:44 francis Note Added: 0012255
2017-09-06 05:35 fsoyer Note Added: 0012261
2017-09-06 09:04 francis Note Added: 0012264
2017-09-06 10:27 ludovic Severity major => minor
2017-09-06 18:36 fsoyer Note Added: 0012270
2017-09-06 18:36 fsoyer Note Edited: 0012270 View Revisions
2017-09-07 12:07 cedric.archambeau Note Added: 0012277
2017-09-08 10:38 fsoyer Note Added: 0012278
2017-09-08 10:56 francis Changeset attached => sogo master 614a1371


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker