SOGo | BTS

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004260SOGoWeb Generalpublic2017-08-24 11:342018-10-03 06:28
Reporterfsoyer 
Assigned Toludovic 
PriorityhighSeverityminorReproducibilityrandom
StatusresolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version3.2.10 
Target VersionFixed in Version 
Summary0004260: After a restart of services on servers, some user settings are resetted
DescriptionOn SOGO 3.2.9 updated to 3.2.10, server CentOS 7.3, MariaDB 10.0, with NGINX. we note randomly that the settings in mysql/sogo_user_profile were resetted to default. It seems (but needs to be confirmed) to occur after a nginx restart (but the first time it occurs this was a sogod+nginx restart).
On a backup of the database, we see the day before all settings, particularly "SOGoSieveFilters", "SOGoMailSignature" which contains datas. After a restart of nginx this morning, this settings have disappear from his c_uid in sql, and are no more shown in the webUI. But the filters have not disappear on the disk, in .dovecot.sieve.
We have seen this bu 3 times for now : two times on 3.2.9, one time today on 3.2.10 (SOGo was upgraded last week)
I wonder if there is a mechanism of auto-save for the settings or something else, on the server or the client, which bug if it try to write when nginx restart ?
Additional InformationWhen it occurs, this is only (actually) on one user, all others are not modified. But on the 3 times it occurs, this was 3 different users.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to 0004315closedludovic User preferences disappear ramdomly 

-  Notes
User avatar (0012232)
ludovic (administrator)
2017-08-24 15:36

Is it possible that these users had images in their HTML signatures?
User avatar (0012233)
ludovic (administrator)
2017-08-24 15:54

Try doing in mysql:

alter table sogo_user_profile MODIFY c_defaults LONGTEXT;
alter table sogo_user_profile MODIFY c_settings LONGTEXT;
(0012234)
fsoyer (reporter)
2017-08-25 03:54

Hi ludovic,
I see : yes, there is images. I understand that this can overfow some fields, but I would want to understand the relationship, if I can.
If the images were too big, the settings would not be recorded at all. Also if we modify the settings, say for example, add a sieve filter which make the field exceeding its size. But, what can cause this disappearance, randomly, without any modification ?
User avatar (0012235)
ludovic (administrator)
2017-08-25 08:49

Data being truncates means the JSON payload isn't valid anymore, thus it is invalidated.
(0012260)
fsoyer (reporter)
2017-09-06 05:24

Hi Ludovic,
I made the change of the field types 2 weeks ago, unfortunatly one user tell us this morning that he have lost his signature and his settings.
I reopen the bug because I think I've found the source error, there may be a check or a workaroud to find for you, to avoid this case.

At 4:00AM, exactly when the phone of user concerned made an activesync connection, sogo overflows in memory. The problem is that there is absolutly no activity on the server at this time, just some terminals like this phone which make some ping requests one time a minute. So I don't understand why sogo has reached this limit, when it have no problem with it at work hours when about 40 terminals are connected and are working !!

sogo.log:

Sep 06 04:12:11 sogod [16246]: 1.2.3.4 "POST /SOGo/Microsoft-Server-ActiveSync?User=myuser&DeviceId=BC6A29MD9D3JHFP5KTA1HRLK0O&DeviceType=iPhone&Cmd=Ping HTTP/1.1" 200 13/0 10.722 - - 0
Sep 06 04:12:11 sogod [16246]: |SOGo| terminating app, vMem size limit (512 MB) has been reached (currently 513 MB)
<data>:117: element div: validity error : ID divtagdefaultwrapper already defined
<div id="divtagdefaultwrapper">
                              ^
<data>:476: element div: validity error : ID editorUserSignature already defined
<div id="editorUserSignature">
                             ^
<data>:1: element hr: validity error : ID zwchr already defined
></div></div></div></div></div></div></div></div><div> </div><hr id="zwchr"
                                                                               ^
<data>:1: element span: validity error : ID OBJ_PREFIX_DWT1198_com_zimbra_phone already defined
br>
<span class="Object" role="link" id="OBJ_PREFIX_DWT1198_com_zimbra_phone"
                                                                               ^
<data>:1: element div: validity error : ID yui_3_16_0_ym19_1_1499153001738_22463 already defined
i de juin.</span></div><div id="yui_3_16_0_ym19_1_1499153001738_22463" dir="ltr"
                                                                               ^
<data>:1: element div: validity error : ID yui_3_16_0_ym19_1_1499153001738_22463 already defined
 dir="ltr"> </div><div id="yui_3_16_0_ym19_1_1499153001738_22463" dir="ltr"
                                                                               ^
<data>:1: element div: validity error : ID yui_3_16_0_ym19_1_1493810811789_2492 already defined
1493810811789_2492">Bonjour,</div><div id="yui_3_16_0_ym19_1_1493810811789_2492"
                                                                               ^
<data>:1: element div: validity error : ID yui_3_16_0_ym19_1_1493810811789_2492 already defined
10.04.17 par mail.</div><div id="yui_3_16_0_ym19_1_1493810811789_2492" dir="ltr"
                                                                               ^
<data>:1: element div: validity error : ID yui_3_16_0_ym19_1_1493810811789_2492 already defined
mois d'avril 2014?</div><div id="yui_3_16_0_ym19_1_1493810811789_2492" dir="ltr"
                                                                               ^
<data>:1: element div: validity error : ID yui_3_16_0_ym19_1_1493810811789_2492 already defined
ltr">Cordialement.</div><div id="yui_3_16_0_ym19_1_1493810811789_2492" dir="ltr"
                                                                               ^
<data>:1: element div: validity error : ID yui_3_16_0_1_1497521737805_2599 already defined
vril et mai 2017</span></div><div id="yui_3_16_0_1_1497521737805_2599" dir="ltr"
                                                                               ^
<data>:1: element div: validity error : ID yui_3_16_0_1_1497521737805_2599 already defined
_2599" dir="ltr"> </div><div id="yui_3_16_0_1_1497521737805_2599" dir="ltr"
                                                                               ^
<data>:433: element table: validity error : ID already defined
lpadding="0" border="0" bgcolor="#EEEEEE" style="background: #FFFFFF;" dir="rtl"
                                                                               ^
Sep 06 04:12:11 sogod [16571]: <0x0x7f9032ad50e0[WOWatchDogChild]> child 16246 exited
Sep 06 04:12:12 sogod [16571]: <0x0x7f9032858eb0[WOWatchDog]> child spawned with pid 19216
Sep 06 04:12:14 sogod [19216]: <0x0x7f9032bd4120[WOHttpAdaptor]> notified the watchdog that we are ready
Sep 06 04:12:14 sogod [19216]: <0x0x7f9032897830[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Sep 06 04:12:14 sogod [19216]: <0x0x7f9032897830[SOGoCache]> Using host(s) '127.0.0.1' as server(s)
(0013073)
fsoyer (reporter)
2018-10-03 06:07

Well : I think that you can close this issue as there was no more loss of settings appends since the fields modifications and this last problem at 2017-09-06.
Thanks for all.

- Related Changesets
sogo: master 2a046557
Timestamp: 2017-08-24 16:10:30
Author: ludovic
Details ] Diff ]
(fix) increased column size of settings/defaults for MySQL (fixes 0004260)
mod - Documentation/SOGoInstallationGuide.asciidoc Diff ] File ]
mod - NEWS Diff ] File ]
add - Scripts/sql-update-3.2.10_to_3.3.0-mysql.sh Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-08-24 11:34 fsoyer New Issue
2017-08-24 15:35 ludovic Severity major => minor
2017-08-24 15:36 ludovic Note Added: 0012232
2017-08-24 15:54 ludovic Note Added: 0012233
2017-08-24 16:13 ludovic Changeset attached => sogo master 2a046557
2017-08-24 16:13 ludovic Assigned To => ludovic
2017-08-24 16:13 ludovic Resolution open => fixed
2017-08-25 03:54 fsoyer Note Added: 0012234
2017-08-25 08:49 ludovic Note Added: 0012235
2017-08-25 08:49 ludovic Status new => resolved
2017-09-06 05:24 fsoyer Note Added: 0012260
2017-09-06 05:24 fsoyer Status resolved => feedback
2017-09-06 05:24 fsoyer Resolution fixed => reopened
2017-10-17 05:50 Christian Mack Relationship added related to 0004315
2018-10-03 06:07 fsoyer Note Added: 0013073
2018-10-03 06:07 fsoyer Status feedback => assigned
2018-10-03 06:28 francis Status assigned => resolved
2018-10-03 06:28 francis Resolution reopened => fixed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker