Scalable OGo (SOGo)

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004286SOGoWeb Preferencespublic2017-09-14 06:462017-09-29 10:06
Reporterfsoyer 
Assigned Tofrancis 
PrioritynormalSeverityfeatureReproducibilityalways
StatusresolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version3.2.10 
Target VersionFixed in Version 
Summary0004286: Signature editor lakes functionalities
DescriptionSorry if this question was already submitted, I've not found it.
Can you explain to us why the signature editor isn't the same as the editor when creating an email, which has all required functionalities (except for this copy/paste window lost in the last ckeditor version ;) ) ?
Is there a roadmap for this ?

Thanks
TagsNo tags attached.
Attached Filespng file icon Capture d’écran_2017-09-29_15-47-08.png [^] (11,547 bytes) 2017-09-29 09:49

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
User avatar (0012290)
francis (administrator)
2017-09-14 09:04

You can modify the toolbar of CKEditor directly from the template:

https://github.com/inverse-inc/sogo/blob/master/UI/Templates/PreferencesUI/UIxAccountEditor.wox#L126 [^]
(0012291)
fsoyer (reporter)
2017-09-14 11:54
edited on: 2017-09-14 11:55

Aaah yes. Thank you. So for those with the same need :
after copying UIxAccountEditor.wox in /var/lib/sogo/GNUstep/Library/SOGo/Templates/PreferencesUI/, I've added some options from
https://ckeditor.com/forums/CKEditor/Complete-list-of-toolbar-items [^]

This gives to me :
'toolbar': [['Cut', 'Copy', 'Paste', 'PasteText', 'PasteFromWord', '-',
             'Bold', 'Italic', 'Font','FontSize', '-',
             'JustifyLeft', 'JustifyCenter', 'JustifyRight', 'JustifyBlock', '-',
             'TextColor', 'BGColor', '-',
             'Smiley', 'Image', 'Table', 'Link']] }"

But, I noticed that the initial "BGColor" button does not appear in the toolbar, nor the "Image" I've added.
Francis, have you an idea why ?

(0012292)
fsoyer (reporter)
2017-09-14 12:22

[EDIT]
we can delete "Cut', 'Copy', 'Paste', 'PasteText', 'PasteFromWord', '-'," as the browser doesn't allow pasting this way :(
User avatar (0012309)
francis (administrator)
2017-09-18 15:23

You should try the toolbar configurator: https://docs.ckeditor.com/#!/guide/dev_toolbar [^]

It will look like this :

ck-options="{ 'autoGrow_minHeight': 70,
         'toolbarGroups': [
        { 'name': 'basicstyles', 'groups': [ 'basicstyles' ] },
        { 'name': 'colors', 'groups': [ 'colors' ] },
        { 'name': 'paragraph', 'groups': [ 'list', 'indent', 'blocks', 'align', 'paragraph' ] },
        { 'name': 'links', 'groups': [ 'links' ] },
        { 'name': 'insert', 'groups': [ 'insert' ] },
        { 'name': 'editing', 'groups': [ 'spellchecker', 'editing' ] },
        { 'name': 'styles', 'groups': [ 'styles' ] },
        { 'name': 'mode', 'groups': [ 'mode' ] }
    ], 'removeButtons': 'Strike,Subscript,Superscript,Anchor,Format,Image,Underline,Scayt,Source,Blockquote,CreateDiv,Outdent,Indent,BulletedList,NumberedList'
}"
(0012310)
fsoyer (reporter)
2017-09-19 04:31
edited on: 2017-09-19 05:57

[EDIT]
I had some display problems using your example, but I've found that this is commenting old lines ("<!--", "-->") in the block textarea that brokes the UI !
So after *replacing* old lines from L125 by pasting your example, it's OK : we have a complete editor !

Thank you Francis.

(0012341)
fsoyer (reporter)
2017-09-29 09:16

Sorry to reopen this, my question is not exactily about the functionalities but a bug in one in particular : I found that when you want to modify the font color or font background color, if you ask "more colors" there is no "color circle" to customize it.
Maybe (certainly ?) a bug of ck-editor ? Or not ?

Thanks
User avatar (0012342)
francis (administrator)
2017-09-29 09:32

It works for me. Any JavaScript error?
(0012343)
fsoyer (reporter)
2017-09-29 09:49
edited on: 2017-09-29 09:55

[EDIT] same thing in the editor when creating a new mail.

[EDIT AGAIN] : sorry, I didn't think to open the Chrome developer tools. Yes, it seems that there are some errors :

colordialog.css Failed to load resource: the server responded with a status of 404 (Not Found)
dialog.css Failed to load resource: the server responded with a status of 404 (Not Found)
colordialog.css Failed to load resource: the server responded with a status of 404 (Not Found)

User avatar (0012344)
francis (administrator)
2017-09-29 10:06

See https://github.com/inverse-inc/sogo/commit/a31306859551672e86c34ed85f1ff6b8110f9218 [^]

- Issue History
Date Modified Username Field Change
2017-09-14 06:46 fsoyer New Issue
2017-09-14 09:04 francis Note Added: 0012290
2017-09-14 11:54 fsoyer Note Added: 0012291
2017-09-14 11:55 fsoyer Note Edited: 0012291 View Revisions
2017-09-14 12:22 fsoyer Note Added: 0012292
2017-09-18 15:23 francis Note Added: 0012309
2017-09-19 04:31 fsoyer Note Added: 0012310
2017-09-19 05:32 fsoyer Note Edited: 0012310 View Revisions
2017-09-19 05:54 fsoyer Note Edited: 0012310 View Revisions
2017-09-19 05:57 fsoyer Note Edited: 0012310 View Revisions
2017-09-19 08:22 francis Status new => resolved
2017-09-19 08:22 francis Resolution open => fixed
2017-09-19 08:22 francis Assigned To => francis
2017-09-29 09:16 fsoyer Note Added: 0012341
2017-09-29 09:16 fsoyer Status resolved => feedback
2017-09-29 09:16 fsoyer Resolution fixed => reopened
2017-09-29 09:32 francis Note Added: 0012342
2017-09-29 09:49 fsoyer File Added: Capture d’écran_2017-09-29_15-47-08.png
2017-09-29 09:49 fsoyer Note Added: 0012343
2017-09-29 09:49 fsoyer Status feedback => assigned
2017-09-29 09:51 fsoyer Note Edited: 0012343 View Revisions
2017-09-29 09:54 fsoyer Note Edited: 0012343 View Revisions
2017-09-29 09:55 fsoyer Note Edited: 0012343 View Revisions
2017-09-29 10:06 francis Note Added: 0012344
2017-09-29 10:06 francis Status assigned => resolved
2017-09-29 10:06 francis Resolution reopened => fixed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker