SOGo | BTS

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004508SOGoWeb Mailpublic2018-07-11 11:362018-08-01 11:03
ReporterASolana 
Assigned Tofrancis 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Platform[Server] LinuxOSUbuntuOS Version16.04 LTS
Product Version4.0.1 
Target VersionFixed in Version4.0.2 
Summary0004508: Webmail search text box: weird issue with default URL "unsafe:javascript:void(0)"
DescriptionWeb mail search box displays a text at magnifying glass right side.
This text always displays the selected folder name.

If a user click this text then she/he can introduce a text to look for.

Up SOGo 4.0.0 version this text had associated the URL "javascript:void(0)".

SOGo 4.0.1 version has associated the URL "unsafe:javascript:void(0)" at this text and a weird issue appears depending the web browser used when a user clicks on the text :


- Firefox 61 (Win10) and Firefox 54 (Ubuntu 14.04): web browser tries to open "unsafe:javascript:void(0)" and it loads a blank window with this error message:

"The address wasn’t understood.
Firefox doesn’t know how to open this address, because one of the following protocols (unsafe) isn’t associated with any program or is not allowed in this context.
You might need to install other software to open this address."

     
- Chrome 64.0.3282.186 (64 bits) (Ubuntu14.03): web browser displays a dialog box:
            "Do you want to open xdg-open?"

- Chrome with Windows 10: it works, no issue.


  
Users could search without issues if they only click in magnifying glass icon and then enter a text to look for.

Steps To ReproduceUse Firefox broswer or Chrome for Ubuntu 14.04, click on text message at magnifying glass right side.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0012978)
ASolana (reporter)
2018-07-25 07:35

I've installed the 4 patched files that "resolves" issue 0004508: these patched files avoid blank pages on web browsers but introduce a new issue.

New issue: the new default URL always points to the Inbox URL or first addresbook.

So, when a user tries to search in other folder, if she/he clicks on the text then she/he is redirected to Inbox folder.

The same with other addressbooks, clicking on text causes a redirection to the first addressbook.


Theh steps To Reproduce:

- Messages windows
1. Select a message folder (different from Inbox)
2. Click on text message at magnifying glass right side.
3. search focus is redirected to Inbox Folder

- Addressbooks windows
1. Select an adressbook (different from personal addressbook)
2. Click on text message at magnifying glass right side.
3. search focus is redirected to the main personal addressbook
User avatar (0012979)
francis (administrator)
2018-07-25 08:44

Have you also regenerate the compiled version of the JavaScript files?

You can also test using a nightly build.
(0012981)
ASolana (reporter)
2018-07-26 12:39

I've tested nightly build packages: the issue doesn't appears, it's solved.

Could you send me some procedure in order to regenerate the compiled version of the JavaScript files?

I'd like to patch stable 4.0.1 version because it fixes very important issues, without this patches I cannot install 4.01 in our environtment, our users would complain a lot and Help Desk team would hate me.

I tried to substitute the 4 files you fixed but that's not enough if another file needs to be regenerated, as you said.
User avatar (0012982)
francis (administrator)
2018-07-26 13:11

It's documented here:

https://sogo.nu/files/docs/SOGoDevelopersGuide.html#_building_frontend [^]
(0012989)
ASolana (reporter)
2018-08-01 11:02

I successfully regenerated .js and .js.map files following instructions documented
 in
https://sogo.nu/files/docs/SOGoDevelopersGuide.html#_building_frontend [^] [^]

I've patched our 4.0.1 SOGo server and issue is solved temporary until you release 4.0.2 version.

- Related Changesets
sogo: master 05e033cc
Timestamp: 2018-07-11 14:00:54
Author: francis
Details ] Diff ]
(js) Fix unsafe JS links

Fixes 0004508
mod - UI/Templates/ContactsUI/UIxContactFoldersView.wox Diff ] File ]
mod - UI/Templates/MailerUI/UIxMailFolderTemplate.wox Diff ] File ]
mod - UI/WebServerResources/js/Contacts/AddressBookController.js Diff ] File ]
mod - UI/WebServerResources/js/Mailer/MailboxController.js Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-07-11 11:36 ASolana New Issue
2018-07-11 14:04 francis Changeset attached => sogo master 05e033cc
2018-07-11 14:04 francis Assigned To => francis
2018-07-11 14:04 francis Resolution open => fixed
2018-07-11 14:11 francis Status new => resolved
2018-07-11 14:11 francis Fixed in Version => 4.0.2
2018-07-25 07:35 ASolana Note Added: 0012978
2018-07-25 07:35 ASolana Status resolved => feedback
2018-07-25 07:35 ASolana Resolution fixed => reopened
2018-07-25 08:44 francis Note Added: 0012979
2018-07-26 12:39 ASolana Note Added: 0012981
2018-07-26 12:39 ASolana Status feedback => assigned
2018-07-26 13:11 francis Note Added: 0012982
2018-08-01 11:02 ASolana Note Added: 0012989
2018-08-01 11:03 francis Status assigned => resolved
2018-08-01 11:03 francis Resolution reopened => fixed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker