SOGo | BTS

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004670SOGoWeb Mailpublic2019-02-04 16:382019-03-20 13:47
Reporterppjet 
Assigned Toludovic 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSLinuxOS Version4.9
Product Version4.0.5 
Target VersionFixed in Version 
Summary0004670: Webmail loads indefinitely when opening pgp signed email
DescriptionWhen trying to open a pgp signed email, the loading animation stays indefinitely, and the email content never gets displayed, (which is the most important to me).

Using Firefox Nightly 66.0a1, or Chromium 72.0.3626.81 on ArchLinux.
SOGo version: 4.0.5-2debian9.1
Steps To Reproduce- Try to open a pgp signed email

"Request Failed" error gets displayed in the top right corner, but the loading animation stays indefinitely, and the email is not displayed.
Additional InformationFeb 04 21:10:36 sogod [778]: [ERROR] <0x0x55bb0fa7c730[UIxMailRenderingContext]> found no viewer for MIME type: application/pgp-signature
2019-02-04 21:10:36.699 sogod[778:778] EXCEPTION: <NSException: 0x55bb0ea5f680> NAME:NSInvalidArgumentException REASON:-[UIxMailPartSignedViewer _processMessage]: unrecognized selector sent to instance 0x55bb0fa7a980 INFO:(null)
TagsNo tags attached.
Attached Fileszip file icon message.zip [^] (4,982 bytes) 2019-03-14 16:21
txt file icon backtrace.txt [^] (7,014 bytes) 2019-03-15 14:34 [Show Content]
txt file icon backtrace2.txt [^] (7,272 bytes) 2019-03-15 14:41 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
User avatar (0013380)
ludovic (administrator)
2019-02-18 14:38

Please attach a sample email to this ticket.
(0013448)
wimmer (reporter)
2019-03-14 16:20

I have the same problem on my debian-testing system.
I use sogo from debian respository, have updated system and have following packages installed:
  sogo 4.0.7-1
  sogo-common 4.0.7-1
  libsope1 4.0.7-1
  gnustep-base-common 1.26.0-4
  gnustep-base-runtime 1.26.0-4
  gnustep-common 2.7.0-4
  libgnustep-base1.26 1.26.0-4
  openssl 1.1.1b-1
  gpgv 2.2.12-1

This is warning from sogo.log:
Mar 14 20:12:24 sogod [22117]: [ERROR] <0x0x55ebccfa5e50[UIxMailRenderingContext]> found no viewer for MIME type: application/pkcs7-signature
2019-03-14 20:12:24.495 sogod[22117:22117] EXCEPTION: <NSException: 0x55ebccf7f7a0> NAME:NSInvalidArgumentException REASON:-[UIxMailPartSignedViewer _processMessage]: unrecognized selector sent to instance 0x55ebccfafcf0 INFO:(null)
Mar 14 20:12:24 sogod [22117]: 147.228.248.10 "GET /SOGo/so/wimmer/Mail/0/folderINBOX/10138/view HTTP/1.1" 501 0/0 0.505 - - 0

That message is in the attachment. But this problem occures on all signed messages.
Sogo 2.x shows content of same messages without problem (on debian stable system).
User avatar (0013452)
ludovic (administrator)
2019-03-15 13:53

It works for me - please produce a detailed stack trace.
(0013453)
wimmer (reporter)
2019-03-15 14:37

I tried to produce back trace.
Is it fine?
User avatar (0013454)
ludovic (administrator)
2019-03-15 14:40

I think the problem is that you're using a libsope package from Debian not from US. There's no such thing as libsope1 in our packages.
(0013456)
wimmer (reporter)
2019-03-15 15:31

Hi Ludovic,
I'm confused now ;-)
As I mentioned, I use:
- debian buster distribution
- sogo packages from their official repository
   http://ftp.debian.org/debian/ [^] buster

There is no packages for debian testing in your repository
   https://packages.inverse.ca/SOGo/ [^]
so I cannot use it.

If it means that packages from official debian repository is out of your focus,
I will try to inform their mainteners about this problem.
Maybe you can ask why I don't use your repository. I prefer offical repository in all cases, where it is possible.
I can try to compile SOGo and SOPE from your source files on my system also.
I use SOGo v2 in production and I appreciate it's stability. Now I consider migration to v4 and I look for the best way how to operate it.

Thanks for your work,
Milos
User avatar (0013457)
ludovic (administrator)
2019-03-15 15:32

We can't support / debug packages that aren't our own. Most of the time they are altered.
(0013459)
wimmer (reporter)
2019-03-16 14:40

I compiled SOGo and SOPE v4.0.7 on my debian buster system and I can confirm that contents of signed messages are displayed fine on this instalation.
So it is problem of sogo packages from debian repository https://packages.debian.org/buster/sogo [^]

- Issue History
Date Modified Username Field Change
2019-02-04 16:38 ppjet New Issue
2019-02-18 14:38 ludovic Note Added: 0013380
2019-02-18 14:39 ludovic Severity major => minor
2019-03-14 16:20 wimmer Note Added: 0013448
2019-03-14 16:21 wimmer File Added: message.zip
2019-03-15 13:53 ludovic Note Added: 0013452
2019-03-15 14:34 wimmer File Added: backtrace.txt
2019-03-15 14:37 wimmer Note Added: 0013453
2019-03-15 14:40 ludovic Note Added: 0013454
2019-03-15 14:41 wimmer File Added: backtrace2.txt
2019-03-15 15:31 wimmer Note Added: 0013456
2019-03-15 15:32 ludovic Note Added: 0013457
2019-03-16 14:40 wimmer Note Added: 0013459
2019-03-20 13:47 ludovic Status new => closed
2019-03-20 13:47 ludovic Assigned To => ludovic
2019-03-20 13:47 ludovic Resolution open => no change required


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker