View Issue Details

IDProjectCategoryView StatusLast Update
0004829SOGoPackaging (RedHat)public2020-05-14 13:49
Reporterzhb Assigned Toludovic  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version4.0.8 
Summary0004829: Build packages for RedHat / CentOS 8
Description

Dear developers,

CentOS 8 has been released days ago, and Red Hat Enterprise Linux 8 has been released 4 months ago.
Any plan to build SOGo-4 for CentOS 8?

TagsNo tags attached.

Activities

florian

florian

2019-09-26 02:25

reporter   ~0013772

I asked the same question on the mailing list and got no response.

ludovic

ludovic

2019-09-26 09:37

administrator   ~0013775

CentOS 8 was released yesterday so we'll work on packages in then next coming days.

zhb

zhb

2019-09-26 09:40

reporter   ~0013776

Dear ludovic,

Thank you very much. :)

zhb

zhb

2019-10-28 23:23

reporter   ~0013867

Dear Ludovic,

Any update? :)

zhb

zhb

2020-02-10 09:56

reporter   ~0014149

Dear Ludovic,

Any update? :)

falon

falon

2020-04-06 03:27

reporter   ~0014264

Interesting. Because I would like to evaluate this product on EL8, I made my build.
I think there are some troubles to build in EL8 because Red Hat removed the support for ObjectiveC in gcc compiler. I wonder how Inverse could address this problem.
In my environment I rebuilded gcc with ObjectiveC. I don't suppose this is the right solution, but it works. Red Hat EL8 lack of GNUSTEP too, I rebuilded it.

Finally I make my SOGo built based on a recent nightly edition and Red Hat Enterprise Linux release 8.1
If you like to try just for fun...
https://cloudsmith.io/~csi/repos/sogo

Bye
Marco

zhb

zhb

2020-04-06 08:15

reporter   ~0014265

I suppose SOGo team can rebuild gcc with objc support on their build machine, and offer GNUStep in yum repo like their CentOS 7 repo. :)

mbiernat

mbiernat

2020-04-18 10:35

reporter   ~0014278

Any update?
Centos 8 is almost a half of year after release. Is it any plan to support sogo on this distro?

ludovic

ludovic

2020-05-14 13:49

administrator   ~0014337

Nightly builds are now available for CentOS 8.

Issue History

Date Modified Username Field Change
2019-09-25 22:35 zhb New Issue
2019-09-26 02:25 florian Note Added: 0013772
2019-09-26 09:37 ludovic Note Added: 0013775
2019-09-26 09:40 zhb Note Added: 0013776
2019-10-28 15:26 ludovic Severity major => feature
2019-10-28 23:23 zhb Note Added: 0013867
2020-02-10 09:56 zhb Note Added: 0014149
2020-04-06 03:27 falon Note Added: 0014264
2020-04-06 08:15 zhb Note Added: 0014265
2020-04-18 10:35 mbiernat Note Added: 0014278
2020-05-14 13:49 ludovic Assigned To => ludovic
2020-05-14 13:49 ludovic Status new => resolved
2020-05-14 13:49 ludovic Resolution open => fixed
2020-05-14 13:49 ludovic Note Added: 0014337