View Issue Details

IDProjectCategoryView StatusLast Update
0004845SOGoWeb Calendarpublic2020-01-10 13:20
Reporterabma Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status feedbackResolutionfixed 
Product Version4.0.8 
Fixed in Version4.2.0 
Summary0004845: "Request failed" when trying to view/edit an event
Description

its possible to create events in SOGo which can't be edited or deleted any more.

Steps To Reproduce

import the attached file, try to open or delete the event

-> request failed

Additional Information

from sogo.log:

Oct 07 18:41:08 sogod [12036]: |SOGo| starting method 'GET' on uri '/SOGo/so/user/Calendar/personal/2F05-5D9B6280-2B-19A3F3C0.ics/view'
2019-10-07 18:41:08.655 sogod[12036:12036] EXCEPTION: <NSException: 0x5593c1fe1c30> NAME:NSInvalidArgumentException REASON:Tried to add nil value for key 'localizedStartTime' to dictionary INFO:{calendar = "Pers\U00F6nlicher Kalender"; id = "2F05-5D9B6280-2B-19A3F3C0.ics"; isAllDay = 0; isReadOnly = 0; pid = personal; userHasRSVP = 0; }
Oct 07 18:41:08 sogod [12036]: |SOGo| request took 0.017255 seconds to execute
Oct 07 18:41:08 sogod [12036]: 192.168.101.113 "GET /SOGo/so/user/Calendar/personal/2F05-5D9B6280-2B-19A3F3C0.ics/view HTTP/1.1" 501 0/0 0.019 - - 0

TagsNo tags attached.

Activities

abma

abma

2019-10-07 12:43

reporter  

test.ics (698 bytes)   
BEGIN:VCALENDAR
PRODID:-//Inverse inc./SOGo 4.0.8//EN
VERSION:2.0
METHOD:PUBLISH
BEGIN:VTIMEZONE
TZID:America/Montreal
X-LIC-LOCATION:America/Montreal
BEGIN:DAYLIGHT
TZOFFSETFROM:-0500
TZOFFSETTO:-0400
TZNAME:EDT
DTSTART:19700308T020000
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=2SU
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:-0400
TZOFFSETTO:-0500
TZNAME:EST
DTSTART:19701101T020000
RRULE:FREQ=YEARLY;BYMONTH=11;BYDAY=1SU
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
UID:2F05-5D9B6280-2B-19A3F3C0
SUMMARY:Test
LOCATION:Test
CLASS:PUBLIC
TRANSP:TRANSPARENT
CREATED:20191007T160848Z
DTSTAMP:20191007T160848Z
LAST-MODIFIED:20191007T160848Z
END:VEVENT
X-WR-CALNAME:test
END:VCALENDAR
test.ics (698 bytes)   
abma

abma

2019-10-07 12:45

reporter   ~0013810

can be reproduced on demo.sogo.nu, too.

Christian Mack

Christian Mack

2019-10-08 09:27

developer   ~0013817

An appointment without start and end date.
How did you create that?

abma

abma

2019-10-08 11:19

reporter   ~0013818

create new event:
title: test
and then delete all values from "from" and "to"

-> save

abma

abma

2019-10-11 08:33

reporter   ~0013830

the error still can be reproduced when importing the .ics file.

AFAIK there are still several ways to add/create such an invalid entry:

  • import .ics
  • invitation
  • via an external caldav client like thunderbird

the bad thing IMHO is, that such an entry can't be edited or changed or deleted in SOGo.

bpE52AOfxlfLyo4

bpE52AOfxlfLyo4

2019-11-23 21:50

reporter   ~0013921

Last edited: 2019-11-23 21:58

View 5 revisions

same problem here. any way to fix this ?

11:48:53.507 sogod[5671:5671] EXCEPTION: &lt;NSException: 0x55fce4cdddb0> NAME:NSInvalidArgumentException REASON:Tried to add nil value for key 'localizedStartTime' to dictionary INFO:{calendar = &quot;Personal Calendar&quot;; id = &quot;34f9ff5b-51a7-4af0-abb1-fe5afa1e50f9.ics&quot;; isAllDay = 0; isReadOnly = 0; pid = personal; userHasRSVP = 0; }

I'm on sogo 4.1.1 and this event cannot be edit or deleted.
Also because is my Personal Calendar I cannot even delete the calendar all togheter.

the bad thing IMHO is, that such an entry can't be edited or changed or deleted in SOGo.

strongly agree!

briest

briest

2020-01-10 13:20

reporter   ~0014056

I don't know if the problem is related, but I get the same error -- and I've just updated SOGo to version 4.2.0 (@shiva2.inverse 202001100157).

I have imported an .ics file to preexisting calendar and noticed, that:

  • import raised no errors, notification of many (7000+) events imported appeared
  • many events in calendar are shown as "(public event)"
  • on click, UI shows "(!) Request failed" and event does not open
  • sogo logs "2020-01-10 18:37:50.380 sogod[32342] EXCEPTION: <NSException: 0x7fd7e8bd2fa0> NAME:NSInvalidArgumentException REASON:Tried to add nil value for key 'localizedStartTime' to dictionary INFO:{calendar = astro; id = "B3BA5703-33AC-4676-B151-DEF4922B1F10.ics"; isAllDay = 0; isReadOnly = 0; pid = "4F64-5C7AFF80-513-37F72240"; userHasRSVP = 0; }"

I have updated sogo to current nightly (by apt, so with all dependencies), after update I have removed the calendar, added new one and imported .ics file again, with the same result.

The .ics is attached; can be also downloaded from https://cantonbecker.com/astronomy-calendar/astrocal.ics (page https://cantonbecker.com/astronomy-calendar/). I have used the calendar in previous years (and previous SOGo versions, since from 2.x times) and this is first time I get the problem. Maybe for 2020 it was generated in slightly different way? Sadly, I have no .ics files from past years.

astrocal.ics (319,553 bytes)

Related Changesets

sogo: master 7bc73b6f

2019-10-10 14:22:56

francis

Details Diff
(js) Fix handling of times in task/event editors

Fixes 0004497
Fixes 0004845
Affected Issues
0004497, 0004845
mod - UI/Templates/SchedulerUI/UIxAppointmentEditorTemplate.wox Diff File
mod - UI/Templates/SchedulerUI/UIxTaskEditorTemplate.wox Diff File
mod - UI/WebServerResources/js/Scheduler/ComponentController.js Diff File

sogo: master 3bb40e40

2019-11-27 17:00:28

francis

Details Diff
fix(calendar): adjust invalid dates when importing a vEvent

Fixes 0004845
Affected Issues
0004845
mod - SoObjects/Appointments/SOGoAppointmentFolder.m Diff File
mod - SoObjects/Appointments/SOGoAppointmentObject.m Diff File
mod - SoObjects/Appointments/iCalEvent+SOGo.h Diff File
mod - SoObjects/Appointments/iCalEvent+SOGo.m Diff File
mod - SoObjects/SOGo/NSCalendarDate+SOGo.h Diff File
mod - SoObjects/SOGo/NSCalendarDate+SOGo.m Diff File

sogo: master 15d7c69d

2019-12-16 10:48:26

francis

Details Diff
fix(calendar): adjust invalid dates when importing a vEvent

Fixes 0004845
Affected Issues
0004845
mod - SoObjects/Appointments/iCalEvent+SOGo.m Diff File

Issue History

Date Modified Username Field Change
2019-10-07 12:43 abma New Issue
2019-10-07 12:43 abma File Added: test.ics
2019-10-07 12:45 abma Note Added: 0013810
2019-10-08 09:27 Christian Mack Note Added: 0013817
2019-10-08 11:19 abma Note Added: 0013818
2019-10-10 14:23 francis Changeset attached => sogo master 7bc73b6f
2019-10-10 14:23 francis Assigned To => francis
2019-10-10 14:23 francis Resolution open => fixed
2019-10-10 14:24 francis Status new => resolved
2019-10-10 14:24 francis Fixed in Version => 4.1.0
2019-10-11 08:33 abma Note Added: 0013830
2019-10-11 08:33 abma Status resolved => feedback
2019-10-11 08:33 abma Resolution fixed => reopened
2019-11-23 21:50 bpE52AOfxlfLyo4 Note Added: 0013921
2019-11-23 21:51 bpE52AOfxlfLyo4 Note Edited: 0013921 View Revisions
2019-11-23 21:55 bpE52AOfxlfLyo4 Note Edited: 0013921 View Revisions
2019-11-23 21:56 bpE52AOfxlfLyo4 Note Edited: 0013921 View Revisions
2019-11-23 21:58 bpE52AOfxlfLyo4 Note Edited: 0013921 View Revisions
2019-11-27 17:03 francis Changeset attached => sogo master 3bb40e40
2019-11-27 17:03 francis Fixed in Version 4.1.0 => 4.2.0
2019-12-16 10:48 francis Changeset attached => sogo master 15d7c69d
2019-12-16 10:48 francis Resolution reopened => fixed
2020-01-10 13:20 briest File Added: astrocal.ics
2020-01-10 13:20 briest Note Added: 0014056