View Issue Details

IDProjectCategoryView StatusLast Update
0004910SOGoActiveSyncpublic2020-01-09 14:54
Reporterondrej.kolin Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
PlatformServerOSUbuntuOS Version18.04 LTS
Product Version4.1.1 
Fixed in Version4.3.0 
Summary0004910: ActiveSync is misbehaving on event series
Description

Activesync is unreliable on event series, some events are not synched, changed events can not be accepted, some get doubled. Clients are Outlook Office 365. Example of event which is misbehaving is included in attachments.

Additional Information

Our sales are unhappy and we can not guarantee the basic functionality

TagsNo tags attached.

Activities

ondrej.kolin

ondrej.kolin

2019-12-18 04:09

reporter  

raw.webmail (1,139 bytes)   
BEGIN:VCALENDAR
PRODID:-//Inverse inc./SOGo 4.1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Berlin
LAST-MODIFIED:20191023T183904Z
X-LIC-LOCATION:Europe/Berlin
BEGIN:DAYLIGHT
TZNAME:CEST
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
END:DAYLIGHT
BEGIN:STANDARD
TZNAME:CET
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
UID:040000008200E00074C5B7101A82E0080000000030FC5A63DCEED401000000000000000
010000000BEA8D0148C593548B78361077E262707
SUMMARY:Benocs Sales Stand Up
TRANSP:OPAQUE
CLASS:PUBLIC
CATEGORIES:0
DESCRIPTION: Redacted -> Zoom information
LOCATION:https://zoom.us/j/123456789
DTSTART;TZID=Europe/Berlin:20191219T100000
DTEND;TZID=Europe/Berlin:20191219T110000
ORGANIZER;CN=organizator@external.company.com;PARTSTAT=ACCEPTED:ma
ilto:organizator@external.company.com
ATTENDEE;CN=internal@benocs.com;PARTSTAT=ACCEPTED:mailto:internal@benoc
s.com
LAST-MODIFIED:20191218T084336Z
BEGIN:VALARM
TRIGGER;RELATED=START;VALUE=DURATION:-PT15M
ACTION:DISPLAY
END:VALARM
END:VEVENT
END:VCALENDAR
raw.webmail (1,139 bytes)   
Benocs_Sales_Stand_Up.ics (1,482 bytes)   
BEGIN:VCALENDAR
PRODID:-//Microsoft Corporation//Outlook 16.0 MIMEDIR//EN
VERSION:2.0
METHOD:REQUEST
X-MS-OLK-FORCEINSPECTOROPEN:TRUE
BEGIN:VTIMEZONE
TZID:W. Europe Standard Time
BEGIN:STANDARD
DTSTART:16011028T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:16010325T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
ATTENDEE;CN=internal@benocs.com;ROLE=OPT-PARTICIPANT;RSVP=TRUE:mailto:internal@benocs.com
CATEGORIES:0
CLASS:PUBLIC
CREATED:20191218T084711Z
DESCRIPTION:redacted: zoom meeting data
DTEND;TZID="W. Europe Standard Time":20191219T110000
DTSTAMP:20191218T080726Z
DTSTART;TZID="W. Europe Standard Time":20191219T100000
LAST-MODIFIED:20191218T084711Z
LOCATION:https://zoom.us/j/826142070
ORGANIZER;CN=external@external.company.com:mailto:external@external.company.com
PRIORITY:5
SEQUENCE:23
SUMMARY;LANGUAGE=de:Benocs Sales Stand Up
TRANSP:OPAQUE
UID:040000008200E00074C5B7101A82E0080000000030FC5A63DCEED401000000000000000
	010000000BEA8D0148C593548B78361077E262707
X-ALT-DESC;FMTTYPE=text/html:redacted: zoom meeting data
X-MICROSOFT-CDO-BUSYSTATUS:BUSY
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-DISALLOW-COUNTER:TRUE
X-MS-OLK-CONFTYPE:0
BEGIN:VALARM
TRIGGER:-PT15M
ACTION:DISPLAY
DESCRIPTION:Reminder
END:VALARM
END:VEVENT
END:VCALENDAR

Benocs_Sales_Stand_Up.ics (1,482 bytes)   
ondrej.kolin

ondrej.kolin

2019-12-18 05:08

reporter   ~0013987

Created in Outlook 365 and mailed to another Outlook 365 with SOGO EAS
Accepted, visible in SOGO
Not on Android

BEGIN:VCALENDAR
PRODID:-//Inverse inc./SOGo 4.1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Berlin
LAST-MODIFIED:20191023T183904Z
X-LIC-LOCATION:Europe/Berlin
BEGIN:DAYLIGHT
TZNAME:CEST
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
END:DAYLIGHT
BEGIN:STANDARD
TZNAME:CET
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
UID:040000008200E00074C5B7101A82E00800000000F036C75729B4D501000000000000000
010000000F1D37AC4DB81A14687799772953F5114
SUMMARY:Benocs GmbH - Blah
oup
TRANSP:OPAQUE
CLASS:PUBLIC
DESCRIPTION: description
LOCATION:https://zoom.us/j/123456789
DTSTART;TZID=Europe/Berlin:20200109T093000
DTEND;TZID=Europe/Berlin:20200109T103000
LAST-MODIFIED:20191216T155311Z
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER;VALUE=DURATION:-PT15M
END:VALARM
ORGANIZER;PARTSTAT=ACCEPTED;CN=internal@benocs.com:mailto:internal@beno
cs.com
ATTENDEE;PARTSTAT=ACCEPTED;CN=:mailto:external@external...
ATTENDEE;CN=anothertwo@anothercompany.com;PARTSTAT=NEEDS-ACTION;RSVP=TRUE:
mailto:anothertwo@anothercompany.com
ATTENDEE;PARTSTAT=ACCEPTED;CN=anotherone:mailto:anotherone@another.company.com
om.de
END:VEVENT
END:VCALENDAR

ondrej.kolin

ondrej.kolin

2019-12-18 05:11

reporter  

configuration.sogo.conf (2,599 bytes)   
{  
  NGImap4DisableIMAP4Pooling = "NO";
  NGImap4ConnectionStringSeparator = ".";
  OCSFolderInfoURL = "mysql://sogo:password@xxx.xxx.xxx.210:3306/sogo/sogo_folder_info";
  OCSStoreURL = "mysql://sogo:password@xxx.xxx.xxx.210:3306/sogo/sogo_store";
  OCSAclURL = "mysql://sogo:password@xxx.xxx.xxx.210:3306/sogo/sogo_acl";
  OCSCacheFolderURL = "mysql://sogo:password@xxx.xxx.xxx.210:3306/sogo/sogo_cache_folder";
  OCSSessionsFolderURL = "mysql://sogo:password@xxx.xxx.xxx.210:3306/sogo/sogo_sessions_folder";
  SOGoACLsSendEMailNpotifications = YES;
  SOGoAppointmentSendEMailNotifications = YES;
  SOGoAuthenticationMethod = LDAP;
  SOGoEnablePublicAccess = YES;
  SOGoFirstDayOfWeek = 1;
  SOGoFirstWeekOfYear = First4DayWeek;
  SOGoTimeZone = Europe/Berlin;
  SOGoFoldersSendEMailNotifications = YES;
  SOGoSharedFolderName = "shared Folders";
  SOGoOtherUsersFolderName = "Other Users";
  SOGoVacationEnabled = YES;
  SOGoIMAPServer = "imap://xxx.xxx.xxx.40:143/?tls=YES";
  SOGoLanguage = "";
  SOGoMailDomain = "benocs.com";
  SOGoMailMessageCheck = "every_minute";
  SOGoMailingMechanism = smtp;
  SOGoPasswordChangeEnabled = YES;
  SOGoProfileURL = "mysql://sogo:password@xxx.xxx.xxx.210:3306/sogo/sogo_user_profile";
  SOGoSMTPServer = "xxx.xxx.xxx.40";
  SOGoSieveScriptsEnabled = YES;
  SOGoForwardEnabled = YES;
  SOGoSieveServer = "sieve://xxx.xxx.xxx.40:4190/?tls=YES";
  SOGoSuperUsernames = (
      okolin,
      ipoese
  );
  WOUseRelativeURLs = YES;
  SOGoUserSources = (
    {
    CNFieldName = cn;
    IDFieldName = cn;
    IMAPHostFieldName = gosaMailServer;
    IMAPLoginFieldName = uid;
    UIDFieldName = uid;
    baseDN = "dc=mail,dc=xeropath,dc=com";
    bindDN = "cn=admin,dc=mail,dc=xeropath,dc=com";
    bindFields = (uid, mail);
    bindPassword = "NXn23dTa(8(X";
    canAuthenticate = YES;
    displayName = "Other users";
    hostname = "ldaps://server.benocs.com:636";
    id = public;
    type = ldap;
    isAddressBook = YES;
    MailFieldNames = (mail, gosaMailAlternateAddress);
    userPasswordAlgorithm = ssha;
    filter = "(objectClass!='gosaUserTemplate')";
    }
    );
  MySQL4Encoding = "utf8mb4";
  // MySQL4DebugEnabled = YES
  // Tweak options:
	WOWatchDogRequestTimeout = 10;
	SOGoMaximumPingInterval = 354;
	SOGoMaximumSyncInterval = 354;
	SOGoInternalSyncInterval = 30;
	SOGoMaximumSyncResponseSize = 512;
	SOGoMaximumSyncWindowSize = 256;
	SOGoEASDebugEnabled = YES;
	WOWatchDogRequestTimeout = 60;
  // Tweaks 20191213
        SOGoMaximumSyncResponseSize = 4096; 
	SOGoMaximumSyncWindowSize = 1023;
  // Tweaks 20191218
	SxVMemLimit = 768;
}

configuration.sogo.conf (2,599 bytes)   
tfu

tfu

2019-12-18 11:31

reporter   ~0013990

I saved above ics-text into a file and imported it into sogo. After sync it shows on android, but not in OL (connected via EAS).
But you mentioned that it is not visible in android. What exactly is your problem?
Can you please attach the problem ics as a file?

ondrej.kolin

ondrej.kolin

2019-12-18 11:33

reporter   ~0013991

The problem is, that some events are not visible in Android. Usually events, that have time changed, but not ID changed.

tfu

tfu

2019-12-18 12:24

reporter   ~0013992

What brand is your android device? Samsung?
Please describe step by step how the problem can be reproduced.

tfu

tfu

2019-12-19 04:35

reporter   ~0013999

In addition to above I'd like to understand whether the original (unmodified event) also contains something like this:
ATTENDEE;PARTSTAT=ACCEPTED;CN=:mailto:external@external... ->>>>> CN=:mailto:XXXX >>>> i.e. no text between CN= and :mailto

tfu

tfu

2019-12-19 14:02

reporter   ~0014002

Upcoming nightly contains a fix regading missing attendee name. To make sure that events are re-synced re-create the sync profile on the client.

ondrej.kolin

ondrej.kolin

2019-12-20 05:24

reporter   ~0014003

Hey, we have traced the problem a bit more.

External user creates an event with time (f.e. 10:00)
He sends an invitation to our sogo user.
Our sogo user uses the Outlook feature to offer a different date/time.
The external user accepts the change and sends a new invitation.
Our sogo user accept the NEW invitation and in his Calendar appears the event with OLD datetime

Btw.
"re-create the sync profile" means manage-eas?

tfu

tfu

2019-12-20 08:05

reporter   ~0014005

Tried what you described above and it worked for me. After last step I see that event with new proposed time in calendar.

ondrej.kolin

ondrej.kolin

2020-01-06 05:00

reporter   ~0014018

Happy new year,

@tfu, have you tested it using Outlook clients? I will test it on a new fresh instance in that case.

tfu

tfu

2020-01-06 08:24

reporter   ~0014021

Yep, I tested with Outlook.

ondrej.kolin

ondrej.kolin

2020-01-09 02:51

reporter   ~0014038

I was able to reproduce it in outlook once, but not on the second time, when I was making screenshot. I will try to reproduce it again and report it here.

Related Changesets

sogo: master 4ed2c727

2019-12-19 09:03:17

ludovic

Details Diff
fix(eas): make sure there is always an attendee name (fixes 0004910) Affected Issues
0004910
mod - ActiveSync/iCalEvent+ActiveSync.m Diff File

Issue History

Date Modified Username Field Change
2019-12-18 04:09 ondrej.kolin New Issue
2019-12-18 04:09 ondrej.kolin File Added: raw.webmail
2019-12-18 04:09 ondrej.kolin File Added: Benocs_Sales_Stand_Up.ics
2019-12-18 05:08 ondrej.kolin Note Added: 0013987
2019-12-18 05:11 ondrej.kolin File Added: configuration.sogo.conf
2019-12-18 11:31 tfu Note Added: 0013990
2019-12-18 11:33 ondrej.kolin Note Added: 0013991
2019-12-18 12:24 tfu Note Added: 0013992
2019-12-19 04:35 tfu Note Added: 0013999
2019-12-19 09:08 ludovic Changeset attached => sogo master 4ed2c727
2019-12-19 09:08 ludovic Assigned To => ludovic
2019-12-19 09:08 ludovic Resolution open => fixed
2019-12-19 14:02 tfu Note Added: 0014002
2019-12-20 05:24 ondrej.kolin Note Added: 0014003
2019-12-20 08:05 tfu Note Added: 0014005
2020-01-06 05:00 ondrej.kolin Note Added: 0014018
2020-01-06 08:24 tfu Note Added: 0014021
2020-01-09 02:51 ondrej.kolin Note Added: 0014038
2020-01-09 14:54 francis Status new => resolved
2020-01-09 14:54 francis Fixed in Version => 4.3.0