View Issue Details

IDProjectCategoryView StatusLast Update
0004927SOGoActiveSyncpublic2020-01-09 14:53
Reporterondrej.kolin Assigned Toludovic  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformServerOSUbuntuOS Version18.04 LTS
Product Version4.2.0 
Fixed in Version4.3.0 
Summary0004927: Nonvalid XML answer generated
Description

Sometimes a wrong XML answer is generated. Can't really reproduce it. All those misformatted answers look like:

<?xml version="1.0" encoding="utf-8"?><!DOCTYPE ActiveSync PUBLIC "-//MICROSOFT//DTD ActiveSync//EN" "http://www.microsoft.com/&quot;>&lt;Sync xmlns="AirSync:"><Collections><Status>13</Status></Sync>

(Missing </Collections> tag)

In logs I can see something like:
Jan 08 10:36:45 sogod [19327]: <0x0x560d8272e200[SOGoActiveSyncDispatcher]> EAS - Discard response {FolderSyncKey = "activesync_company_com_1942_23ab6a7e_0"; PingCachedFolders = ("mail%2Fee293c324575615baa51000048ac2651", "vevent%2Fpersonal", "vcard%2Fpersonal", "mail%2F90a38300157b1b5ced1a000048ac2651", "mail%2F71b26138cfad625bd975000048ac2651", "vtodo%2Fpersonal", "mail%2F19c1910991673c5cbd57000048ac2651", "mail%2F727273071f911b5c3c12000048ac2651", "mail%2FJunk", "mail%2Fb5ff021736673c5c6557000048ac2651", "mail%2Fshared", "vevent%2Fstaff-calendar_personal", "vtodo%2Fstaff-calendar_personal"); PingHeartbeatInterval = 354; PingRequest = 19331; SyncRequest = 1578476202; "SyncRequest+mail/19c1910991673c5cbd57000048ac2651" = 19331; "SyncRequest+mail/71b26138cfad625bd975000048ac2651" = 19331; "SyncRequest+mail/727273071f911b5c3c12000048ac2651" = 19331; "SyncRequest+mail/90a38300157b1b5ced1a000048ac2651" = 19331; "SyncRequest+mail/Junk" = 19331; "SyncRequest+mail/b5ff021736673c5c6557000048ac2651" = 19331; "SyncRequest+mail/ee293c324575615baa51000048ac2651" = 19331; "SyncRequest+mail/shared" = 19331; "SyncRequest+vcard/personal" = 19331; "SyncRequest+vevent/personal" = 19331; "SyncRequest+vevent/user_personal" = 19331; "SyncRequest+vtodo/personal" = 19331; "SyncRequest+vtodo/user_personal" = 19331; }
Jan 08 10:36:45 sogod [19327]: [ERROR] <0x0x560d80708020[NSDataMalloc]> xml2wbxmlFromContent: failed: Parsing of XML Document Failed

Jan 08 10:36:45 sogod [19327]: [ERROR] <0x0x560d80708020[NSDataMalloc]> Original data written to: /tmp/activesync_benocs_com_4b7f_23c51684_1.data

Additional Information

This looks like it is not affecting the functionality of the server at all.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

sogo: master 047a98b8

2020-01-08 13:04:42

ludovic

Details Diff
fix(eas): avoid generating broken XML ouput (fixes 0004927) Affected Issues
0004927
mod - ActiveSync/SOGoActiveSyncDispatcher+Sync.m Diff File

Issue History

Date Modified Username Field Change
2020-01-08 04:48 ondrej.kolin New Issue
2020-01-08 13:08 ludovic Changeset attached => sogo master 047a98b8
2020-01-08 13:08 ludovic Assigned To => ludovic
2020-01-08 13:08 ludovic Resolution open => fixed
2020-01-09 14:53 francis Status new => resolved
2020-01-09 14:53 francis Fixed in Version => 4.3.0