View Issue Details

IDProjectCategoryView StatusLast Update
0005022SOGoPackaging (RedHat)public2020-06-23 12:56
Reporterjvb Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version4.3.2 
Summary0005022: CentOS 8: libmysqlclient.so.21 required when using MariaDB?
Description

New to SOGo, I was waiting long to test it on CentOS 8. Trying the new nightly packages.

I am using 10.4.13-MariaDB
When I setup sogo using mysql, it does correctly populate the database, because it can not connect due to missing libs.

May 15 15:52:48 sogod [1233594]: [ERROR] <0x0x5626167b4580[WOWatchDog]> an exception occured in runloop <InvalidAdaptorBundleException: 0x5626167d6380> NAME:InvalidAdaptorBundleException REASON:Cannot load adaptor bundle 'MySQL' INFO:(null)
Error (objc-load):libmysqlclient.so.21: cannot open shared object file: No such file or directory
Error (objc-load):libmysqlclient.so.21: cannot open shared object file: No such file or directory

libmysqlclient.so.21 is provided by mysql-libs:
dnf whatprovides /usr/lib64/mysql/libmysqlclient.so.21
mysql-libs-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 : The shared libraries required for MySQL clients
Repo : AppStream
Matched from:
Filename : /usr/lib64/mysql/libmysqlclient.so.21

Which I do not have, because I am using MariaDB which provides:
rpm -ql MariaDB-compat
/usr/lib/.build-id
/usr/lib/.build-id/b9
/usr/lib/.build-id/b9/6e60b38b77e80cef7840ad411cfb0607d09a01
/usr/lib64/libmysqlclient.so.15
/usr/lib64/libmysqlclient.so.15.0.0
/usr/lib64/libmysqlclient.so.16
/usr/lib64/libmysqlclient.so.16.0.0
/usr/lib64/libmysqlclient.so.18
/usr/lib64/libmysqlclient.so.18.0.0
/usr/lib64/libmysqlclient_r.so.15
/usr/lib64/libmysqlclient_r.so.15.0.0
/usr/lib64/libmysqlclient_r.so.16
/usr/lib64/libmysqlclient_r.so.16.0.0
/usr/lib64/libmysqlclient_r.so.18
/usr/lib64/libmysqlclient_r.so.18.0.0

Is there a way the packages can work with official latest MariaDB?

Steps To Reproduce

1) use nigtly repo
2) dnf install sogo
3) dnf install sope49-gdl1-mysql
4) install latest mariaDB && create sogo db/user
4) configure sogo.conf to use mysql
SOGoProfileURL = "mysql://sogo:PWD@127.0.0.1:3306/sogo/sogo_user_profile";
OCSFolderInfoURL = "mysql://sogo:PWD@127.0.0.1:3306/sogo/sogo_folder_info";
OCSSessionsFolderURL = "mysql://sogo:PWD@127.0.0.1:3306/sogo/sogo_sessions_folder";
OCSEMailAlarmsFolderURL = "mysql://sogo:PWD@127.0.0.1:3306/sogo/sogo_alarms_folder";
OCSStoreURL = "mysql://sogo:PWD@127.0.0.1:3306/sogo/sogo_store";
OCSAclURL = "mysql://sogo:PWD@127.0.0.1:3306/sogo/sogo_acl";
OCSCacheFolderURL = "mysql://sogo:PWD@127.0.0.1:3306/sogo/sogo_cache_folder";
MySQL4Encoding = utf8mb4;

5) try to use sogo webUI

Tagscentos, libmysqlclient, MariaDB

Activities

ludovic

ludovic

2020-06-23 12:56

administrator   ~0014422

Should be now fixed - try the upcoming nightly build.

Issue History

Date Modified Username Field Change
2020-05-15 10:03 jvb New Issue
2020-05-15 10:03 jvb Tag Attached: centos
2020-05-15 10:03 jvb Tag Attached: libmysqlclient
2020-05-15 10:03 jvb Tag Attached: MariaDB
2020-06-23 12:56 ludovic Assigned To => ludovic
2020-06-23 12:56 ludovic Status new => resolved
2020-06-23 12:56 ludovic Resolution open => fixed
2020-06-23 12:56 ludovic Note Added: 0014422