View Issue Details

IDProjectCategoryView StatusLast Update
0005025SOGoWeb Mailpublic2020-05-18 15:26
Reporterjan Assigned Toludovic  
PrioritynormalSeverityblockReproducibilityhave not tried
Status resolvedResolutionno change required 
OSLinuxOS VersionDebian 9 stretch 
Product Version4.3.2 
Summary0005025: Sending Mail failed sogod[18657:18657] EXCEPTION: <NSException: 0x559ab6bd6440>
Description

Hello,
After using SOGo for over a year now sending Mails failed. I didn't change anything on the configuration.
My Sogo Server works together with ISPConfig.

When i try to send an E-Mail i will get the Message on red Request Failed.

IMAP Debug Logging enabled

S[0x559ab6c3cf10]: 11 OK [APPENDUID 1536484085 115] Append completed (0.016 + 0.040 + 0.006 secs).
C[0x559ab6bc4870]: 12 logout
S[0x559ab6c3cf10]: BYE Logging out
S[0x559ab6c5dd30]:
OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE STARTTLS AUTH=PLAIN AUTH=LOGIN] Dovecot ready.
C[0x559ab6ba9470]: 1 login "jan@XXXXXXXXX.de" "XXXXXXXX"
S[0x559ab6c5dd30]: 1 OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE SORT SORT=DISPLAY THREAD=REFERENCES THREAD=REFS THREAD=ORDEREDSUBJECT MULTIAPPEND URL-PARTIAL CATENATE UNSELECT CHILDREN NAMESPACE UIDPLUS LIST-EXTENDED I18NLEVEL=1 CONDSTORE QRESYNC ESEARCH ESORT SEARCHRES WITHIN CONTEXT=SEARCH LIST-STATUS BINARY MOVE QUOTA] Logged in
C[0x559ab6ba9470]: 2 capability
S[0x559ab6c5dd30]: CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE SORT SORT=DISPLAY THREAD=REFERENCES THREAD=REFS THREAD=ORDEREDSUBJECT MULTIAPPEND URL-PARTIAL CATENATE UNSELECT CHILDREN NAMESPACE UIDPLUS LIST-EXTENDED I18NLEVEL=1 CONDSTORE QRESYNC ESEARCH ESORT SEARCHRES WITHIN CONTEXT=SEARCH LIST-STATUS BINARY MOVE QUOTA
S[0x559ab6c5dd30]: 2 OK Capability completed (0.000 + 0.040 + 0.039 secs).
C[0x559ab6ba9470]: 3 ID ("x-originating-ip" "217.224.73.130")
S[0x559ab6c5dd30]:
ID ("name" "Dovecot")
S[0x559ab6c5dd30]: 3 OK ID completed (0.001 + 0.040 + 0.039 secs).
C[0x559ab6ba9470]: 4 namespace
S[0x559ab6c5dd30]: NAMESPACE (("" ".")) NIL NIL
S[0x559ab6c5dd30]: 4 OK Namespace completed (0.000 + 0.040 + 0.039 secs).
C[0x559ab6ba9470]: 5 LIST "" ""
S[0x559ab6c5dd30]:
LIST (\Noselect) "." ""
S[0x559ab6c5dd30]: 5 OK List completed (0.001 + 0.040 + 0.039 secs).
C[0x559ab6ba9470]: 6 select "Drafts"
S[0x559ab6c5dd30]: FLAGS (\Answered \Flagged \Deleted \Seen \Draft)
S[0x559ab6c5dd30]:
OK [PERMANENTFLAGS (\Answered \Flagged \Deleted \Seen \Draft *)] Flags permitted.
S[0x559ab6c5dd30]: 1 EXISTS
S[0x559ab6c5dd30]:
1 RECENT
S[0x559ab6c5dd30]: OK [UNSEEN 1] First unseen.
S[0x559ab6c5dd30]:
OK [UIDVALIDITY 1536484085] UIDs valid
S[0x559ab6May 18 12:15:15 sogod [18657]: 217.224.73.130 "GET /SOGo/so/jan@XXXX.de/Mail/0/folderDrafts/newDraft1589796914-1/edit HTTP/1.1" 200 1196/0 0.298 2292 47% -16K
May 18 12:15:18 sogod [18657]: 217.224.73.130 "GET /SOGo/so/jan@XXXX.de/Contacts/allContactSearch?search=jan HTTP/1.1" 200 640/0 0.021 2755 76% 80K
May 18 12:15:20 sogod [18657]: 217.224.73.130 "GET /SOGo/so/jan@XXXX.de/Contacts/allContactSearch?search=jan@ HTTP/1.1" 200 783/0 0.006 - - 0
May 18 12:15:26 sogod [18657]: [WARN] <0x0x559ab6e5ef40[SOGoUserDefaults]> expected an NSString for 'SOGoMailComposeFontSize' (ignored)
2020-05-18 12:15:26.715 sogod[18657:18657] EXCEPTION: <NSException: 0x559ab6bd6440> NAME:NSInvalidArgumentException REASON:NGSmtpClient(class) does not recognize clientWithURL: INFO:(null)
May 18 12:15:26 sogod [18657]: 217.224.73.130 "POST /SOGo/so/jan@XXXXX.de/Mail/0/folderDrafts/newDraft1589796914-1/send HTTP/1.1" 501 0/2243 0.212 - - 124K

I also checked if there where any updates.

SOGo is 4.3.2

Tagsmail

Relationships

has duplicate 0005028 resolvedfrancis Webmail doesn't work - Request Failed - when i try to send a message 

Activities

jan

jan

2020-05-18 06:24

reporter  

jan

jan

2020-05-18 06:27

reporter   ~0014348

Sendig Mails from Roundcube is working

ludovic

ludovic

2020-05-18 06:28

administrator   ~0014349

Upgrade SOPE.

jan

jan

2020-05-18 06:50

reporter   ~0014350

SOPE is latest Version
sope4.9-gdl1-mysql for debian stretch

ludovic

ludovic

2020-05-18 06:55

administrator   ~0014351

You need to update ALL SOPE packages.

jan

jan

2020-05-18 07:19

reporter   ~0014352

Could it be possible that something with the SOPE Package went wrong?
libsope-appserver4.9 ist schon die neueste Version (4.9.r1664.SHORTDATE)

the_nic

the_nic

2020-05-18 07:26

reporter   ~0014353

The smtpclient is in libsope-mime4.9. Make sure you really have the latest version from the nightlies in there: https://packages.inverse.ca/SOGo/nightly/4/debian/pool/stretch/s/sope/libsope-mime4.9_4.9.r1664.20200514_amd64.deb (but upgrade all of them)

the_nic

the_nic

2020-05-18 07:30

reporter   ~0014354

Maybe because the naming of the package hasnt changed - but the content did (look at the ame, its referring to 2020-05-14), apt does not want to upgrade these packages.

jan

jan

2020-05-18 08:26

reporter   ~0014355

Downgrading to the old version libsope-mime4.9_4.9.r1664.20200514_amd64.deb did the trick. Thx

Issue History

Date Modified Username Field Change
2020-05-18 06:24 jan New Issue
2020-05-18 06:24 jan Tag Attached: mail
2020-05-18 06:24 jan File Added: Anmerkung 2020-05-18 121556.png
2020-05-18 06:27 jan Note Added: 0014348
2020-05-18 06:28 ludovic Assigned To => ludovic
2020-05-18 06:28 ludovic Status new => closed
2020-05-18 06:28 ludovic Resolution open => no change required
2020-05-18 06:28 ludovic Note Added: 0014349
2020-05-18 06:50 jan Status closed => feedback
2020-05-18 06:50 jan Resolution no change required => reopened
2020-05-18 06:50 jan Note Added: 0014350
2020-05-18 06:55 ludovic Note Added: 0014351
2020-05-18 07:19 jan Note Added: 0014352
2020-05-18 07:19 jan Status feedback => assigned
2020-05-18 07:26 the_nic Note Added: 0014353
2020-05-18 07:30 the_nic Note Added: 0014354
2020-05-18 08:26 jan Note Added: 0014355
2020-05-18 08:43 francis Status assigned => resolved
2020-05-18 08:43 francis Resolution reopened => no change required
2020-05-18 15:26 francis Relationship added has duplicate 0005028