View Issue Details

IDProjectCategoryView StatusLast Update
0005045SOGoGUIpublic2020-07-24 15:27
Reporterharmvdwal Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version4.3.2 
Fixed in Version5.0.0 
Summary0005045: List of calendar items puts all-day events in the wrong day when nog in daylight saving time
Description

A sorted list of calendar items puts items in the wrong day when daylight savings is over.
This year that would be 25th of october, which is when all all-day events seem to shift to the day before, even though their source says otherwise.

Steps To Reproduce

Create an all-day event after the 25th of october 2020 and before 28th of march 2021.
Show all future appointments.
See the appointment has shifted to the day before.

Additional Information

This does not happen in the calendar grid

TagsNo tags attached.

Activities

Christian Mack

Christian Mack

2020-07-24 07:49

developer   ~0014575

Which timezone ist this?

harmvdwal

harmvdwal

2020-07-24 08:52

reporter   ~0014576

GMT+1 to GMT+2 (daylight saving).
The date of switching daylight saving, all day events also switch to the wrong date

francis

francis

2020-07-24 11:15

administrator   ~0014577

Can you reproduce the problem on demo.sogo.nu?

harmvdwal

harmvdwal

2020-07-24 11:38

reporter   ~0014578

I created an event on the 9th of november.
If you open the calendar and show all future events you'll see it appear on the 8th of november

harmvdwal

harmvdwal

2020-07-24 11:39

reporter   ~0014579

I'm not 100% sure it's because of daylight saving though.

harmvdwal

harmvdwal

2020-07-24 11:40

reporter   ~0014580

harmvdwal

harmvdwal

2020-07-24 11:50

reporter   ~0014581

Only on "All future events" this happens.

Related Changesets

sogo: master 5e1a5924

2020-07-24 15:24:40

francis

Details Diff
fix(calendar): uncondtionally adjust all-day events dates

Fixes 0005045
Affected Issues
0005045
mod - SoObjects/Appointments/SOGoAppointmentFolder.m Diff File

Issue History

Date Modified Username Field Change
2020-06-08 09:20 harmvdwal New Issue
2020-07-24 07:49 Christian Mack Note Added: 0014575
2020-07-24 08:52 harmvdwal Note Added: 0014576
2020-07-24 11:15 francis Note Added: 0014577
2020-07-24 11:38 harmvdwal Note Added: 0014578
2020-07-24 11:39 harmvdwal Note Added: 0014579
2020-07-24 11:40 harmvdwal Note Added: 0014580
2020-07-24 11:40 harmvdwal File Added: Schermafbeelding 2020-07-24 om 17.39.40.png
2020-07-24 11:50 harmvdwal Note Added: 0014581
2020-07-24 15:27 francis Changeset attached => sogo master 5e1a5924
2020-07-24 15:27 francis Assigned To => francis
2020-07-24 15:27 francis Resolution open => fixed
2020-07-24 15:27 francis Status new => resolved
2020-07-24 15:27 francis Fixed in Version => 5.0.0