View Issue Details

IDProjectCategoryView StatusLast Update
0005056SOGoWeb Mailpublic2020-07-13 10:18
Reportercedric.archambeau Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformServerOSUbuntu LinuxOS Version18.04 LTS
Product Versionnightly master 
Fixed in Version5.0.0 
Summary0005056: Forward on auxiliary account use primary account
Description

Related to https://sogo.nu/bugs/view.php?id=5054 but not the same experience : problem only on forward

When using auxiliary accounts, if we forward an email, sender used is the primary one (should be the account we are in).
We can delete it, and in the list, the good account is shown.

Steps To Reproduce

Forward an email from auxiliary account.
Sender is the primary account

Additional Information

Mails configured in SOGo sources LDAP
We don't use new multi-identity feature.

TagsNo tags attached.

Relationships

duplicate of 0005054 resolvedfrancis AutoReply with Mail identities no longer select an identity as reply (neither the default nor the addressed one) 

Related Changesets

sogo: master c99170b9

2020-07-06 12:17:11

francis

Details Diff
fix(mail): pick proper "from" address when replying/forwarding

Fixes 0005056
Affected Issues
0005056
mod - SoObjects/Mailer/SOGoDraftObject.m Diff File
mod - SoObjects/Mailer/SOGoMailAccount.h Diff File
mod - SoObjects/Mailer/SOGoMailAccount.m Diff File
mod - SoObjects/Mailer/SOGoMailForward.m Diff File
mod - UI/MailerUI/UIxMailAccountActions.m Diff File
mod - UI/MailerUI/UIxMailEditor.m Diff File
mod - UI/WebServerResources/js/Mailer/Message.service.js Diff File

Issue History

Date Modified Username Field Change
2020-06-24 09:09 cedric.archambeau New Issue
2020-06-24 09:09 cedric.archambeau File Added: sogo_forward_from_auxiliary_account_step1.png
2020-06-24 09:09 cedric.archambeau File Added: sogo_forward_from_auxiliary_account_step2.png
2020-07-03 18:20 francis Assigned To => francis
2020-07-03 18:20 francis Status new => assigned
2020-07-06 12:44 francis Changeset attached => sogo master c99170b9
2020-07-06 12:44 francis Resolution open => fixed
2020-07-06 12:47 francis Status assigned => resolved
2020-07-06 12:47 francis Fixed in Version => 5.0.0
2020-07-13 10:18 francis Relationship added duplicate of 0005054