View Issue Details

IDProjectCategoryView StatusLast Update
0005072SOGoWeb Mailpublic2020-07-13 12:33
Reporterabma Assigned Tofrancis  
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly master 
Fixed in Versionnightly master 
Summary0005072: no identity selected when replying to mail and always open mail composer "in a popup window" is set
Description

with 4.3.2.20200707-1 there is no identity selected when replying to an email: it has to be selected manually.

Steps To Reproduce

login to demo.sogo.nu

go to preferences -> mail, set open mail composer to "in a popup window", save.

go to inbox, select a mail, click reply:

no identity selected

Additional Information

this bug introduced after updating to 4.3.2.20200707-1

TagsNo tags attached.

Activities

abma

abma

2020-07-09 03:32

reporter   ~0014477

the issue is not fixed: now an identity is selected, but when clicking on send, the error

"Method Not Allowed" is shown.

After deselecting the preselected identity and selecting the same identity, sending works.

Related Changesets

sogo: master f7e7612e

2020-07-07 14:53:11

francis

Details Diff
fix(mail(js)): pick proper "from" address when replying/forwarding

Fixes 0005072
Affected Issues
0005072
mod - UI/WebServerResources/js/Mailer/MessageEditorController.js Diff File

sogo: master 8f3738bf

2020-07-13 12:29:35

francis

Details Diff
fix(mail(js)): pick proper "from" address when replying/forwarding

Fixes 0005072
Affected Issues
0005072
mod - UI/WebServerResources/js/Mailer/MessageEditorController.js Diff File

Issue History

Date Modified Username Field Change
2020-07-07 10:44 abma New Issue
2020-07-07 14:54 francis Changeset attached => sogo master f7e7612e
2020-07-07 14:54 francis Assigned To => francis
2020-07-07 14:54 francis Resolution open => fixed
2020-07-07 14:54 francis Status new => resolved
2020-07-07 14:54 francis Fixed in Version => 5.0.0
2020-07-07 14:54 francis Product Version 4.3.2 => nightly master
2020-07-07 14:54 francis Fixed in Version 5.0.0 => nightly master
2020-07-09 03:32 abma Status resolved => feedback
2020-07-09 03:32 abma Resolution fixed => reopened
2020-07-09 03:32 abma Note Added: 0014477
2020-07-13 12:33 francis Changeset attached => sogo master 8f3738bf
2020-07-13 12:33 francis Resolution reopened => fixed
2020-07-13 12:33 francis Status feedback => resolved