View Issue Details

IDProjectCategoryView StatusLast Update
0005091SOGoWeb Mailpublic2020-07-24 12:11
Reporternomagic Assigned Tofrancis  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Version4.3.2 
Fixed in Version5.0.0 
Summary0005091: Nightly still breaking multi-accounts
Description

I updated today (nightly) and was very pleased by the newly added support for multiple identities, that's fantastic.

However, I lost the multi-account feature. It's here, but creating one or modifying a previously existing one (now showing blank in the mail section) results in the later disappearing completely from Sogo as soon as I leave the preference > Mail > IMAP Accounts

I found a previous issue ( https://sogo.nu/bugs/view.php?id=5062 ) but it has been closed, and for me the issue is still there, even if it gets removed quietly.

I checked the DB, my 'AuxiliaryMailAccounts' is desperately empty ('[]').

Steps To Reproduce

Modify an existing IMAP Account after upgrading to 4.3.2 nightly or create a new one, it will not be saved, or even be removed from the DB, without Sogo showing any error.

Tagsmulti-accounts

Activities

There are no notes attached to this issue.

Related Changesets

sogo: master 528b7581

2020-07-24 12:08:49

francis

Details Diff
fix(preferences): accept an "id" key for mail accounts

Fixes 0005091
Affected Issues
0005091
mod - UI/PreferencesUI/UIxPreferences.m Diff File

Issue History

Date Modified Username Field Change
2020-07-24 06:46 nomagic New Issue
2020-07-24 06:46 nomagic Tag Attached: multi-accounts
2020-07-24 12:10 francis Changeset attached => sogo master 528b7581
2020-07-24 12:10 francis Assigned To => francis
2020-07-24 12:10 francis Resolution open => fixed
2020-07-24 12:11 francis Status new => resolved
2020-07-24 12:11 francis Fixed in Version => 5.0.0