SOGo | BTS

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000710SOGoWeb Calendarpublic2010-07-27 09:382010-08-18 09:44
Reporterib_pl 
Assigned Tofrancis 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version1.3.0 
Target Version1.3.1Fixed in Version1.3.1 
Summary0000710: IE8 layout issues
DescriptionHello,

Atteched please find issues we found in latest sogo web interface (checked on SOGo demo site today).

Problem 001a might be connected with selectbox length - if it's short then IE8 breaks layout (see 001b - it's ok there).

002 and 003 - problems with diplaying UTF-8 strings in these places.

Issues are IE specific - no such problems in FF or Chrome.

Regards,
Pawel
TagsNo tags attached.
Attached Fileszip file icon screenshots.zip [^] (31,846 bytes) 2010-07-27 09:38
zip file icon SOGo-1.3.0-utf8-fix.patch.zip [^] (449 bytes) 2010-08-16 07:24

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0001258)
wimmer (reporter)
2010-07-29 04:22

When I use IE8, I see that problem on sogo-demo.inverse.ca too.
The reason is bad interpretation/setting of encoding in IE8.
When I look to Page->Encoding, I see "Windows-1250". It is wrong, it must be UTF-8. Firefox uses UTF-8 and has no problem.

On my own server I solved it by setting:
 AddDefaultCharset UTF-8
into
 apache2/conf.d/charset file

This forces IE8 to use UTF-8 charset ;-)
User avatar (0001262)
francis (administrator)
2010-07-29 11:39

The display glitch is fixed in revision 86a177d4a05deda193edc7d9e0fedca89758cadd.

I think I can close the ticket since the other encoding errors could be solved by fixing your Apache configuration.
(0001303)
ib_pl (reporter)
2010-08-16 07:23

Hello,

Thank you for information.

I'm not sure that forcing users to reconfigure their servers is the best solution. I my opinion SOGo should rather set charset meta properly.

Does SOGo use encoding other than UTF-8? If only UTF-8 is used - please verify and consider appling atteched patch (SOGo-1.3.0-utf8-fix.patch) - it should add

<meta http-equiv="content-type" content="text/html; charset=UTF-8" />

to every SOGo html page output (works well in our system).

Thank you,
Pawel
User avatar (0001309)
ludovic (administrator)
2010-08-18 09:44

Please reopen an other bug for this.

What you propose is a quick hack but if things are to be handled by SOGo/SOPE instead of Apache, it should be handled by SOPE since it's SOPE that already handle the WOMessageUTF8 preference.

- Issue History
Date Modified Username Field Change
2010-07-27 09:38 ib_pl New Issue
2010-07-27 09:38 ib_pl File Added: screenshots.zip
2010-07-27 13:19 ludovic Target Version => 1.3.1
2010-07-29 04:22 wimmer Note Added: 0001258
2010-07-29 11:39 francis Note Added: 0001262
2010-07-29 11:39 francis Status new => resolved
2010-07-29 11:39 francis Fixed in Version => 1.3.1
2010-07-29 11:39 francis Resolution open => fixed
2010-07-29 11:39 francis Assigned To => francis
2010-08-16 07:23 ib_pl Note Added: 0001303
2010-08-16 07:23 ib_pl Status resolved => feedback
2010-08-16 07:23 ib_pl Resolution fixed => reopened
2010-08-16 07:24 ib_pl File Added: SOGo-1.3.0-utf8-fix.patch.zip
2010-08-18 09:44 ludovic Note Added: 0001309
2010-08-18 09:44 ludovic Status feedback => closed
2010-08-18 09:44 ludovic Resolution reopened => won't fix


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker