View Issue Details

IDProjectCategoryView StatusLast Update
0000802SOGoBackend Calendarpublic2010-12-06 10:12
Reporterwimmer Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version1.3.2Fixed in Version1.3.2 
Summary0000802: setting of default roles to access a calendar
DescriptionI'm using this setting for default roles to access a calendar:

sogod SOGoCalendarDefaultRoles '(
    PublicDAndTViewer
)'

Users cannot set permissions of their calendars to "none",
SOGo overchanges this value with default "PublicDAndTViewer" in all cases.
Users can set permissions to 'higher' values (Modifier) without problem.

TagsNo tags attached.

Activities

ludovic

ludovic

2010-09-13 21:54

administrator   ~0001438

The problem is due to the fact that when we specify None, all rights are removed, including the rows in the rights "table".

When SOGo looks in the rights "table" for the particular calendar and no rights are given, it defaults to what is provided in SOGoCalendarDefaultRoles preference.

Perhaps we should store "None" for the various class.
francis

francis

2010-09-17 16:37

administrator   ~0001475

Fixed in revision b8fdd2b522b773a7377d9617f8dce71cb94ce7db
francis

francis

2010-12-06 10:03

administrator   ~0001928

Not yet fixed.
francis

francis

2010-12-06 10:11

administrator   ~0001929

Don't ask. It's Monday morning.

Issue History

Date Modified Username Field Change
2010-09-02 12:12 wimmer New Issue
2010-09-02 12:31 ludovic Target Version => 1.3.2
2010-09-13 21:54 ludovic Note Added: 0001438
2010-09-16 09:00 ludovic Target Version 1.3.2 => 1.3.3
2010-09-17 16:37 francis Note Added: 0001475
2010-09-17 16:37 francis Status new => resolved
2010-09-17 16:37 francis Fixed in Version => 1.3.2
2010-09-17 16:37 francis Resolution open => fixed
2010-09-17 16:37 francis Assigned To => francis
2010-12-06 10:03 francis Note Added: 0001928
2010-12-06 10:03 francis Status resolved => feedback
2010-12-06 10:03 francis Resolution fixed => reopened
2010-12-06 10:03 francis Target Version 1.3.3 => 1.3.5
2010-12-06 10:11 francis Note Added: 0001929
2010-12-06 10:11 francis Status feedback => closed
2010-12-06 10:11 francis Resolution reopened => fixed
2010-12-06 10:12 francis Target Version 1.3.5 => 1.3.2